Bit Comet screwing up my internet?
January 26, 2007 2:31 AM   Subscribe

When I start Bit Comet dowloads (of legal material only) I notice it works momentarily, but then messes up the internet connection for all other apps. Logmein goes offline, MSN Msg logs out, and i can access websites intermittently... What gives?

I should point out that bit comet has worked for me fine before... just done a clean reinstall. The only thing I can think of is some kind of conflict with Logmein? Which is the only thing I didn't have before. I have also changed the random listening port. My housemate uses torrents on a Mac Mini with no problems which makes me think its not the routing set up.

I have latest version, XP. Any tips would be gratefully recieved.
posted by tomw to Computers & Internet (14 answers total) 2 users marked this as a favorite
 
Your upload rate limit is probably set too high for your Internet connection to handle nicely. Is your housemate running torrents at the same time you are? If so, you both need to lower your upload rates.
posted by flabdablet at 3:33 AM on January 26, 2007


You may need to adjust your router's port redirection settings
posted by chillmost at 3:39 AM on January 26, 2007


Less vague...I mean adjust the router's port redirection settings so that it works on both computers. It may currently only be set up to forward to the mac mini's IP. I did this once but I cannot find the link and I'm supposed to look like I am working right now.
posted by chillmost at 3:42 AM on January 26, 2007


There is no port forwarding. Upload limit isn't an issue, its set fairly low on both comps...
posted by tomw at 4:47 AM on January 26, 2007


Try it with the other machine offline, and see if the problem goes away. (I suspect the upload rates are set too high).
posted by Leon at 4:52 AM on January 26, 2007


Might be the Windows XP SP2 half-open connection limit, too.
posted by flabdablet at 5:13 AM on January 26, 2007 [1 favorite]


Bit Comet is a whore. You should switch to something more friendly to the internet, like uTorrent.
posted by cellphone at 6:25 AM on January 26, 2007 [1 favorite]


Youre probably opening far too many connections than either your router, computer, or modem can handle. Im not familiar with that BT client but you should be able to specify a max amount of connections. Use half of the current value and see if that helps. Do this on both computers.

You can also update both the firmware on the router and network driver (wired? wireless?) on the computer. Also if you are doing this over wireless, switch to wired and see if it helps.
posted by damn dirty ape at 6:47 AM on January 26, 2007


After your re-install did you install the latest network driver for your computer or are you going with the microsoft default? Make sure to get the newest one off the manufacturers website.
posted by damn dirty ape at 6:48 AM on January 26, 2007


See here.
posted by Zed_Lopez at 6:48 AM on January 26, 2007


Second uTorrent (which is lightweight) or Azureus (which is not). Both are easier on internet connections that the evil Bit Comet.
posted by The Bellman at 7:03 AM on January 26, 2007


Ya, just switch clients. It's not worth debugging. Azureus has proven itself to me on both the Mac and Windows. It also has automatic bandwidth shaping based on round trip times. I agree Azureus is not lightweight but that doesn't mean much in the era of multi gigahertz multi core machines.
posted by chairface at 7:50 AM on January 26, 2007


As someone who runs a fairly popular BT related help site, I will advise AGAINST the "just switch clients" answer that so many are so happy to give. Of course, I always advocate the learning process that goes along with problem solving.

3 possible issues here:

1. Like someone said, it's a max connections @ the router issue. Most routers can't handle over 200 concurrent connections. Turn DOWN the number of connections in the client, there is NO NEED for it to be over 100. Often denoted by network-wide blinking out on random internet applications. (Like...you can't pull up a webpage, but you CAN get in MSN.) The only GOOD fix for this is a hard reset of the router, meaning hold the reset button until the lights go off and then back on steadily.

2. Optionally, if it's an SP2 computer, you're running into the max-connections-locally issue. Google "lvllord patch" and it'll fix that. SP doesn't like more than 10 connections.

3. You are simply timing out those applications because of the latency caused by sucking so much data through such a small hole. Throttle your download speed @ the client if you wish to run other applications.
posted by TomMelee at 8:09 AM on January 26, 2007 [3 favorites]


TomM : Global connections was set to AUTO. So I've put it to 100. Will also check my flatmate's settings on BT when I get back. Seems like the most likely answer though - thanks.
posted by tomw at 8:46 AM on January 26, 2007


« Older I'm tilted!   |   Why is my new laptop buzzing? And why do dogs have... Newer »
This thread is closed to new comments.