Cisco non-root bridges not connecting using 802.11A.
January 11, 2007 9:46 AM   Subscribe

Our small non-profit is trying to deploy some Cisco wireless bridges between buildings. Will a non-root bridge's radio show up as disabled if it cannot associate with the root-bridge? Scenario: Root Bridge on main building (Cisco 1240AG) - using 802.11A 2 satelite buildings have Cisco 1240AG Bridges in non-root mode using 802.11A Radio status on root-bridge is up Radio status on two non-root bridges is down Using 802.11A patch antennas and RP-TNC LMR-400 cabling to antennas from AP. No run is over 50'. All antennas are line-of-sight and longest antenna to antenna run is 500'.
posted by bloodniece to Computers & Internet (8 answers total) 2 users marked this as a favorite
 
In case you are wondering, we don't have the budget to pay a Cisco engineer to help us. The bridges were a donation. I'm a technical user but am nowhere near trying to be a Cisco tech.
posted by bloodniece at 9:51 AM on January 11, 2007


Assuming by root and non-root, you're talking about the device Role and not STP, make sure on the two non-roots, you have "no shutdown" and the ssid setting in the dot11radio interface configuration.
posted by jma at 11:03 AM on January 11, 2007


ok, I ran ssh into the bridges and ran:
config terminal
int Dot11radio1
no shutdown
exit
exit
wr

Still nothing. SSID is set too.
posted by bloodniece at 11:20 AM on January 11, 2007


What's under dot11radio0?
posted by jma at 11:54 AM on January 11, 2007


Scratch that. Can you post the config of the root and one of the non-roots, with any sensitive info (ssid, maybe) obfuscated?
posted by jma at 11:56 AM on January 11, 2007


Also, email in profile if you'd like to take it off AskMe
posted by jma at 12:05 PM on January 11, 2007


Power cycled both non-roots and one came up and linked at 18Mbps. Nice.

The other is still down.

Show Run:

WL-RNTL#show run
Building configuration...

Current configuration : 4347 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname WL-RNTL
!
!
ip subnet-zero
ip domain name companyname.org
!
!
aaa new-model
!
!
aaa group server radius rad_eap
!
aaa group server radius rad_mac
!
aaa group server radius rad_acct
!
aaa group server radius rad_admin
!
aaa group server tacacs+ tac_admin
!
aaa group server radius rad_pmip
!
aaa group server radius dummy
!
aaa authentication login default local
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authorization exec default local
aaa accounting network acct_methods start-stop group rad_acct
aaa session-id common
!
dot11 ssid mysecretssid
authentication open mac-address mac_methods
infrastructure-ssid optional
!
dot11 network-map
power inline negotiation prestandard source
!
crypto pki trustpoint TP-self-signed-3904102212
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3904102212
revocation-check none
rsakeypair TP-self-signed-3904102212
!
!
crypto ca certificate chain TP-self-signed-3904102212
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33393034 31303232 3132301E 170D3032 30333031 30323431
33315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 39303431
30323231 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100AA81 55E13FD4 009CFE3A 9126816E F1576696 65E239C7 5BDC33E3 1E8D4B04
F920D5BA 3B494839 43F86BE1 CDBE3853 E664B00E 81C63639 72F35E29 1735D9A9
29246EBD 5EFC11E5 39E764CF 44B5944B B914413A 36F9C31C 15FC89E5 C236181B
4454B49E E41558AF 8C4C2291 71D7F6B9 AAC7CDD2 D69E0C6B 009962A8 A2E5EF46
755F0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 14167636 22979622 BF861669 982CDA96 8359DEB3 3A301D06
03551D0E 04160414 16763622 979622BF 86166998 2CDA9683 59DEB33A 300D0609
2A864886 F70D0101 04050003 81810057 88CABAA2 86A6FB8A 8B081E29 7B915B10
449C368C 2127AF4A 785EE3FF A90272A0 410BA0CF 4CC1AAEC 70ECE8CA 0F74AA74
A773A4C6 C124DEA2 CAC57227 798101B7 E79A998B 37610111 D911EEAA 7C7071B3
D8C1C761 AFDE4157 2D9C51CD 50B88880 2558ECB1 E6BF577E B12A10CC A3C1B7D4
1B8EDA40 B714E148 11AE62A9 FCD78F
quit
dot1x credentials MyCompanyName-Primary
username myusername
password 7 000000000000000
!
username ans privilege 15 password 7 100000000000000000
username 0019a9d03760 password 7 0000000000000
username 0019a9d03760 autocommand exit
username derek privilege 15 password 7 0000000000000000
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
!
encryption key 1 size 128bit 7 EE0D647D22683069634D3069A024
encryption key 2 size 128bit 7 CB79105B12230A5C3251397E7128
encryption key 3 size 128bit 7 B139776A3C6E5C3C6390262B5962 transmit-key
encryption key 4 size 128bit 7 063F735DC042324F4424607E423D
encryption mode wep mandatory
!
ssid mysecretssid
!
speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
station-role non-root bridge
antenna receive right
antenna transmit right
bridge-group 1
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
hold-queue 160 in
!
interface BVI1
ip address 192.168.0.26 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.0.1
no ip http server
ip http authentication aaa
ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
!
radius-server attribute 32 include-in-access-req format %h
radius-server vsa send accounting
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
!
end
posted by bloodniece at 12:50 PM on January 11, 2007


Thanks for all the help guys. I found a CCNE dude, in town, who was feeling generous. He is going to spot-check my cabling and antenna placement and go over the configs with me. Might be time for me to start studying for the CCNA.
posted by bloodniece at 11:41 AM on January 12, 2007


« Older are there accepted standards for web design?   |   Writer's Market: What's the big hairy deal? Newer »
This thread is closed to new comments.