I'm a .NET mess
December 3, 2006 2:14 PM   Subscribe

Why do I get 404s when trying to download anything from Microsoft.com?

I recently tried to install an application that needed Microsoft's .NET framework. When I went to MS's site to download the .NET framework, the download simply wouldn't work -- instead, I just got a 404 page. I tried both Firefox and IE 7 and got 404s with both browsers. Then I tried downloading other things on MS's site to test -- and when I get to the download page (for example, this one) I always get a 404. This has persisted for weeks, and no one else I've talked to has experienced problems. What might be causing the issue on my end?
posted by arielmeadow to Computers & Internet (12 answers total) 1 user marked this as a favorite
 
Since Microsoft's error page does not include the text "404," you may be experiencing problems with an upstream proxy. Why don't you paste the error message you get here?
posted by grouse at 2:53 PM on December 3, 2006


Those links worked for me.
posted by Steven C. Den Beste at 2:57 PM on December 3, 2006


This sure sounds like a problem you will likely want to troubleshoot, but anyway if you just need the .NET framework, it is included as a redistributable on quite a few installation cd-roms. For example, several MS applications such as SQL Server 2005 include it. It's also on the Windows Server 2003 R2 CD, if that happens to be available.
posted by Herr Fahrstuhl at 3:19 PM on December 3, 2006


Are you running PeerGuardian, or similar?
posted by Mwongozi at 3:29 PM on December 3, 2006


Grouse, you're right. What I'm actually getting are "Server not found" messages in both IE and Firefox.

And Mwongozi, no PeerGuardian nor anything like it.
posted by arielmeadow at 9:32 PM on December 3, 2006


ariel,

Please do this: Start, Run, "cmd.exe". Hit enter. A command prompt will pop up. Now, type "ping download.microsoft.com". You should see something like this:

C:\Documents and Settings\dan>ping download.microsoft.com

Pinging a767.ms.akamai.net [204.2.208.57] with 32 bytes of data:

Reply from 204.2.208.57: bytes=32 time=72ms TTL=56
Reply from 204.2.208.57: bytes=32 time=77ms TTL=56
Reply from 204.2.208.57: bytes=32 time=84ms TTL=56
Reply from 204.2.208.57: bytes=32 time=73ms TTL=56

If you see "127.0.0.1" instead of an Akamai link, type:

del c:\windows\system32\drivers\etc\hosts

...and/or run anti-spyware software, such as Lavasoft's AdAware. Now, if you get a different sort of error -- perhaps it locks up, and then says it's unable to resolve that name, maybe there's a problem with your upstream name resolver. You can fix this by:

1) Go to Control Panel
2) Go to Network Connections
3) Go to the network adapter you're using to connect to the Internet. This is either your Ethernet adapter or your Wireless adapter -- in doubt, go to the one that says "Connected" under it.
4) Right click. Select "properties".
5) Find, under "this connection uses the following items", Internet Protocol(TCP/IP). Select it, and click "Properties"
6) Select "Use the following DNS Server addresses", and enter a preferred DNS server of 4.2.2.1, and an alternate of 209.131.97.97.
7) Hit OK. See if things are working OK now.

Good luck!
posted by effugas at 10:24 PM on December 3, 2006


effugas, this is so bizarre -- when I ping download.microsoft.com, I simply get an error saying Ping request could not find host download.microsoft.com. Please check the name and try again.
posted by arielmeadow at 10:53 PM on December 3, 2006


Maybe talk to your ISP? Are you using a different DNS server from your ISP's DNS server? Try effugas' second set of instructions to change your DNS server and see if that helps.
posted by antifuse at 1:31 AM on December 4, 2006


Try pinging 204.2.208.57, and see if that connects?
posted by Boobus Tuber at 3:18 AM on December 4, 2006


Apparently, you're not the only one who's had this problem.
posted by IronLizard at 4:06 AM on December 4, 2006


I had this exact problem on the school network. Problem was our MTU packets were too large and MS rejected them. Or something like that. I fixed it by downloading Dr TCP and changing the MaxMTU value to 1300 or less (Windows default is 1500).
posted by jmd82 at 6:33 AM on December 4, 2006


Aha! It appears that this may be an issue with my ISP (comcast). I'll pursue it with them. Thanks for the tips, everyone!
posted by arielmeadow at 2:18 PM on December 4, 2006


« Older What is this purple nylon sleeve-thingy with...   |   Are portfolio listings sites worth the money? Newer »
This thread is closed to new comments.