Outlook-->IE, Thunderbird-->Firefox?
October 26, 2006 9:47 AM   Subscribe

How can I force Thunderbird to open links in Firefox when IE is set as my default browser?

At work I run Thunderbird for my personal email and Outlook for work email. Most of the links I get in Outlook are for things that require IE, such as links to MS Project web and a few other IE based apps that use Active X and for any number of reasons won't run in Firefox.

I use Thunderbird for personal mail as well as my RSS feeds. So when I click on a link, say to an AskMe thread, I want it to open in Firefox.

Is there any way to do this? I tried the "IE Tab" Firefox extension but the IE-only pages still wouldn't work.

Please don't turn this into a which-browser-is-better thread. I've installed IE7 and even though it has tabs I'd still prefer to use Firefox when I can.
posted by bondcliff to Computers & Internet (5 answers total)
What you should do is get the IE View extension for Firefox, which allows you to mark certain sites so Firefox will always open them in IE (that is, not in a Firefox tab, but in the actual IE browser).

Then, set Firefox to be your default browser. Problem solved.
posted by cerebus19 at 10:08 AM on October 26, 2006

I tried the "IE Tab" Firefox extension but the IE-only pages still wouldn't work.

What IE Tab does is start up an instance of Internet Explorer inside your Firefox tab. There's no way that any website can tell that you're using Firefox with IETab; it's indistinguishable from using IE. In what way did they 'not work'? Did they display incorrectly, or fail to load?
posted by matthewr at 10:10 AM on October 26, 2006

It's not particularly well documented, but I just managed to do the opposite on my desktop as a test, so Thunderbird opened links in IE.

Go to Tools, Options, Advanced and click on Config Editor. In the list of preferences, toggle off network.protocol-handler.external-default so you'll be prompted for what to do with links. Return to mail, click on an html link, browse to Firefox.exe and check the box so you won't be asked again. Do the same for htm files.

Once you've done that, take a look at the mimeTypes.rdf file in your profile directory...you see some new info in there listing the new protocol handler. You should now be able to switch back and forth just by editing that file.

I'm not sure if there'll be any negative impact from this change so you may want to create a secondary TBird profile and try it there first.
posted by JaredSeth at 10:55 AM on October 26, 2006

Response by poster: I know that's what should happen, matthewr, but it doesn't seem to work. When trying to open anything in Project Web Access under IE tab it gives me the error:

"Invalid Browser Version. IE 5.0 or later is needed to use Project Web Access."

I have the Project server URL in the IE Tab filter to always open in IE Tab. Sharepoint works fine, PWA does not.
posted by bondcliff at 11:00 AM on October 26, 2006

Response by poster: Guh. I didn't have the slash at the end of the URL in the IE Tab filter. I put that in and it seems to be working now. Stupid, stupid me.

Can I mark my own answer as best?

Thanks all!
posted by bondcliff at 11:15 AM on October 26, 2006

« Older Lets have your recipes for low-calorie protein...   |   To buy a great turkey Newer »
This thread is closed to new comments.