How do I get rid of Photoshop's transparent program background?
August 17, 2006 9:33 PM   Subscribe

PhotoshopFilter: Is there a way to get rid of the "transparent" program background in Adobe Photoshop for Mac?

I have Adobe Photoshop CS2 9.0 on my Mac. There's no gray background to the program when I'm working inside of Photoshop... so that I can still see my desktop. This is distracting, and I frequently accidentally click "out" of Photoshop by clicking on this background space when working with an image. Is there a way to bring that gray background back, so that Photoshop takes over my entire screen?
posted by inactivist to Computers & Internet (22 answers total) 1 user marked this as a favorite
 
Press F.
posted by deadfather at 9:39 PM on August 17, 2006


One possible solution doesn't put in a grey background, but it does disable the Finder — and by extension, it stops the effect of accidental "click-outs" if you only have Photoshop running.
posted by Blazecock Pileon at 9:40 PM on August 17, 2006


I think deadfather's fot it - pressing f will cycle you through three different window modes. Two full-screen and the usual window view.
posted by lekvar at 9:44 PM on August 17, 2006


F (up to 3 times to cycle.)

Tab to get rid of your palettes.

Completely full screen work.
posted by filmgeek at 9:53 PM on August 17, 2006


Little-known trick: when you've pressed F to work in Full Screen mode, you can re-color the default gray to any color you want by Shift-Clicking with the Paint Bucket tool in that area. I always change mine to Black.
posted by robbie01 at 9:55 PM on August 17, 2006


The F trick is useful, but it's not what I want. I frequently work with multple images open in photoshop, so I want to be able to see all of them (over that grey program background) at the same time, not just one.
posted by inactivist at 10:13 PM on August 17, 2006


It is what you want. Try cycling through a couple of F presses. You're just in the wrong mode.
posted by deadfather at 10:17 PM on August 17, 2006


At the first F press, it takes one of the open images (whichever I am working on) and maximizes it to full screen over a grey background. At the 2nd F press, it takes the same image and does the same thing, except the background is black. At the 3rd F press, it takes me back to where I started.

At no point, even though 2 images are opened in Photoshop, am I able to see both images and drag them around the screen.
posted by inactivist at 10:20 PM on August 17, 2006


Oops. You're right. (On a PC at the moment.)
posted by deadfather at 10:24 PM on August 17, 2006


i've never found an actual answer for this, though i personally consider it a plus - i feel confined by the silly background box in windows PS. perhaps if you just cleaned up your desktop and changed the wallpaper color to grey it would serve the same purpose?
posted by ab3 at 10:59 PM on August 17, 2006


I think you might like DooDim. It lets you darken or complete hide all apps except whatever is currently in the foreground.
posted by nathan_teske at 11:44 PM on August 17, 2006


1. Download Tinkertool.
2. Run TinkerTool, and under 'Finder', tick 'Disable Desktop features'.
3. Click the 'Relaunch Finder' button in the bottom right.

(With this setting enabled, the Finder won't be activated when you click on the desktop.)

4. Open System Preferences and set your desktop background to grey or black or whatever you want.
5. Hide the Dock.
6. Open Photoshop.
7. Hit Command-Option-H (or go to Photoshop > Hide Others) to hide everything except for Photoshop.

Once you've got this set up, in the future you'll obviously only need to do steps 6 and 7.
posted by chrismear at 12:14 AM on August 18, 2006


Chrismear and Nathan_teske... thanks for your solutions, I find them both useful. DooDim is an easy and handy application that I will be using from now on. Unfortunately, it doesn't prevent me from clicking out of Photoshop on accident. This happens rather frequently... mutlitple times per session. I use a Wacom pen tablet and work quickly, so my precision often goes out the window and I end up clicking out of Photoshop several times in a row sometimes.

The thing I don't like about Tinkertool is that it disables Desktop use for all times... not just when in Photoshop. I want to save items to it, and be able to click on it to get to it like I always do... just not while in Photoshop.

Unfortunately neither one of them does what I want 100%, but they do help. If there's yet another solution out there, I'm glad to hear it.
posted by inactivist at 1:07 AM on August 18, 2006


>I end up clicking out of Photoshop several times in a row sometimes.

Why not just work in a big document window that takes up the whole of the window? Just because you're working on a picture X pixels by Y doesn't mean you can't be working on a canvas twice that size. Crop when you're finished.
posted by AmbroseChapel at 2:43 AM on August 18, 2006


Get a PC? It sounds like you need that grey background.
posted by Brandon Blatcher at 4:01 AM on August 18, 2006


Use "F" to get you in fullscreen mode, then use Window-->Arrange-->Tile to make both of your working documents appear at the same time, press Tab to temporarily hide your tool palettes, stretch your open documents to cover the entire desktop, press Tab again to get your palettes back. If you like, Use Window-->Arrange-->Match Zoom and Location to make your open documents of equal size.

Choose Window-->Workspace-->Save Workspace so you don't have to re-do this everytime you open Photoshop.
posted by LuckySeven~ at 5:12 AM on August 18, 2006


So...you can't simply grab the lower-right corner of the image frame and drag the frame out beyond the image? When I do that, I get as much gray surrounding the image as I need. Works this way in CS1, anyway.
posted by Thorzdad at 5:31 AM on August 18, 2006


Ok.... since for some reason my desire for this grey background is inconceivable, I'll lay it all out:

I'm a digital artist who usually works with MULTIPLE images at the same time, referencing, sampling, mixing, comparing, etc etc. Working with one image in fullscreen mode is therefore not an option since I rarely only work with one image at a time. I use a tablet and work quickly, inevitably clicking outside of an image's boundaries multiple times per session and it builds up to be a bit of an annoyance I was hoping could be avoided.

My desktop is cluttered because I click-and-drag images from Firefox to my desktop to save them... I collect images for inspiration on my drive, almost every day, and the quickest way to do it is just to drag it to the desktop hence cluttering it up. And anyway, DooDim solves that issue anyway. It's the click-out problem that's left now.

I own a Mac, I love my Mac, I plan to keep it. I used to use Photoshop on a PC and simply miss that feature and was wondering if it could be recovered, is all.

Thanks for your suggestions, using DooDim and TinkerTool in conjunction will have to do.
posted by inactivist at 1:46 PM on August 18, 2006


I'm new to OS X also, inactivist, and often work in Photoshop the same way that you do. Did you try my suggestion? It works. :)
posted by LuckySeven~ at 4:15 PM on August 18, 2006


Have you considered using Exposé for checking multiple images at once? F10 will only show you the ones from the frontmost App.
posted by KimG at 5:04 AM on August 19, 2006


Expose doesn't work within Photoshop, which is what I need.

LuckySeven, thanks for the tip, I knew of that feature before but I never thought of using it towards this particular problem of mine. It may help somtimes.

The only gripe with that is that I work with large images so the grey box around an image when stretche dout doesn't do much unless I'm zoomed out (which is only sometimes). I'm always clicking up to the border (there's no grey box cause it's zoomed in and up to the border, know what I mean?) and sometimes going over. Thoughts?
posted by inactivist at 7:01 PM on August 19, 2006


I think I get what you mean. It's annoying, that's for sure. I use a Wacom tablet also, but On my PC, I use two monitors and usually have my most zoomed in "working on" image on monitor 1 and the other with the "sample images" and tool palettes on monitor 2. At this point, I still prefer working on Photoshop on my PC due to this very issue. Still, some things you might want to try to make it a little less annoying:

Try clicking on the zoom tool and then turning off the "zoom resizes windows" option.

Try option-->command-->plus till you're overly zoomed in, then command-->minus until you get to the size you want.

If you're having trouble moving around to work on your images when they're really zoomed in, you know you can use the hand tool (keyboard shortcut: h or hold down the spacebar to turn any tool temporarily into the hand tool) to move around more easily.

If you do accidently click out onto the desktop, you can command + tab to cycle back to Photoshop.

If you use broad strokes on your Wacom and that's causing you to frequently click outside of your working area, you can try mapping a portion of your tablet to represent the entire monitor screen. I have it set this way for Photoshop and Firefox (it saves wear and tear on my arm and wrist too). The upper left quadrant of the tablet represents the entire length and width of my monitor; this way I'm able to rest my wrist on the right side of the tablet and still draw. It takes a few hours getting used to drawing with smaller strokes and arm movements, but ultimately, I find it's worth it.

If I can think of anything else, I'll let you know.
posted by LuckySeven~ at 12:57 AM on August 20, 2006


« Older Shotguns and PZMs for the Stage?   |   Metal deodorant bars for garlic/onion? Newer »
This thread is closed to new comments.