Help consistently auto joining home wifi network
July 23, 2022 6:18 AM   Subscribe

How do I get my phone to consistently automatically join my home wifi network when I return home (like it’s supposed to per the setting)?

I recently got a new iPhone 13 Pro. It will not reliably automatically join my home wifi when I return from being out (e.g. at a store). If I toggle wifi off then on on my phone it will quickly automatically join my home network.

We have a new router and my phone is set to automatically join my home WiFi network. I have tried restarting the phone and modem, setting my phone to forget the network and reloading it, and resetting the phone’s network settings.

If it matters, I rarely join wifi networks outside my home. I only do so occasionally when I’m visiting family. I do not connect to public wifi networks or an office network.

Any idea on why this happens and how to fix it? I’m not technically inclined so please explain this like I’m five. Thanks, and sorry for the boring, pedestrian question. But I’m desperate.
posted by smokyjoe to Computers & Internet (16 answers total) 1 user marked this as a favorite
So in this situation does it join a mobile network instead, like a 5G or LTE? If so, one fix, which is not a total fix, might be to just turn Cellular off in your settings, so it has to look for a WiFi to join. Then if you are out and about you just need to turn cellular on to use your phone.

But also, make sure (again) that your home network is set up to auto-join. On your phone, when connected to home WiFi, in settings, tap WiFi, then the name of your network. On the next screen at top is the Auto-Join option. Make sure it is set to green.
posted by beagle at 6:39 AM on July 23, 2022

You’ve done all the right things, so this is odd. Given that you have tried “forget this network”, I’m assuming that for the network in question you have “auto-join” turned on for the network in question?

How about “Private wi-fi address”, is that on or off?

What’s your behaviour when you leave the house? I presume the phone is previously connected to wifi; you leave it connected and don’t touch any wifi-related controls while out; you return (probably with phone locked in your pocket), and the phone doesn’t reconnect to the network (quickly? ever?).

Does it work with other known networks, or is this a problem common to all wifi networks you have previously joined? (Commercial hotspots you have to log into don’t count for this - just home networks of family or friends).

If it works with other networks, the finger points at your router / network settings for this network. If it does not, then it’s something about your phone’s settings.

Do other phones, if there are any, auto-join as expected on your network?

This is a shot in the dark, as I don’t know that wrong settings here would cause problems like you’ve seen, but: do you have location services enabled? (Settings > Privacy > Location Services). There are also individual toggles at the end of the list there under the sub-menu System Services, one of which is Networking & Wireless. These are On for me.
posted by breakfast burrito at 6:49 AM on July 23, 2022

Best answer: In the wifi setting space, for this network, is the slider for auto-join on? Is this router a common name it might have a duplicate of?
posted by nickggully at 6:50 AM on July 23, 2022

I apologize for a basic question but how — precisely — are you discovering that it hasn’t joined your home network?
posted by Tell Me No Lies at 7:51 AM on July 23, 2022

Response by poster: To answer a few questions, instead of joining wifi, it stays on cellular. My home network is definitely set to auto-join. The name of my home network is customized and uncommon so I don’t think that’s the issue. "Private wifi Address” is on. Breakfast burrito, you surmised my behavior while out (phone connected to wifi; i leave and don’t touch wifi controls; return with phone locked and it doesn’t reconnect (ever, as opposed to taking a long time to do so). I’m not sure whether I have this problem with other networks, because I very rarely join other networks so haven’t had enough experience to know. Also, that location services>system services toggle is also on for me.

Tell Me No Lies - usually i notice when i try to watch a video and it’s stalling—i then look for the wifi symbol in the upper right corner of the phone and see it’s off, so I go and toggle wifi on and off, and it will then auto-join.
posted by smokyjoe at 8:59 AM on July 23, 2022 [1 favorite]

My 13 Pro hasn’t wanted to rejoin my home Wi-Fi this past week - sometimes it evens pops up a dialog asking for the password again. It sounds like this could indicate low signal strength but I never had a problem so I’m not sure.

After removing and re-adding the network several times the problem seems to have gone away.
posted by Nonsteroidal Anti-Inflammatory Drug at 9:00 AM on July 23, 2022 [1 favorite]

iOS does consider network encryption settings when prioritizing networks to join. Your WiFi network probably has a password (and thus encryption) but it’s worth verifying that.
posted by aubilenon at 9:22 AM on July 23, 2022

There was an iOS update (15.6) this week with bug fixes and security updates. Have you updated the OS?
posted by terrapin at 9:55 AM on July 23, 2022

Do you have Wi-Fi Assist turned on? Check Settings > Cellular and scroll all the way down. Wi-Fi Assist will more aggressively use the cellular network if it thinks the wi-fi strength isn't great.
posted by sriracha at 12:53 PM on July 23, 2022

It won’t be the solution, but I’d recommend turning off Private Wi-fi Address for this network. It’s a feature that is trying to give you privacy from tracking by… yourself. It’s a layer of cleverness that’s unlikely to help.

Have you rebooted your router since this started happening? Perhaps even resetting it to factory setting and starting from scratch? I know that’s not a step to be taken lightly, but it may be worth bearing in mind. I had one problem )with smart home gear, not at all related) that was only fixed that way.
posted by breakfast burrito at 5:14 PM on July 23, 2022 [1 favorite]

Unfortunately I can't tell you how to fix it but my iPad Pro (which has a cell connection) did the same thing for a while. No specific thing that I did seemed to make a difference and then one day it started working normally and has been fine ever since.

If you kept the same network name when you got the new router, have you tried changing it to see if that makes any difference?
posted by Candleman at 7:35 PM on July 23, 2022

I was having different problems with connecting on same phone, noticed Bluetooth was off, turned Bluetooth on and problem solved. not sure if that was coincidence. so just throwing it out there.
posted by cda at 7:44 PM on July 23, 2022

I had a similar problem, couldn't figure it out for the life of me. After a month or two trying to fix it, someone mentioned changing the name of my wifi network to something simpler and that did the trick.

The old name was like L4z3nby! and I changed it to lazenby.

Why no, I'm not watching James Bond movies. Why do you ask :P
posted by Sphinx at 5:01 PM on July 24, 2022

Best answer: Make/model of your router? Is it set up with separate 2.4GHz and 5GHZ network names (this should not be done, but often is). Do you live in a crowded place where there's likely to be a lot of competing WiFi networks?
posted by soylent00FF00 at 3:51 PM on July 26, 2022

Response by poster: I think nickggully and soylent00FF00 have it, by zeroing in on duplicate wifi networks. After reading all of the answers here and getting the sense that this is not a widespread problem, I went back into my router settings to hunt down the issue. The router is set up with two networks having the same name, one at 2.4GHz and one at 5GHz. There is a toggle for “Smart Connect” that allows them to have the same name and password, and the router automatically connects your device to the faster band. I had the toggle off (I turned it off a few weeks ago specifically to access the 2.4GHz band to connect a device that is not 5GHz compatible). I suppose the duplicate names and password were causing an issue. I have now turned on Smart Connect and so far in my limited testing today this issue seems to be resolved. Thanks all for saving my sanity.
posted by smokyjoe at 6:05 PM on July 26, 2022 [1 favorite]

Glad it's working now! I suspect that your router's "Smart Connect" feature may be a re-branding of 802.11k or 802.11r or 802.11v which are some WiFi extensions to help devices pick the right channel when moving around. See
posted by soylent00FF00 at 4:09 PM on July 30, 2022

« Older Weird bird behavior - why was a flock of birds...   |   How relatively bad is my memory for ideas? Newer »

You are not logged in, either login or create an account to post comments