Gmail/Weebly confusion part 2
October 28, 2021 5:55 PM   Subscribe

I posted a question re: some Gmail/Weebly problems I was having. Some got solved. Some are persisting. Weebly is telling me something and I'm not sure if I believe them. Can you help me, a totally non-tech person, sort out my next steps?

What happened before: For my work, for 8 years I have had a Weebly website/domain and the associated email address. Email arrived into my personal gmail inbox and when I responded to it, it would look like it was coming from my work email. I could also open a new email inside my personal gmail inbox and select if I wanted it to look like it was coming from my personal or my work email. A couple of weeks ago I lost the alias part of that. I could receive work emails, but when I responded the outgoing message looked like it was coming from my personal email. I had no option to start a new email from my work address.

What Weebly said/did: First, there was plenty of confusion (see more details in that earlier question) because I have an old account, grandfathered in before everyone had to pay to use Google Workspace. Eventually they restored the proper settings so I now receive my work emails into my personal gmail inbox. But I still don't have that alias capability.

When I currently try to restore the alias settings I used to have, following instructions from Reddit someone helpfully posted in that earlier thread: In gmail I go to Settings --> Accounts & Import --> Send email as/Add another email address --> put in the settings that used to be there (which I have a screenshot of), it doesn't work. I get the message "Couldn't reach server. Please double-check the server and port number."

What variables I have tried:
-- using the server/port settings I had before (basically
-- using the server/port settings that are automatically being populated there (starting with mx)
-- using my gmail password
-- leaving the password slot blank (it doesn't allow this)
-- using my weebly password
-- using a gmail app password
Nothing works or changes. I still get "Couldn't reach server..."

Currently Weebly customer support is saying:
-- Too bad; your old, grandfathered setup doesn't allow alias responses
-- A direct quote re: this work email address I've been using for years: Yes, you're always going to get that "Couldn't reach server" message because this email address "is just a spoof email that is forwarded to your regular gmail inbox" therefore no, you won't be able to use it in this way you've been using it for years
-- You should pay for Google Workspace
-- If you pay for Google Workspace, your work emails are going to go into a separate email box so you're not going to have that alias functionality

My goals:
-- Not to have 2 separate email boxes. I am a one-person operation. I don't receive a huge volume of email. It seems insane to have 2 separate inboxes.
-- I actually don't mind paying for Google Workspace if I need to. But I need literally zero functionality besides this alias situation.
-- Continue to receive emails at my work address and be able to respond to them from that address.
-- Be able to generate a new email from my work address.

Can you help with this?
posted by BlahLaLa to Computers & Internet (6 answers total) 1 user marked this as a favorite
Response by poster: I forgot to add: I will happily pay some tech-oriented professional to fix this for me, if there is such a person.
posted by BlahLaLa at 5:56 PM on October 28, 2021

You need someone who's familiar with testing mail servers.

It sounds as if your domain is NOT hooked up to Google mail server on the SENDING end somehow.

Generally, there are TWO servers you need to configure for mail: the incoming mail server, and the outgoing mail server. And that procedure you have was correct, but due to a config change on their end, that server was probably taken out of service, and they are not giving access to the new one (or don't know how).

Generally speaking, most domains use on port 587 using TLS, where you substitute domainname for your actual domain name.

I've also seen a complaint mentioning that Google may have turned off access to "less secured apps" and you may need to check the settings mentioned here:

Specifically: Step 4, where it says "disable access to less secure apps". You may need to turn that off.
posted by kschang at 8:36 PM on October 28, 2021 [2 favorites]

Best answer: So I have—or had, I haven't tested it in a couple of years—this functionality with Gmail and a custom domain that I have for business purposes.

Here is the official Google Support page on sending emails from a different address:

You may need to go into the Settings page for Gmail and go through the verification procedure again (basically they send a message to the address you want to send from, in order to verify that you actually control it and aren't just spoofing someone else's address).

From Gmail, you click on the gear icon in the upper-right corner, then on the "See all settings" button, and then on the "Accounts and Import" tab. Then look for the section that says "Send mail as".

Mine shows two email addresses; one is my main/personal Gmail address, and the other is the business email on the custom domain.

For my business email, it says:
Not an alias.
Mail is sent through:
Secured connection on port 587 using TLS
So I am using Google's SMTP (outbound email) server to send messages from this address, apparently. It looks like I could also configure it to use my own SMTP server, if I had one set up for that domain (which I do not).

Clicking on "More info" brings up a popup window (make sure you have pop-ups allowed) titled "Edit email address" with a yellowish background, where I can modify outgoing mail settings for that address. And on the first page of that settings screen, it shows that I'm using "" on Port 587 for outgoing email. The username is my Gmail address (, and then the password field is blanked out.

This makes some sense: in order to use Google's SMTP server for outgoing email, I have to authenticate to it with my Google credentials.

The one fly in the ointment in my case, is that I have Google Two Factor Authentication enabled. This means that under normal circumstances, I can't log into anything Google-related using a simple username and password. (This is a good idea and you should have it enabled, as it prevents your account from being hacked.)

So the password that I have to enter into the "Edit email address" pop-up window isn't actually my main Google account password. Instead, it's a special app-specific password generated here: (hopefully this link will work)

That page shows a list (titled "Your app passwords") of the legacy applications I'm still using that don't work with modern Two Factor Authentication. And one of them is titled "Gmail SMTP (" ... indicating that at some point (apparently in 2017), I must have set all this up.

Anyway, this is just how my account, which sounds somewhat similar to yours, is set up. I'm not saying it's a good or even recommended way of doing things... there are aspects of it that I am actually surprised work. (I wouldn't be surprised if emails that I send this way get caught in spamfilters pretty often, since I am effectively spoofing email from a domain that doesn't match the SMTP server it's being sent through.) But it seems to work well enough that I hadn't bothered to look into it in four years.
posted by Kadin2048 at 9:15 PM on October 28, 2021 [1 favorite]

Best answer: I sent you a MeMail.
posted by flabdablet at 9:40 PM on October 28, 2021

Response by poster: After many steps, many attempts to fix it that seemed to work but then didn't, I sat back in complete frustration. And a few days later it just started magically working again. I have no energy to figure out why or how.
posted by BlahLaLa at 10:12 PM on November 6, 2021

Chances are it's something on THEIR side, and the different attempts generated enough error logs that finally got noticed.
posted by kschang at 10:33 PM on November 6, 2021

« Older Why would my period symptoms vary so much month to...   |   Women's Biking Commuting Clothing NYC Newer »

You are not logged in, either login or create an account to post comments