Windows, Stop Scaling, Please
April 5, 2021 4:08 PM   Subscribe

Hi All, I have a cloud gaming PC which is very pleasant to use in most respects, except for one particularly nagging issue. Every time I connect to it, presumably using VNC or some similar technology, Windows has scaled the display to 200%, as this is "recommended." How can I stop it from doing so?

I'm a screen reader user, and contrary to what folks might think scaling does actually impact me in some weird ways. The screen reader is sometimes sent the (unscaled) coordinates for controls and such, so interacting with them using my virtual mouse, for instance, becomes annoying.

I can generally reset the scaling to 100% in display settings, but this is tedious to have to do every single time I connect to the machine.

Any advice on how to get windows to leave it alone?
posted by Alensin to Technology (4 answers total)
 
I think what you want is to Google
"disable scaling for [remote desktop app] on windows 10" where you put in the name of the specific app you're using. So you need to figure out whether it's VNC (or one of its variants), Splashtop, Windows Remote Desktop, etc.

When you use a remote desktop the actual size of your screen that's physically connected doesn't come into it, your app creates a virtual screen and selects a standard size, which is probably smaller/lower then your gaming monitor's resolution. However when you STOP using remote desktop the size of your virtual monitor (and any required scaling) can be held over back to your normal desktop by Windows.

The exact steps will vary from app to app, so for example the changes to make for VNC specifically are here. What you probably want to do it match the remote desktop resolution to your normal resolution, although keep in mind if you're using a 4K monitor then the bandwidth requirements to make it work are going to be significant.
posted by tiamat at 8:09 PM on April 5


This might be helpful, if you're using Windows Remote Desktop:

Remote Desktop between two Windows 10 machines, how to disable DPI synchronization
posted by tiamat at 8:18 PM on April 5


Response by poster: Sadly, I'm not sure what Shadow PC uses internally, guess it's time to do some digging. From my perspective I just want to stop the scaling on the remote end, I don't care about the local machine at all, since I'm running my screen reading program there rather than locally.
posted by Alensin at 8:29 PM on April 5


Since Shadow PC is either a proprietary client or it uses something else under the covers, I suspect you'd get better answers by posting a question to their community support forum or by contacting support directly, assuming you haven't already.
posted by Aleyn at 12:13 AM on April 6


« Older What to do with this old car?   |   this tiktok but MORE Newer »

You are not logged in, either login or create an account to post comments