Read Only Folder - User Error
March 19, 2006 7:20 PM   Subscribe

Every time I turn off the Read Only setting for this one folder it reverts immediately. Is there another way to change this setting?

I shared this folder on my network using a program called Network Magic that came with my router. I have since turned off the Share setting and uninstalled Network Magic, but the folder seems to still be affected by my actions. I right-click the folder, hit properties, click the Read Only button so that it shows it is turned off, hit Apply, then I hit Ok. At this point it asks if I want to do this for all the sub-folders and files, I say yes. And this seems to do nothing. I still can't delete files in this folder and if I check the settings, it is Read Only again.

This is an 80 gig folder that I would really like to shrink. Are there any programs that would allow me to modify, delete, or change the status of this read only folder? Or is there another way to approach this through Windows XP? Thanks.
posted by aburd to Computers & Internet (6 answers total) 1 user marked this as a favorite
 
Are you still sharing the folder? Try turning off sharing if it's still on. (right click, properties, second tab.)
posted by Malor at 8:07 PM on March 19, 2006


The folder is not shared. I just double checked.
posted by aburd at 8:11 PM on March 19, 2006


That Read Only checkbox on the property sheet is a bizarro little thing; sometimes it means that the folder's Read Only attribute really is set, sometimes it means that the folder contains at least one read-only file. I often have trouble with it.

The most reliable way I know to turn off the Read Only attribute on a folder is to use the command prompt:

cd \path\to\containing\folder
attrib -R foldername

The Read Only attribute doesn't actually do much for folders, though; it can stop the rmdir command from deleting them, but it doesn't actually prevent changes to the folder contents or stop you deleting them through the GUI. What you probably do need to change are the folder's NTFS security permissions; it sounds like Network Magic might have hosed these up for you.

If you've got XP Professional, open an Explorer window, go to Tools->Folder Options->View, scroll down to the bottom, and turn off "Use Simple File Sharing". That will make a Security tab show up in the property sheet for any file or folder, and you can give yourself the necessary permissions using that.

Windows XP Home doesn't have a "Use Simple File Sharing" setting to turn off; instead, you need to download and run "security for folders and files" from this site to make the security tabs available (they're also available in Safe mode, but rebooting twice every time you want to mess with a security setting is a PITA).
posted by flabdablet at 9:00 PM on March 19, 2006


Thanks. I am am deleting lik crazy now.
posted by aburd at 9:17 PM on March 19, 2006


One neat hack for deleting a file or folder that windows won't let you (in NT, 2k and xp): open task manager, kill explorer.exe (right click, end process, hit ok). choose file.. new task.. browse. use the browse folder to find your offending files/folders and delete them. when your done choose file..new task and type explorer.exe and hit ok.
posted by psychobum at 6:56 AM on March 20, 2006


Psychobum's trick is good for deleting files that Windows Explorer normally holds open, like the index.dat file in Content.IE5. It doesn't get you around NTFS permissions, though; the Task Manager's Browse dialog is run with the current user's credentials, regardless of whether Explorer is still active or not.
posted by flabdablet at 11:49 PM on March 20, 2006


« Older how to deal with U.S. compensation for foreign...   |   In search of pipeline analysis Newer »
This thread is closed to new comments.