My Blog Doesn't Recognize Me!
March 23, 2020 4:19 AM   Subscribe

Weird Wordpress.com problem - My Wordpress blog doesn't seem to think I'm logged on when I'm looking at it. Help?

I have a Wordpress blog; if you are logged into your Wordpress account, there is usually a very convenient black bar across the top of your screen with a button that says "Write" that links directly to the blog entry page. However, a week ago my main blog stopped showing me that black bar, but only stopped showing to me on my own blog. I can go to any other Wordpress page, and it's there; but on my own blog, it's gone.

Also, when you are looking at your own posts on your blog, you have the word "Edit" that appears underneath each post, which you can click if you need to edit something on the fly. If it's not your blog, you don't see that. I no longer see "Edit" at the bottom of my posts, even when logged in.

I can still post to my blog, or edit a given post, I just have to get there via a clunky multi-step workaround via a dashboard and selecting "add new post" or "edit post" or the like.

I've confirmed I am logged in. My blog is still treating me like i'm not.

I have tried clearing my cache.

Help?
posted by EmpressCallipygos to Computers & Internet (18 answers total)
 
Are you getting to the page in question via http or https? I've seen other people's WordPress installations have all kinds of conniptions about whether I'm logged into them or not if I inadvertently hit the http version, which there are still a lot of servers around not set up to force redirection away from.
posted by flabdablet at 4:28 AM on March 23


I can't tell - I just went to the blog, and it simply says "nameofbloghere . com". Any way I can ascertain this without just looking at the address bar?

I'm also going to try logging on via my workplace computer (shhh - don't tell the boss) in a bit and see if that makes any difference.
posted by EmpressCallipygos at 4:34 AM on March 23


Is there a little lock symbol in the address bar to the left of nameofbloghere.com? If not, try sticking https:// in front by hand and see what happens.
posted by flabdablet at 4:49 AM on March 23


I was just able to log on successfully at work, and the black bar is there and there is a little lock symbol next to it. So that's probably a clue.

When I'm back home - I'll try the https in front of the URL and see if that helps. Fingers crossed.
posted by EmpressCallipygos at 5:45 AM on March 23


My WP blog’s black bar disappears after a certain period of time and then I have to log back in by going to nameofblog.com/wp-admin.
posted by beagle at 6:23 AM on March 23


Have you turned off the "Show admin bar" in the settings on your user page?

Have you checked to make sure it isn't "you" that thinks you're logged in? Reload the page. Does the bar appear. When did you log in last? Where? What machine? Which browser. Logins are checked per browser session. So just because you were logged in at some point in the past doesn't mean you still are.

You're operating on the assumption that you are in fact logged in , but I don't see where you've confirmed that that's true.
posted by humboldt32 at 9:03 AM on March 23


Humboldt: Before today, I only logged in on my home computer, on my own Chrome browser, which I have permanently set to "remember" the password. I further also have WordPress set up to "remember my password" and "keep me logged in".

Moreover, at the bottom of the page, I see an option that invites me to "follow" my own account, and I clicked on that as an experiment. I was brought to a page that invited me to log on as myself. I said yes. It brought me back to the front page of my blog, which did not have the "show admin bar", and also still did not have the "edit" option on the posts.
posted by EmpressCallipygos at 9:08 AM on March 23


Did you try any of the suggestions I made? Did you reload the page? Did you check the "Show admin bar" setting? What happens when you go to "https://www.myblog.com/wp-admin?

That "Remember me" setting uses cookies. Do you have cookies disabled? Have you cleared your cookies lately?

Have you tried a different browser to see what happens?

Again, have you tried reloading the page? What you're describing has a caching situation feel about it.
posted by humboldt32 at 9:15 AM on March 23


Yes to all of the above.
posted by EmpressCallipygos at 9:17 AM on March 23


I asked questions that will help troubleshoot this that you haven't answered.

What happens when you go to "https://www.myblog.com/wp-admin?

Do you have cookies disabled?

What happens with a different browser?
posted by humboldt32 at 9:20 AM on March 23


... at the bottom of the page, I see an option that invites me to "follow" my own account, and I clicked on that as an experiment. I was brought to a page that invited me to log on as myself.

In the WordPress installation where I ran across this kind of issue, that was pretty much the scenario as well. Although the page itself had been opened via https, some of the clickable links on it were still to explicit http:// URLs.

It appears that recent versions of WordPress require https for anything behind a login wall, and if you try to use plain http to pull up a page that should be accessible to a logged-in user, you get redirected to a login screen instead. And that happens via a relative URL, so you end up with a plain http version of the login screen which simply doesn't work.

It's normal but not quite universal now for servers hosting this kind of stuff to be configured in a way that forces https. For a WordPress site on one of those, clicking on an http:// link will automatically redirect to the https:// counterpart. I'm guessing that's why this this kind of thing could have been missed in testing.
posted by flabdablet at 9:57 AM on March 23


update - it IS already at the https:// version of the site. This is only happening on my own site, and only on my own browser.

Okay, so tackling humboldt32's checklist:

Have you turned off the "Show admin bar" in the settings on your user page?

I don't know where that option is, so I'm assuming that if I did so, it was by a freaky fluke. Where would I go to check whether that was turned off? (And the fact that I'm even asking you this means it's likely I didn't.)

Have you checked to make sure it isn't "you" that thinks you're logged in? Reload the page. Does the bar appear. When did you log in last? Where? What machine? Which browser. Logins are checked per browser session. So just because you were logged in at some point in the past doesn't mean you still are.

I have my site set to permanently "remember" me and keep me logged in. Logging off and logging back in was one of the first things I did to try to fix this, and I've done that repeatedly. I'm logged in, trust me. The bar is not appearing on my home page. It IS appearing when I go to the Wordpress "dashboard".

What happens when you go to "https://www.myblog.com/wp-admin?

The Admin bar is there. I use the dashboard to go to "visit my site" and it is gone again.

Do you have cookies disabled?

I don't know what this means.

What happens with a different browser?

The bar does appear when I log in on another computer.

I have googled other possible causes and can eliminate some - I did not switch themes recently, and I did not add a new plugin to my Wordpress site. I literally have touched nothing in the layout for the past year, and this started happening last month.
posted by EmpressCallipygos at 4:22 AM on March 25


Just remembered something that may help diagnose - I actually have two blogs in WordPress, and both are linked to my account. I most frequently post to one - but a couple weeks back I posted something to the other one. That's about the time this admin bar issue started happening on my main blog.

I have tried setting the main blog to be my "primary blog" on the WordPress dashboard; it is indeed listed as my primary blog on the dashboard, but still no admin bar.
posted by EmpressCallipygos at 6:03 AM on March 25


What happens if you try from a private/incognito tab in the same browser that's currently affected?
posted by flabdablet at 6:06 AM on March 25


Also possibly of interest: How to Disable the WordPress Admin Bar
posted by flabdablet at 6:15 AM on March 25


I actually tried to find the box listed in the "How to disable the WordPress admin bar" article above to see if it had been unchecked, but - I couldn't even find the tickbox they're talking about. The layout of my Dashboard doesn't seem to be configured the same way (or I was reading an article that was bad at explaining where I would find the different steps).

Also, that wouldn't explain why the "edit" option is also missing underneath each post.
posted by EmpressCallipygos at 6:25 AM on March 25


When you hover over "visit my site", is the link https: or http:?
posted by humboldt32 at 11:28 AM on March 25


Any joy from private browsing mode?

What version is your WordPress installation?

What's the name and version of the browser on which you're seeing this issue?
posted by flabdablet at 4:35 AM on March 26


« Older Creating a simple digital archive   |   COVID-19 Custody question Newer »

You are not logged in, either login or create an account to post comments