Microsoft Word font problem
March 7, 2006 10:49 PM   Subscribe

I'm having trouble with fonts/symbols when opening someone else's Microsoft Word documents. Please help!

I have a document that was saved in Microsoft Word 2002, and I'm opening it in Microsoft Word 2002. I can't contact the author of this document and I'm having problems with some symbols in it. The document as a whole is in Times New Roman. But opening quotes show up as a Courier New capital A, ending quotes show up as a Courier New @, and apostrophes show up as Courier New =. I can't figure out why. The strange thing is that I can't search and replace these symbols/characters using the font options in search and replace, identifying them as Courier New. Word doesn't find them. I *can* find these symbols as Times New Roman characters, but the problem is that I can't search "A" and replace it with a quotation mark because the search also catches all of the regular "A"s in the document. When I highlight these characters the font line in the toolbar shows them as Times New Roman. The only reason I know that they are different fonts is that when I highlight one of these characters and go to Insert | Symbol, the window defaults opening on a character identical to the one you highlighted, and I can see that the character is in Courier New. That is, in the Insert | Symbol window, there is a character highlighted, that character visually matches the mistaken character perfectly, and the font window inside the Insert | Symbol window lists the font as Courier New.

I have tried changing the smart quotes/straight quotes options. I have also tried the Wordperfect Import solutions on this page. None of these work. I don't have any evidence that the document was originally a WP document instead of a Word document, but the font thing is suspicious.

Has anyone ever encountered this? I really hope someone has a suggestion because otherwise I'll be going through this line by line and replacing these characters by hand.
posted by underwater to Computers & Internet (12 answers total)
 
Not sure if this will work but have you tried selecting all of the text in the document and changing it to a simple font like Arial?
posted by gfrobe at 1:03 AM on March 8, 2006


Another option that might work: copy the offending character and paste into the Find part of the Find/Replace window. Insert regular quotation mark/apostrophe in the Replace part. Do a Replace All.
posted by chrominance at 1:09 AM on March 8, 2006


is this in all documents or just one specific doc?
posted by k8t at 1:46 AM on March 8, 2006


Changing the font affects all the other characters but not the 'wrong' characters.

copy the offending character and paste into the Find part of the Find/Replace window. Insert regular quotation mark/apostrophe in the Replace part. Do a Replace All.

When I do this, the Courier New A gets pasted as a regular capital A, so it replaces all of the A's in the document.

is this in all documents or just one specific doc?

It's in all and only documents from one specific source, but I can't contact the source to have them investigate or change the documents.

And I see that this question is almost off the MeFi front page in 8 hours! I really hope someone looks at this again--I don't want to spend 2 hours hand-editing these documents. Thanks for the ideas so far.
posted by underwater at 8:10 AM on March 8, 2006


I have encountered this and am wracking my brain trying to recall the solution. I don't think it ran to changing each occurence...let me think about that. Would it be possible for you to email a small bit of offending text?
posted by beelzbubba at 8:53 AM on March 8, 2006


Use the Find-Replace with the text formatting conditions.
1. Go to Edit > Replace and select the Replace tab.
2. Put A in the Find What: field and opening quotes in the Replace With: field.
3. Click the More button to show the Format properties button.
4. Click the Find What: field to highlight A.
5. Click the Format (with down arrow) button and select Font. Select Courier New.
6. Click the Replace With: field to highlight the opening quotes.
7. Click the Format (with down arrow) button and select Font. Select Times New Roman.
8. Click Replace All.
9. Repeat with the other 2 situations.
posted by junesix at 9:02 AM on March 8, 2006


The fact that this occurs with the "smart" (quote and apostrophe) characters only is suggestive, because microsoft products have a history of using certain character sets in this range differently than other competing products. Here's the windows-1252 character set, and the range at issue is 0x82 to 0x9f. You could probably confirm this if you opened the document in a hex editor, and searched for a string that had one of the offending characters, to see what the underlying representation is. If this was the answer, maybe you could do a unicode find and replace, or a find and replace in the hex editor.

I don't know what the WP representation of these characters are.

OTOH, you could just try downloading a trial version of Word Perfect and seeing what happens if you open the document up there. Ditto for open office
posted by jasper411 at 9:33 AM on March 8, 2006


Iirc, junesix has the solution for you. When I reread that it is the quote marks you had problems with, and with jasper411's answer, the bells rang!

FWIW, when editing, I turn off all the special MS-Bells&Whistles replace all the smart quotes with straight, and so on, using a simple macro. The macro is also perfect for removing extra blank spaces after a full stop.
posted by beelzbubba at 9:58 AM on March 8, 2006


You can search and replace with fonts. Choose Edit, Replace, open the menu by clicking More, in the Find what fileld, ented the a, choose Format and choose Courier. In the replace with field, enter ", choose format and select Times NR.
posted by theora55 at 10:08 AM on March 8, 2006


I appreciate the new comments, but as stated in the original question: "I can't search and replace these symbols/characters using the font options in search and replace, identifying them as Courier New. Word doesn't find them."

Word doesn't identify these characters as Courier New, even though that's how they are displayed.

Please any other ideas...
posted by underwater at 11:09 AM on March 8, 2006


After doing some googling, I found these pages (first, second) that describe the problem. But I don't understand how to implement the solution using macros.

Can someone explain it?
posted by underwater at 11:34 AM on March 8, 2006


Good find underwater! Underneath all MS products there is background visual basic code. This is invisible to the casual user, and it's the reason that MS products are so vulnerable to viruses and such, as VBA is a very powerful programming language that can totally hose your Windows installation.

The thing you found is some visual basic code that someone has developed, which they say will solve the problem of typographic substitution. Just looking it over, it appears that it searches out all the characters at issue and replaces them with Unicode representations.

If you feel comfortable trying it out, and you're looking for some adventure, go to your document and press alt-F11. It will open up the Visual Basic editor. You would copy the code and paste it into the New Macro folder of your normal module.

There are lots of resources on the web, if you're interested in learning more about VBA, including newsgroups, such as you've found.
posted by jasper411 at 11:55 AM on March 8, 2006


« Older I have some nice waterfront property to sell you...   |   Anyone taken Buspinol for anxiety? Newer »
This thread is closed to new comments.