Wireless internet problem
February 28, 2006 11:36 PM   Subscribe

I just received my brand new laptop from Dell. I am connecting to the wireless network, but I am unable to connect to any websites.

The network is currently set up as an unsecure network, I had it set up as a WEP network and it was connecting as well, but either way it is not resolving any websites. I ran the network set up wizard and set it up as a "all computers connecting through hub". We have another computer in the room which is correctly wirelessly connecting to websites. I have tried power cycling the router and repairing the connection. The laptop can connect and load websites fine when physically connected to the router.

The system is a brand new Dell laptop running Windows XP SP2. The router I are using is a Netgear WRTG-614v6. I've tried everything I can think of and have contacted Dell customer service and found them to be incredibly unhelpful.
Anybody have experience with a similar problem? Any advice would be much appreciated.
posted by honeyx to Computers & Internet (11 answers total)
1) Try rebooting.
2) Barring that working, try Start->Accessories->Command Prompt and type "ipconfig /renew"
3) Is it possible to connect successfully with a wire? If you can connect via ethernet port, that would indicate a possible problem with your internal wireless card.

Just some starters. Hopefully that will help.
posted by one.louder.ash! at 12:04 AM on March 1, 2006

Sounds like a DNS issue. Are you sure your server numbers are correct?
posted by kenchie at 12:15 AM on March 1, 2006

I have similar wireless connection problems from my Dell if I'm running on battery power (rather than mains.) A driver/BIOS update helped a lot.
posted by rjt at 1:04 AM on March 1, 2006

can you connect to other networks okay?

what happens if you plug your laptop directly into the router?
posted by k8t at 2:09 AM on March 1, 2006

To fix this kind of problem, you need to work from the bottom up... the higher level stuff doesn't work until the low-level stuff does.

First test: turn off your wireless network (FN-F2 on my 9300... or you can Disable it in network properties), and plug in via physical wire. Do some web browsing. If that doesn't work, then you have a deeper issue of some kind... it's not just a wireless problem. You can use most of the same steps below to try to troubleshoot your wired link, but there's many many many things I'm not checking.... this is already a freaking book. :)

If you can web browse okay, open a command prompt and ping the IP address of another machine on your network. And ping www.yahoo.com. Verify that both pings return four replies. Write down both numbers if you will forget them, as you're going to use them again soon. (This proves that they are pingable when connected the normal way.)

Disconnect the network cable and ping-test the local IP again... verify that you get NO replies. This ensures that it was the wire that was working, and not the wireless.

Now turn your wireless back on, and give it about 30 seconds to connect and get an IP address. Try pinging the local IP.

1) If that fails, then either your security key is wrong, or your DHCP server isn't working over wireless. (DHCP hands out addresses automatically.)
1a) Manually assign your laptop an unused IP in your home network. (normally you will use as your netmask, and the address of your router as the default gateway and DNS server.) Try that ping again. If it still doesn't work, then you either have an incompatible AP or your encryption key is wrong. Triple check encryption keys.
1b) if that worked, then your DHCP server isn't working right. You can just keep the static IP for now.

2) Ok, you can ping another machine on your net. Try pinging the number you wrote down for www.yahoo.com. if that fails, then check your Default Gateway setting. Also verify that the router doesn't have the wireless network turned off from outside access or the like. (that would be unusual, not a high probability.)

Basically, if you can ping another machine in your net, but not a working outside number, then either your laptop has a bad gateway or your router is refusing to forward your traffic. You'll have to dig to find out what's wrong.

3) ping 'www.yahoo.com' by name. If that fails, that means your DNS resolution isn't working. If it comes back with 'could not find host', that means DNS isn't working. If you look on your router's config pages, it will normally tell you the DNS servers it was told to use on a status page somewhere. Copy those values into the static settings and try again. If it still fails, or if your router won't tell you the values to use, then you may need to call your ISP and ask them for the nameservers you should be using. Also look at step 5; the router may give you the nameservers only via DHCP, so you may need to switch, write them down, and switch back to static.

4) I'll assume you can now ping www.yahoo.com. That means nameservice and ICMP are working, so try some web browsing. I'd really expect this to work right.

5) Assuming it did, write down all your settings and go back into DHCP mode. (obtain IP address automatically). Once you've done that and hit OK, try web browsing again. If it now fails, then open a command prompt, and type ipconifg /all. Compare the IP settings there with the working ones you wrote down. Reconfigure your router to give you working values, or else switch to static addressing permanently. (makes it harder to move networks if you do that, though.)

To sum up, what you're doing here:

1) Verify it works in wired mode, prove that both local and remote addresses successfully ping;
2) Connect via wireless, prove it works to ping locally;
3) Prove it works to ping remotely;
4) Prove that DNS resolution works;
5) Prove that web browsing works;
6) Double-check the automatic settings to see if they're wrong for some reason.

Hope that helps. :)
posted by Malor at 5:21 AM on March 1, 2006

Update router firmware and drivers for the wireless card on your laptop.
posted by sophist at 6:21 AM on March 1, 2006

I had the same problem with my newly-purchased HP laptop. I think there's a problem in SP2 that keeps you from connecting -- I had an IP, I had DNS, but no packets were moving. I downloaded this program (as recommended by the HP tech-support people on a chat) and it fixed it fine.
posted by Vidiot at 7:43 AM on March 1, 2006

To sort of add to one.louder.ash!'s comment, it might help (though I don't know if it makes a difference) in the command prompt to try IPCONFIG/RELEASE, and then IPCONFIG/RENEW. Does the same thing as disabling and enabling.

I find it humorous (in a sad way) that I posted a question yesterday about how my (wired) connection on my Dell laptop didn't work. Odd coincidence.
posted by itchie at 8:42 AM on March 1, 2006

Depending on how the modem/router are set up, you may need to register your MAC address with your ISP.
posted by five fresh fish at 11:17 AM on March 1, 2006

Note, that the WinsockXPFιx.exe program Vidiot links may not work for XP SP2. You can try instead a command line unique to SP2, "netsh winsock reset", which will do the same work of rebuilding your Winsock registry entries--though I had no luck with this myself last week, when my DHCP server couldn't assign my wireless card an address. I finally had success physically deleting Winsock and Winsock2 from the registry.
posted by Tufa at 11:33 AM on March 1, 2006

Response by poster: Update:

I contacted the ISP customer service and the rep. suggested that it was a problem with the router. He discovered that the router was sending and recieving packets for about five seconds after the the network was reset. we contacted Netgear customer support. The CSR suggested that I try switching the broadcast channel from channel 11 to channel six. It is interesting to note that well doing this enabled the Dell laptop fomr which I am typing to access the internet, this has disabled our Mac from wirelessly accessing the internet. Perhaps changing some settings with the Mac will allow it to access the internet again.

Some of the suggestions above, particularly Malor's, were helpful but did not fix the connectivity. I noticed that several responses detailed solutions which I had specifically addressed as having attempted to no avail. one.louder.ash!, while I appreciate your attempt, everything that you suggested was something that I specifically said I tried in the MI. Indeed, several people in this thread wondered if I could get connectivity if I connected the laptop physically- I very directly stated in the MI that I could. Next time a question like this comes up please read it carefully to reduce noise.
posted by honeyx at 5:39 PM on March 1, 2006

« Older Microsoft advertisement not so nice to females -...   |   "Step" is a difficult word to google. Newer »
This thread is closed to new comments.