Wireless devices can't chat with each other. Replace router?
December 17, 2016 8:10 AM   Subscribe

So, this is one of those router questions. I'm having a problem with wireless devices not being able to talk with one another.

Here's my affected equipment:
Linksys E2000 Router
Chromecast Audio
Roku Streaming Stick (newest version)
Android Phones (Moto G4, Moto G(gen 1)

So, my network has always worked swimmingly except for this one issue. After a while, separate wireless devices will no longer be able to talk with one another. So, for example, my Android phone will no longer be able to find the Chromecast to cast to it (through Plex) and my phone will also no longer be able to find my Roku for use as a remote.

This is despite the fact that I have assigned each device a static internal IP address in the router menu, and even if I type that address manually into the Roku app it can't connect. While this is happening, I can still connect to the Chromecast Audio from my desktop PC, which is connected to the router via wired Ethernet.

Resetting the router fixes the issue for a while. Note that I also already have AP isolation disabled in the router menu, since the Chromecast doesn't work at all otherwise.

So I guess my question is: can you think of any other troubleshooting I should try, or should I just buy a new router and hope for the best? I went for years without having to reset my router all the time and this is quite aggravating. And if the former what would you recommend as a router? I was just going to go with the Wirecutter recommended Archer.

(PS. Just to be totally clear each separate device can still access the internet fine as well as the wired PC, so for example my phone can still backup its photos to the PC)
posted by selfnoise to Computers & Internet (8 answers total)
 
Ideas:

Does the Linksys E2000 have the newest firmware?
Do you have a guest network enabled and some of the devices are accidentally slipping between the two?

And from the CNET review:

"The Linksys E2000 can't operate in both 2.4GHz and 5GHz frequency bands at the same time."

So maybe a bunch of your 5GHz devices are humming along and then a 2.4GHz only devices connects, kicking them all down to 2.4Ghz, and maybe some of them can't figure out what's happening or recover? Some wireless devices are more finicky than others.

I think a more capable router might help you here considering the number of devices you have.

> And if the former what would you recommend as a router?

The Wirecutter usually gives good recommendations. I've been very happy with my Apple Airport Extreme - very reliable router - but the newest trend is moving to mesh networking, and Apple seems to be getting out of the router game. I'd look at the Google Wifi, which is new enough that Wirecutter hasn't had a chance to review it yet, but I've heard good things about it - easy to setup and manage, less intrusive than the Orbi.
posted by bluecore at 8:26 AM on December 17, 2016


my guess is that the addresses you have assigned manually are being used by dhcp and so there is a conflict in the network.

check that you have excluded the assigned addresses from the range of addresses that the router can allocate via dhcp.
posted by andrewcooke at 9:57 AM on December 17, 2016


Sounds like the AP Isolation option got switched on, since this exactly what it does. From the E2000 manual, Advanced Wireless options section:

AP Isolation The AP (Access Point) Isolation feature isolates all wireless clients and wireless devices on your network from each other Wireless devices will be able to communicate with the Router but not with each other To use this option, select Enabled AP Isolation is disabled by default
posted by zsazsa at 1:55 PM on December 17, 2016 [1 favorite]


Oops, saw you already made sure it was off. Never mind.
posted by zsazsa at 2:12 PM on December 17, 2016


I've been very happy with my Apple Airport Extreme - very reliable router - but the newest trend is moving to mesh networking, and Apple seems to be getting out of the router game.

If all you need is a new, dependable router, I wouldn't let trends like mesh get in the way of grabbing an Airport Extreme while you still can. Even though Apple may be getting out of the router business (though, they've not officially said so) anything you buy will still carry the standard one-year warranty, and you can extend that with AppleCare, which will cover you regardless of whether Apple stops selling routers. I suspect you could grab a refurb on Apple's store, too. Same warranty as a shiny new model.

Airport Extremes rock in terms of dependability and ease of use. I have a way-out-of-warranty, umpteen year-old model and it still gets security updates when required.
posted by Thorzdad at 6:01 AM on December 18, 2016


Thanks for helping me with my brainstorming all!

I think I've solved the problem. My Roku and Chromecast were assigned static IPs by the router but not our phones, since they were not being picked up by the routers firmware as available to assign for whatever reason. So I manually assigned them IP addresses by inputing their MAC addresses. Since then, no issues.
posted by selfnoise at 5:01 AM on December 20, 2016


that's consistent with what i said above. the process of giving out addresses (to devices with no fixed address assigned) is handled by a protocol called DHCP and if you connect and reconnect over time with various devices it's likely going to work through the range of available addresses (including the ones that you had fixed "by hand"). once two things have the same address, things stop working right.

[sorry if this is obvious or you know it's wrong; just trying to fill in the gaps so you understand the possible cause]
posted by andrewcooke at 5:46 AM on December 20, 2016


Just a final message in case anyone else comes across this question.

The solution I found above did work... for about a week. Then I started having to reset the router again. Eventually I just caved in and bought a T-Link AC1200 router on sale. Everything has worked famously ever since.

I considered flashing DD-WRT onto the old router, but I wasn't really in the mood to mess with something like that. I did notice that apparently the DD-WRT corrects an issue with the E2000 where Cisco actually overclocked the CPU and it runs too hot, creating instability. So that's good to know after several years of using the damn thing.
posted by selfnoise at 5:32 PM on February 5, 2017


« Older Does it help organizations to have me on their...   |   Festive-ish Meal That's Easily Cooked, Transported... Newer »
This thread is closed to new comments.