How do I sign myself out of Google (not Gmail) on other computers?
April 12, 2015 11:41 AM   Subscribe

For nearly a year, I've been plagued by my Google searches periodically defaulting to the Swedish Google page (and all of my Google activity turning into Swedish language). I have clicked on "sign out of all other web sessions" in gmail lots and lots of times. I have recently worked out that this happens because I signed into Google on my girlfriend's mother's account last summer. How can I make this stop without involving my girlfriend's mother?

So my Google (including Gmail) keeps turning Swedish. I have reset the language to English a few hundred times in recent months, but it keeps turning Swedish. I long suspected it had something to do with me being signed into something on my (Swedish) girlfriend's phone or computer (e.g. I have paid for apps on her phone using my Google Wallet).

However, I recently looked at my Google search history . I didn't even know this thing existed! There I could see everything I'd ever searched on Google - pretty horrifying! Worse still, I could see lots of searches I did not make, but which from their nature were likely to have been made by my girlfriend's mother!

I repeat: I have clicked on "recent activity" and "sign out of all other web sessions" many, many times and this does not work.

I find it horrifying that I can in effect so easily spy on someone for so long just by signing into Google on their computer. My girlfriend's mother is a typical, slightly paranoid, elderly internet user, who would be dismayed to know how insecure her private searches have been. For this reason, I would prefer to find a way to sign out of my account on her computer without involving her. Is there a way?
posted by cincinnatus c to Computers & Internet (12 answers total) 2 users marked this as a favorite
 
Have you changed your password? It could be saved on her computer so that every time you log her out she just (inadvertently?) logs back in.
posted by Yellow Silver Maple at 11:46 AM on April 12, 2015 [1 favorite]


Hmm, good idea, and I've just changed my password, but surely if she was accidentally logging in (and I don't think I would've had her computer save it) it would show up in "last account activity"? The only activity listed is on my computer, with my UK IP address.
posted by cincinnatus c at 11:54 AM on April 12, 2015


You could try turning on 2-factor authentication, that might log her out.
posted by BungaDunga at 12:04 PM on April 12, 2015


Signing out of gmail sessions won’t be enough. You need to sign the other device out of your Google account altogether. Go here: https://myaccount.google.com/ and click on Recent Activity -> Devices, which should take you to https://security.google.com/settings/security/activity then find your girlfriend’s mother’s device in the list, click on it & then click on the big red "REMOVE" button. That ought to fix the problem.
posted by pharm at 12:26 PM on April 12, 2015 [2 favorites]


Pharm, I tried that and the only devices listed using my account in the last 28 days are the ones that should be there: my phone, my PC, my work computer. Nothing in Sweden.
posted by cincinnatus c at 12:44 PM on April 12, 2015


Darn. I really thought that would do the trick.

If you’re not actually logged on your in-law's computer, you really shouldn’t be seeing their searches in your search history should you. This might actually be a Google bug.
posted by pharm at 1:08 PM on April 12, 2015


Have you had the same thing happen in different browsers or on different computers? If not, try clearing your browser history, cache, cookies, etc.
posted by bluedaisy at 1:34 PM on April 12, 2015


Nuke your browser cookies for *.google.com. It's possible (even probable) that Google's storing language preferences in a cookie not tied to any particular account.
posted by neckro23 at 3:06 PM on April 12, 2015


I've deleted cookies multiple times , and in any case I've had this issue recur with a brand-new phone, a brand-new PC, a fresh installation of Windows, and browsers being uninstalled/reinstalled. It happens on multiple devices. When my language settings change to Swedish, it coincides exactly with my girlfriends's mother searching for things that appear in my Google account's search history. My Google then becomes Swedish on all devices. When I reset my language preference (which I've done many, many times), it is reset on all devices - until my girlfriend's mother makes a search (luckily she's only on the internet a couple of times a day). It is definitely tied to my Google account and not cookies, cache etc.
posted by cincinnatus c at 4:06 PM on April 12, 2015


Is she using a VPN connection that exits in Sweden?
posted by Mac-Expert at 4:35 PM on April 12, 2015


I think you’re going to have to get your girlfriend’s mother to wipe her cookies :(
posted by pharm at 1:34 AM on April 13, 2015


Well, since I changed the password this hasn't happened again, so that's great. I'm assuming that's what stopped it and will update if not.

Bit weird - and worrying - that I could spy on someone just through signing into Gmail on their computer last summer. Also weird and worrying is that none of this showed up under my Google activity.

Whatever, though. Problem resolved for now.

Thanks everyone.
posted by cincinnatus c at 2:27 PM on April 21, 2015


« Older Have you experienced derealization as a child...   |   Self-publishing a children's book Newer »
This thread is closed to new comments.