Setting up LAN & WLAN Homegroup-ed computers in Win7
September 16, 2013 3:49 AM   Subscribe

How do I set up my desktop and laptops so that they can all see each other's network folders, in Win7, when some are on a wired connection and some are on a wireless connection?

I have a desktop computer and up to 3 laptops. They're all running Windows 7. When two or more of the devices are on the same connection, eg, the Desktop and Laptop 1 are both on a wired connection, they can see each other's shared files/folders. If the Desktop is on a wired connection and a laptop is on a wireless connection, they can't see each other's shared files.


Desktop is wired, Laptop 1 is wired. Both can see each other's shared files.
Desktop is wired, Laptop 1 is wireless, Laptop 2 is wireless. Desktop can't see anything, but the two laptops can see each other's files.

All connections are going through the same router. All devices are in the same Homegroup. All devices in the building are trusted, so password protection isn't necessary. All of the permissions appear to be set correctly - when everything is wired, or everything is wireless, everything works as it's supposed to.

How do I get all the devices to see one another, irrespective of the type of connection they're using?
posted by Solomon to Computers & Internet (9 answers total) 1 user marked this as a favorite
It sounds as though the wireless network and the wired network aren't bridged within the router (i.e. they're being treated as two separate networks). If this is just a consumer-grade router, there's usually setting in its configuration to tie the two networks together, although that's usually the default.
posted by RonButNotStupid at 3:59 AM on September 16, 2013 [1 favorite]

Sounds like you're using a separate wireless router to add wireless capacity to a wired network, which in turn has its own router to connect it to the Internet.

If that's right, you will need to turn the wireless router's firewall, NAT, router and DHCP server functions off and use it as a straight Wireless Access Point.

Most wireless routers make that reasonably easy to do. If yours doesn't, post back with its make and model for a walkthrough.
posted by flabdablet at 4:10 AM on September 16, 2013

That's a good point flabdablet. I just assumed everything was plugged into the same device...

Can you check the local IP addresses wired computers are receiving versus the ones wireless ones get? If they're different networks (192.168.0.* versus 192.168.1.*) then the wireless is definitely firewalled and NATed off from the wired network.
posted by RonButNotStupid at 4:28 AM on September 16, 2013

Response by poster: The device is a TP Link TD-W8968. All devices are connect to it, wired or wirelessly.

The Desktop's IP address is, Laptop 1's IP address is & Laptop 2's IP address is They're all showing the same Subnet Mask ( and Default Gateway & DHCP Server (, if that helps?
posted by Solomon at 4:37 AM on September 16, 2013

According to the device's user guide, it supports Virtual LANs which are a way of partitioning the same physical network into several independent segments.

Check your settings. It may be that the wireless side is attached to one VLAN, and the wired side is attached to a different VLAN (See Section 4.5.3 "Interface Grouping") in the user guide.
posted by RonButNotStupid at 4:59 AM on September 16, 2013

In case we're getting ahead of ourselves though....can you ping from wired->wireless and vice versa?
posted by RonButNotStupid at 5:04 AM on September 16, 2013

Response by poster: Resetting the device to factory settings is allowing things to work as they should. I think it might be the router's internal firewall that's causing the problem. Enabling it causes pings to timeout. Disabling it causes them to work as they should.
posted by Solomon at 5:07 AM on September 16, 2013

There may be a setting in the router configuration 'assign each wireless client to it's own vlan' which isolates the wireless clients from each other. make sure this is disabled.
(page 45 of the manual)
posted by defcom1 at 9:36 AM on September 16, 2013

Last time I dealt with weird networking behaviour on a TP-Link router, if I recall correctly, it turned out to be some protection feature labelled "smart" that might have had something to do with broadcasting.

When you have a router that does NAT, as every consumer ADSL router ever made does, turning on any specific firewalling features it may also have is not usually a good idea unless you expect some specific threat originating from inside your own network and understand fully what the router's firewall is going to do to mitigate that. The NAT will inherently stop any unsolicited traffic from outside your network; as you've found, stopping your internal devices talking freely to each other usually causes more grief than it prevents. Turning security features on simply because they exist is not good policy.

The same principle applies to setting up wireless networks: if you have a strong WPA2 password, that's plenty secure enough. Features that let you hide your SSID and blacklist/whitelist specific MAC addresses don't work any better than a WPA2 password would for keeping casual leeches off your WLAN, and do nothing at all to deter a skilled cracker. It remains true that the only way to break WPA2 is using brute force searches against a short password, or dictionary attacks against a weak one.
posted by flabdablet at 7:33 PM on September 17, 2013

« Older A careless Facebook friend request has caused some...   |   Help me stay asleep! Newer »
This thread is closed to new comments.