Firefox zooms in by default. How can I fix this?
July 1, 2013 7:41 AM   Subscribe

Everything in firefox is zoomed in twice by default. Icons in the bookmarks bar are larger than they should be and pixellated. How can I fix this?

Some time over the last week, my firefox installation started acting a bit strange. By default now, all websites are zoomed in 2 levels (as if ctrl + has been pushed twice). Also, icons in my address bar seem to be stretched to be about 125% of their original size; everything in the interface including tabs, bookmark icons under the address bar, home button, etc., all look a bit too big and are pixellated.

I've tried doing the "reset firefox" method under troubleshooting information in the help menu, but the zoom persists. I also tried setting zoom.Maxpercent and zoom.Minpercent to 100 in about:config, but websites still look to be zoomed in twice (i.e., ctrl + has been pushed twice). Hitting ctrl 0 restores websites to their twice zoomed in state, as if that is now the default.

How can I make it so firefox displays websites at their proper zoom and the interface isn't pixellated?

No other programs on my computer have this problem; websites are the proper size in chrome. I'm using Windows 7 and Firefox is up to date.
posted by msbrauer to Computers & Internet (10 answers total) 1 user marked this as a favorite
 
Hold Ctrl and scroll back down to the size you want. It should open that way next time.
posted by weapons-grade pandemonium at 7:53 AM on July 1, 2013


Hold Ctrl and scroll back down to the size you want. It should open that way next time.

Ctrl + and Ctrl - do the same thing. I don't want to have to do this for every single website I go to.
posted by msbrauer at 7:56 AM on July 1, 2013


In about:config, search for layout.css.devPixelsPerPx I believe the default value should be -1.0.
posted by Thorzdad at 7:59 AM on July 1, 2013


Right click on the Firefox icon in the taskbar, then right click on firefox and select properties. Click on the compatibility tab. Is anything checked? The "BIG" menus can result from display scaling on high DPI settings.
posted by zinon at 8:00 AM on July 1, 2013


In about:config, search for layout.css.devPixelsPerPx I believe the default value should be -1.0.

It is currently. Everything got reset to defaults when I did the "reset firefox."
posted by msbrauer at 8:01 AM on July 1, 2013


Right click on the Firefox icon in the taskbar, then right click on firefox and select properties. Click on the compatibility tab. Is anything checked? The "BIG" menus can result from display scaling on high DPI settings.

Nothing checked. I tried the "disable scaling on high DPI settings" checkbox, as well, but didn't see a change.

I did notice that I'm running firefox from the x86 Program Files folder rather than the other program files folder. Could that be causing an issue? That is, is there a 64-bit firefox I should be using instead (if I'm understanding the two program files folders correctly)?
posted by msbrauer at 8:09 AM on July 1, 2013


Based on your description I still think it's a DPI scaling issue. Could you post a screenshot?

Did you restart firefox after changing the scaling setting? Not sure how windows handles that one. But you can try setting the PixelsPerPx to 1 instead of -1. Which should have the same effect.

From this forum post:
At least a new pref was added to get things back to the way it was before. The new pref is 'layout.css.devPixelsPerPx'.

-1.0 makes Fx use the OS DPI. This is the default.
1.0 makes Fx use the original method of handling DPI. This will make things look normal again.

If you set the pref to a 2.0 everything will zoom 2x. A 3.0 will zoom things 3x, etc. You can use decimals (1.5). Using something like 0.5 will make things twice as small.
posted by zinon at 8:51 AM on July 1, 2013


Had the same issue. The solution was found here.
posted by pyro979 at 9:24 AM on July 1, 2013


Don't worry about running from the x86 folder. I'm doing the same thing, and I don't have the problem you've described. (I also stopped automatic updates for FireFox at version 20, 'cuz of stuff like this.)
posted by benito.strauss at 10:43 AM on July 1, 2013


Thanks, everybody. I managed to fix it by setting layout.css.devPixelsPerPx in about:config to 1. The change was instantaneous and did not require restarting firefox. However, now a few of the websites that I did "ctrl -" on twice to fix the zooming need to be reset using "ctrl 0."
posted by msbrauer at 11:54 AM on July 1, 2013


« Older Necessity. Necessity for funny.   |   Seven degrees up, please Newer »
This thread is closed to new comments.