Word doesn't get the (insertion) point - style shortcuts at end of word
May 9, 2013 10:05 AM   Subscribe

In Mac Word 2011 - When editing a block of existing text, with the insertion point at the end of newly typed word, using command-B or command-I seems to style the word preceding the insertion point, and that I just applied styles to, rather than turning the styles off for the word I am about to type. Can this behavior be altered?

This is contrary to the behavior of every previous version of Word I can recall using (and every other word processor, generally) and is driving me nuts in trying to clean up an existing document. My current kludge is to type a space, then Shift+back-arrow to select the space, then Command-B or whatever to disable the style, and then space and resume typing.

But that's stupid and way too much work for what should be accomplished with one keystroke.
posted by snuffleupagus to Computers & Internet (4 answers total)
 
I should add that I don't want the spaces in question styled because the documents concerned are outlines that include underlined phrases in the various headings etc. So I often need to change the formatting at the end of the word, without the formatting command applying to the word to the left of the insertion point. Plus, as I am editing rather than composing, there's usually already a space there.
posted by snuffleupagus at 10:11 AM on May 9, 2013


I'm confused. I too have Mac Word 2011 and this doesn't happen to me. So let's say you want to style a heading as underlined; don't you just command-u, type the word, then command-u again at the end of the word to change back to non-underlined text?
posted by sevensnowflakes at 11:57 AM on May 9, 2013


OH - now I understand. Sorry, it didn't register the first time around that you are likely highlighting text that has already been typed to apply new styling. Here is what you need to do: Word is set up so that when you highlight a portion of a word, it automatically highlights the whole word plus the space after the word. Turn this off by going to Word-->Preferences-->Edit and deselect the box "When selecting, automatically select entire word."

Boom!
posted by sevensnowflakes at 12:03 PM on May 9, 2013


That's not exactly it–I highlight a word or phrase to format it, and then hit the arrow key to move the insertion point to the end of the highlight (i.e. right after the last character of the word and before the following space). At that point, nothing is visibly selected. If I then try to toggle italic/bold/underline via the keyboard shortcut, Word applies that formatting change to the word I just deselected, immediately to the left of the insertion point, rather than just toggling direct formatting for the text I am about to type. And the direct formatting indicator on the ribbon doesn't change.

I've noticed that it doesn't happen all the time, though, so I though it might be some kind of contextual style 'assist' that is more of a detriment in effect. ("It looks like you're trying to style some text!") Or maybe some kind of document specific glitch with the embedded styles--this is an outline that appears to have been handed around for a while, and may have been through more than one doc/docx conversion.

I've also noticed that the direct formatting indicators on the ribbon simply don't work half the time when bold/italics/underline is in fact on, in all documents, so maybe this version of mac word just still has lots of minor bugs.
posted by snuffleupagus at 1:04 PM on May 9, 2013


« Older My roommate is driving me nuts and I'm wondering...   |   Help me understand the traditional IRA Newer »
This thread is closed to new comments.