Remote Desktop Connection woes
April 24, 2013 8:15 AM   Subscribe

My work computer is a laptop running Windows 7. I am working far from my office this week (as I often do) and I connect to my work server through Remote Desktop Connection. Typically this is pretty much problem-free, but for the last two or three days, when I log in to the server, I am seeing the server's desktop not as a full screen, but in a window about 10" wide on my 17.3" laptop screen. As well, while the laptop's screen has a 16:9 aspect ratio, the window looks to be 4:3. Attempting to resize the window through the Maximize/Restore Down icon avails me naught: I can mouse over the edges of the window and drag it to a new size, but it maxes out at the size that I mention, which covers maybe 60% of the screen's real estate. Numerous reboots and resets have not rectified it and I am at a loss as to how to proceed.

It is not a crippling obstacle, of course, but it is an annoyance. I have not changed any settings anywhere, and the only unusual thing that happened before this began is that last weekend I was teaching a course and doing some presentations on this laptop. When I plugged in the projector's cable, the display on laptop immediately resized each time to the projector's aspect ratio, which looked to be about 4:3. Unplugging afterwards, everything went back to the regular display each time.

I have used this machine with a projector before and seen the same resizing of the display on my screen, but I have not had it hooked to a projector in several months, and after a hard drive failure this winter, a new hard drive went into the machine in February or early March. Last weekend was the first time it was used with a peripheral since then.

Note: I work for an NGO and this is a work computer, so suggestions to move to a different software package may not be helpful. Most of us work remotely and none of my coworkers are encountering this problem, so I am not in a strong position to ask everyone else to get rid of their laptops as well and go with some new approach.

Also, I am so very much not a techie guy, so explanations that patronize my understanding of this stuff are just fine. Explain it to me like I am eight.
posted by ricochet biscuit to Computers & Internet (6 answers total) 1 user marked this as a favorite
Best answer: Go to RDC > Preferences in the top menu bar (this is the Mac version of RDC, if on Windows your Preferences may be found elsewhere). In the Preferences dialog, click Display. From there you can change your Remote Desktop Size to a larger size or to full screen.
posted by dayintoday at 8:20 AM on April 24, 2013

Best answer: If you click the "Options" arrow on the bottom left of the RDC popup, there will be a Display tab where you can select options that may remedy your problem.

Alternatively, there's a help page that gives info on starting start RDC from the command line with "/h", "/v" or "/span" for more control of the size of the RDC window.
posted by ShooBoo at 8:22 AM on April 24, 2013

It's also possible that the issue is on the remote end.

When you exit your remote session, do you click on the "X" or do you use the "Log Off" option from the Start Menu? I've had Remote Desktop screen issues that sound somewhat similar to yours and logging off and then back on again fixed it for me.
posted by Gev at 8:32 AM on April 24, 2013

Since you're going to the same computer with, I assume, the same IP, you can use the windows version of RDP Client to save your settings including, if you so desire, the credentials. (or just the username), for convenience sake. "Local Resources" is where you can share drivers with the remote computer as well.

Indeed, be sure to log off at the end of the session. Windows OSes above XP like to have of multiple users running simultaneous sessions, and you don't want to start a bunch of user sessions without also ending them with a logoff.
posted by Sunburnt at 8:35 AM on April 24, 2013

Response by poster: It's also possible that the issue is on the remote end.

When you exit your remote session, do you click on the "X" or do you use the "Log Off" option from the Start Menu?

No one else is having the issue (or any other issue), so I think it is unique to my machine. And I log off with start menu option. Logging off and on does not change anything.
posted by ricochet biscuit at 8:40 AM on April 24, 2013

Response by poster: The option in the RDC preferences dialog box did it. Thanks!
posted by ricochet biscuit at 8:43 AM on April 24, 2013

« Older Sneakers for flatfooted heel strikers   |   Architect versus contractor Newer »
This thread is closed to new comments.