realtek ac97 sound controller doesn't work
April 16, 2013 4:50 AM   Subscribe

Hi, my computer isn't making any sounds at all. win7. The control panel shows the realtek ac97 sound card (or maybe it is a built in piece of the motherboard?) but won't make any noise.. the speakers work, have tested them in another machine.
posted by Mistress to Computers & Internet (9 answers total)
 
What do you see when you right-click the volume icon and select "Playback Devices?"

This FixIt might also be helpful.
posted by samsara at 5:02 AM on April 16, 2013


speakers - realtek ac 97 audio, default device, with a tick mark

realtek digital output - realtek ac 97 audio, ready

FixIt result: we did not detect any problems and therefore no fixes were applied.
posted by Mistress at 5:14 AM on April 16, 2013


Is this a laptop or desktop?

Has the sound worked previously or did this suddenly happen?

Do you frequently plug and unplug the speakers?

When sound should be playing, click on the speaker icon in the Taskbar. Does it show any activity, i.e. red and green bars moving up and down?

These will help differentiate a hardware vs. software issue.
posted by tommasz at 5:50 AM on April 16, 2013


Desktop.

It was given to me and I have never had sound working on it.

I have tried plugging and unplugging the speakers quite a few times in last few days :)

Gettig green bars on clicked speaker icon when sound should be playing.

Thanks you guys :)
posted by Mistress at 6:28 AM on April 16, 2013


Start from the basics. Where are you plugging in the speakers? There will likely be a green connector on the back of the motherboard for the output. If there are other connectors on the front/monitor etc they may not be functional.
posted by Leud at 7:12 AM on April 16, 2013 [2 favorites]


I have been having an issue with my Realtek onboard sound for a few months now where the driver will crash after a day or so of system uptime. Sometimes I could get it to work by unplugging and replugging the speakers, or going into the Windows Device Manager and uninstalling and immediately reinstalling the driver, but most of the time it required a restart of the computer.

there are many people asking about this issue on the various tech support boards, but no one seems to have an answer.

I recently got a driver update from my motherboard manufacturer, but haven't had it long enough to know if the problem is fixed or not.

If you have built-in sound on the motherboard, another thing to check is the connector from the motherboard to the port that you are connecting the speakers to.
posted by ArgentCorvid at 7:37 AM on April 16, 2013


Have you checked your BIOS? Assuming your sound is built-in to the motherboard it might need to be enabled in BIOS. I installed a sound card into a desktop with built-in sound and I needed to disabled the built-in sound in BIOS before my sound card would work so it is possible sound might be disabled on your motherboard.
posted by Rob Rockets at 8:07 AM on April 16, 2013


Sometimes AC 97 drivers show up where the correct ones should be SoundMax or other (due to AC 97 being a common chipset used for compatibility). If it was disabled in BIOS then it normally wouldn't be visible as a playback device, so I'm suspecting drivers primarily.

What's the make/model of the PC you're using? Let's see if we can get up to date drivers installed. If it's a custom built, you can try finding the make model by running systeminfo:

- Click Start and type CMD in the search box, press enter
- in the CMD prompt, type "systeminfo" and press enter
- Scroll up and note the manufacturer and model reported.

If it's a Dell, Lenovo, ASUS, Acer, HP, etc...you'll want to navigate to their support pages and grab the latest audio driver for your make/model. Feel free to post that info here too and we can help you find the right spot for the download.
posted by samsara at 8:46 AM on April 16, 2013


It was in the wrong hole :) thank you all!
posted by Mistress at 9:06 AM on April 16, 2013 [1 favorite]


« Older X11 apps on Ubuntu Touch?   |   Game face on! Newer »
This thread is closed to new comments.