Help me access LibreOffice
November 27, 2012 3:44 PM   Subscribe

I've been using LibreOffice as a word processor for a while now. But all of a sudden, I can't open it. The message says, "LibreOffice can't be opened because it is from an unidentified developer. Your security preferences allow installation of only apps from the Mac App Store and identified developers." I can't see any settings in my OSX System Preferences / Security and Privacy that would cause this. Can you help me restore access to LebreOffice word processor?
posted by partner to Computers & Internet (4 answers total) 1 user marked this as a favorite
System Preferences > Security and Privacy > General tab

bottom half is "Allow applications downloaded from:" - you want to choose "Anywhere"

This is under Mountain Lion.
posted by neilbert at 3:47 PM on November 27, 2012 [1 favorite]

You don't need to do that (and really shouldn't). Just right click and choose Open. That will give you a very similar error box but will also have an "Open" option.

This probably happened because LibreOffice updated itself, and the new update wasn't signed by the developer.

It's also worth mentioning that this is exactly the case that this feature of OS X is supposed to protect you against. An app that you had was updated with a new version. If you don't know why, it could be malware that you really shouldn't be running. The dialog should make you look into why the software was updated.
posted by smackfu at 4:00 PM on November 27, 2012 [3 favorites]

It's a new security feature. You can change the setting that neilbert recommends. Alternatively, I believe you can basically tell OSX that "this application is OK" by right clicking it and selecting "Open", instead of double clicking it.
posted by losvedir at 4:01 PM on November 27, 2012

Good info. Thanks to all.
posted by partner at 5:30 PM on November 27, 2012

« Older Now that I'm single, how do I stop needing...   |   A bad legal history and crowdfunding Newer »
This thread is closed to new comments.