Mystery of the hating motherboard!~
August 16, 2005 4:13 AM   Subscribe

New motherboard cannot detect harddrive and it's driving me nuts. Let's solve this crazy mystery together >.<

I wrote another ask thread earlier concerning my computer not being able to boot. Turns out i had to replace the motherboard. So i bought an asus P4P800-E, computer booted to bios, that's a good sign. However, it cannot detect my WD1200BB drive. I have tried various bios settings (messing with SATA settings...this harddrive is ATA not sata), i have tried messing with the jumpers on the harddrive, and tried using a different ide cable. So far nothing works.

Half the time, the motherboard simply can't detect the harddrive. Sometimes, depending on bios settings, it will see an IDE drive plugged in, when i leave the bios settings it immedietly does not know the drive is there. If i put in a DOS boot disk, i cant even see C:. It gives me various messages, but most of the time just simply tells me to reboot and select proper boot device or insert media. I even tried to plug the harddrive into secondary IDE to no avail.

I have also thought the powercable that was plugged to this harddrive wasnt supplying it with any power, so i plugged this particular one into a fan and the run ran.

I find it hard to believe that a motherboard cannot support this harddrive!

I wanted to flash the bios but i have no idea how to flash it with boot media.
posted by EvilKenji to Computers & Internet (14 answers total)
 
oh, one more thing, if this makes any difference at all, the motherboard supports both SATA, ATA and has RAID...and yes I disabled RAID.
posted by EvilKenji at 4:15 AM on August 16, 2005


Have you tried the drive in another computer? I find it hard to believe you'd need to flash the BIOS for that drive / mobo combination.

Is the drive formatted?

Did the drive come with any custom bootable CD/software? You might try running that and see if it detects the drive.

It's also possible that whatever killed your mobo killed your HD as well.
posted by selfnoise at 6:07 AM on August 16, 2005


Are you sure the HD is strapped correctly? Western Digital drives have 3 strap settings - Master, Slave, & Single drive (or something along those lines).

Just thinkin' you may be trying to set the machine up initially without a slave drive attached on the IDE cable - in which case, it should be strapped to "Single drive" (iirc, no strap at all).

Also, I've seen problems with WD drives & "Auto" IDE settings in the BIOS, but not on any recent m'boards.
posted by Pinback at 6:10 AM on August 16, 2005


Rewritten after mefe and Opera both decided to crash horribly:

BIOS flashing's easy; grab the latest P4P800-E .rom and BIOS flash tool from the Asus website, grab the driver-free DRDOS boot disk from bootdisk.com, drop the lot on a floppy, and follow the instructions on the website to run the flashing tool once you've booted off it.

The drive jumper should either be set in the middle (master), or be removed all together (single drive; assumes you're not going to put anything else on that channel, which you should generally avoid).

You should have 3 PATA channels; two on the Intel ICH5 and one from the Promise RAID controller. You may need to enable RAID in the BIOS for the Promise controller to work; it's worth trying the drive on it, in case the drive and the ICH5 are disagreeing (I've seen this kind of thing with some Maxtor drives and the ICH5).

Making sure the drive (still?) works in another system is also a good idea if nothing seems to help.
posted by Freaky at 6:14 AM on August 16, 2005


The 865PE chipset has some funny things going on with SATA. Here is a similar issue. Unfotunately I can't remember the details very well - the 865PE systems I was refering to were built for others, so they aren't around anymore.

If I get a chance later I will take a look at the MB manual and see if I can spot what I was refering to there.
posted by Chuckles at 6:22 AM on August 16, 2005


So anyway, the comments above may still apply even though it is an ATA drive. If you have the BIOS set to run SATA as ATA then you will be missing the ATA spot the drive would have been in.
posted by Chuckles at 6:25 AM on August 16, 2005


Master, Slave, & Single drive (or something along those lines).

Clarification: Master, Slave and CS (Cable Select). If you have it on CS, and it's not at the end of your ribbon cable, it might not work. This is due to the necessity of a terminating resistor, which used to be a physical resistor you had to plug into the hard drive if it was last in the chain. Ahh, the good 'ol days...
posted by Civil_Disobedient at 6:40 AM on August 16, 2005


If it's a WD drive it may not work correctly on anything but Cable Select. My girlfriend's machine had that same kind of problem (we had it set to 'slave' and it wouldn't be seen on her mobo, but it would on mine).
posted by Dipsomaniac at 7:34 AM on August 16, 2005


Civil_Disobedient, WD drives have a "single master" option as well, where the drive is the only one connected to the IDE chain, and is set to master. WD drives set to "normal" master don't work in this configuration.

Don't ask me why, it was something introduced somewhere later down their line (probably at around 1 or 2 GB).

WD drives also have a CS setting. Annoying, yes.
posted by shepd at 9:36 AM on August 16, 2005


i've tried taking the jumper out, having it set to CS and manually set to master. It is the only drive on the harddrive; there is no slave drive.

Here are some of the bios options regarding the harddrive. This harddrive has the ICH5 and the promise raid controller. The ICH5 has 2 ide ports and the promise adds another. In the settings i can set it to SATA only, PATA only or SATA +PATA. I can also have it set to enhanced mode (for newer OS) or classic mode (for older OS). In addition, I have the option to diable the raid controller or have it set to RAID or normal IDE.

So far i have tried setting the harddrive on primary, CS and taking the jumper out altogether. I have tried setting it to SATA only, PATA only and the mode with both. Also I have tried this with most if not all combinations of classic and enhanced mode. I have also tried running the drive off the promise controller by turning it on and setting it to IDE...doesnt work. Maybe there's some crazy combination of settings and jumper configurations that'll make this work ? But at this point i doubt it!

I'm about to flash the bios see if that helps.
posted by EvilKenji at 3:04 PM on August 16, 2005


Have you tried restoring the BIOS to the factory defaults? There's usually an option for that in the BIOS menu. Occasionally there's an option like "Load optimized defaults," too. Try 'em both if you haven't already.
posted by Civil_Disobedient at 3:09 PM on August 16, 2005


Tried restore bios, flashed bios....still not working. I accidentally had my harrddrive set to slave and the motherboard could detect it quite consistently. However when i have it set to master it keeps semi-detecting it again. Meaning sometimes it doesnt see it, sometimes it does...and it never works.
posted by EvilKenji at 3:59 PM on August 16, 2005


woo harddrive is aparently dead. Problem solved i guess...but wait what could've caused this? The motherboard and harddrive died at the same time...yet the processor, ram and dvd burner are fine! Is it possible that the same thing that caused the motherboard to go down caused this? Or maybe it was because the motherboard was broken that caused some chain reaction into the harddrive?
posted by EvilKenji at 4:42 PM on August 16, 2005


woo harddrive is aparently dead

Ah, well, there you go. :)

but wait what could've caused this

Heat, usually. Static electricity and poor handling, occasionally. Are you absolutely certain that both the motherboard and the hard drive are dead? One or the other I could understand, but both is extremely suspicious.
posted by Civil_Disobedient at 7:56 PM on August 16, 2005


« Older needed: radiologist/neuroradiologist/vascular...   |   wifi antenna for laptops without antenna socket Newer »
This thread is closed to new comments.