iPod acting up!
August 15, 2005 8:54 PM   Subscribe

My iPod is acting up. Help.

I have a windows XP laptop and a 60Gb iPod photo. I can't get my PC to recognize iPod, and I think this happened after I upgraded to iTunes 4.9. Let me give you the facts:

- iPod shows up in the device manager
- iPodService seems to be working properly, since when I plug it to my USB port, iTunes automatically starts.
- I tried restoring my iPod with the latest updater version (which I now regret, because it is now useles. Before I restored it, at least I could use it to listen to music :-) ).
- iPod does NOT show as drive letter on My Computer (that's the part that is puzzling me, because it looks like it should).
- I have turned off the "allow windows to turn this off to safe power" on the USB Root Hubs in Device Manager.
- I have tried plugging it to more than one port. Same results.

Help, Metafilter!
posted by falameufilho to Computers & Internet (7 answers total) 1 user marked this as a favorite
So iTunes doesn't recognize it at all? That's really odd, if it shows up in the Windows Device Manager. If iTunes recognizes that an iPod is connected, it should allow you to set Preferences for it, including whether its hard drive is made accessible.

The only thing I can think of to try would be to uninstall, then reinstall, iTunes. If there's an option in the Device Manager to uninstall the drivers for the iPod, do that, too, and reinstall from the drivers on the Apple website or the CD that came with the iPod.

If you can get the updater to recognize the iPod again, you should probably try to reset it again.
posted by cerebus19 at 9:44 PM on August 15, 2005

I had a similar, but not identical problem, and solved it by letting the battery run down to absolutely zero on my ipod (mini).... did this by changing the setting to backlight-always-on, and leaving overnight. Once I plugged it in with no battery charge the computer recognized it just fine, and its been fine since.
posted by Rumple at 12:57 AM on August 16, 2005

Have you installed or connected any new drives lately? If you've recently added a hard drive or one of those USB flash RAM card readers, there might be a problem with drive letters within a range assigned to the iPod all being used up. Try unplugging all USB devices that have a drive letter.
posted by krisjohn at 1:25 AM on August 16, 2005

I used to have similar problems with my laptop and it turned out to be some kind of software conflict. Closing down all programs didn't actually help as there were still some anti-virus and firewall processes running in the background. Try downloading a free copy of EndItAll which allows you to end/kill all running applications. When you're sure that nothing unnecessary is running, try plugging in the iPod again.

Or maybe you could try starting up the computer in Safe Mode and then plugging in?
posted by gfrobe at 1:42 AM on August 16, 2005

Best answer: I second the drive letter suggestion. We've had this problem at work, where it was not just the iPod but ANYTHING plugged into the USB port: things showed up in the device manager, but nowhere else.

Try changing the drive letter, like this:
-have the iPod plugged in
-right click "my computer" on the desktop
-select manage
-go to "storage" and "disk management" underneath it (it's a branch of it)
-Your iPod should show up here
-right click on the drive that is the USB port with the iPod in it (it might be called just "mass storage device")
-select "change drive letter and paths"
-a menu will pop up. Select
-Pick a new letter for this drive, one that is NOT YET used for any other drive, like Q or something

All this does is rename the USB port from "E" or whatever ot was to "Q", so it's not going to harm anything, and worth a try. If it didn't help, and you don't like Q, you can always change it back to E.
posted by easternblot at 3:27 AM on August 16, 2005 [1 favorite]

install a firewire card (they are pretty cheap) and you shouldn't have this problem.
posted by nimsey lou at 3:29 AM on August 16, 2005

Response by poster: Thanks a LOT eastern blot! I was going crazy here. Your answer was right on the money.
posted by falameufilho at 7:24 AM on August 16, 2005

« Older Streaming to a Mac with iTunes.   |   New computer, old files Newer »
This thread is closed to new comments.