How do I get two wireless PCs to share files?
July 19, 2005 5:40 PM   Subscribe

How do I get two computers connected to a WiFi network to be able to share files? Both are connected through the same Linksys Wireless-B router. One is running XP SP2, the other XP.
posted by teaperson to Computers & Internet (7 answers total)
First thing I'd try:

Open My Network Places on one of the computers. Under Local Network, you should at least see the SharedDocs folder on the computer you're working on. If you see the other computer's SharedDocs folder too, you should be able to open it up and get at its files.

If you don't see either, do this on both computers: Find the Shared Documents folder under My Computer, right-click on it, select Sharing and Security, and turn on sharing. Then see what shows up under My Network Places.

If you only see your own computer's SharedDocs, you need to make sure both computers have the same workgroup name. For XP Home, the workgroup name defaults to MSHOME; for XP Pro, it defaults to WORKGROUP. You can change the workgroup name to anything you like under the Computer Name tab of System Properties (which you can get to through the Control Panel or by right-clicking My Computer and selecting Properties).

There are lots more things that can make this all go wrong, but let us all know how far you get with the three above so we all know which garden path to start wandering up :)
posted by flabdablet at 6:30 PM on July 19, 2005

Odinsdream's point about the common username is right. For least hassle, make sure that the passwords for Bill are the same on both machines as well.
posted by flabdablet at 6:32 PM on July 19, 2005

OD: XP Home doesn't have Network Neighborhood; the nearest equivalent is My Network Places, and it shows you all available shares - you don't have to drill down through a layer of hosts.
posted by flabdablet at 6:35 PM on July 19, 2005

Also, be aware that anyone hanging out near your wireless router will no doubt have access to these documents.
posted by Jairus at 6:41 PM on July 19, 2005

odinsdream: default share settings don't require a user/pass. And even if it did, most Windows XP PCs have an Admin acct with no password. :)
posted by Jairus at 7:19 PM on July 19, 2005

From my experience, if you're talking about XP Home, you're in for a nightmare of ridiculous hoops through which I would not wish my worst enemies. Well, maybe some of them. They deserve it.

Now, if you're talking XP Professional, you've got no can share a directory on one computer, and voila, you can see it on the other computer through network neighborhood. As long as you're on Professional, they don't have to be in the same workgroup. I've got an old NT box that refused to share a specific directory under an old work account of mine unless I log in under that domain account effectively that machine's a member of that domain. My other XP Pro machine can still grab the shares when they're offered, however.
posted by thanotopsis at 10:40 PM on July 19, 2005

I'll add one thing which was the cause of my problem for weeks. Knowing that the usernames on each computer had to be the same, I went into the Control Panel and simply changed one username to match the other. This doesn't work as the old security ID (or something to that effect) hasn't been changed. You either have to create a brand new login name to match the other computer or there is a place in either services or the registry (don't remember which) where you can effectively change the login name and security ID to match the other.
posted by gfrobe at 2:08 AM on July 20, 2005

« Older What overflows into our cold tank?   |, shit Newer »
This thread is closed to new comments.