I hate monopolies.
March 22, 2012 6:36 PM   Subscribe

Why does the Netflix Watch Instantly homepage hate me? It can take anywhere from 5 minutes to ∞ minutes to load all the images. I can't say it's completely useless without the images—if I'm desperate, I can mouse over every black rectangle to see what it contains—but I'm sure the irritation is shortening my life. While it's loading, I typically see a message that Firefox is waiting on data from one of (what appear to be) Netflix's servers. I tried flushing my DNS cache, and that actually seemed to help momentarily, but then it stopped helping. (Yeah, I don't think it really helped.) Is this just Comcast throttling Netflix so I'll use Comcast's video service? Is there anything I can do to speed things up? I started the dreaded customer service phone call last night and that actually seemed to precipitate an avalanche of image loading—did they see my customer service ID and say hey, dump that guy's images so he'll hang up?
posted by bricoleur to Computers & Internet (11 answers total) 10 users marked this as a favorite
have you tried Chrome? i used to love firefox but i had so many issues with it like this that i've been using Chrome exclusively for a good long time now.
posted by sio42 at 6:40 PM on March 22, 2012 [2 favorites]

Came to recommend trying chrome out. And also that you haven't verified the infinity upper bound :p
posted by bessel functions seem unnecessarily complicated at 6:59 PM on March 22, 2012

Chrome. Gave up on Firefox, it's a mess.
posted by henry scobie at 7:07 PM on March 22, 2012


I've got Chrome, and I have trouble like this too.

But that's doesn't necessarily mean that Chrome is the problem; nor is Firefox. In fact -- I've noticed that it comes in spells, and that it's always just one or two sites (usually Youtube or Metafilter) -- and once, when Youtube was loading slow, I tried pulling it up on IE and found out that THAT was also loading slow. Then a few minutes later, it was fine.

If you have IE still, try it on IE and see if you have the same problem. If you do, then it's not your browser after all.

(but don't ask me what it is; I'm still trying to figure out myself.)
posted by EmpressCallipygos at 7:14 PM on March 22, 2012

Comcast's DNS servers can be shitty sometimes. Try manually setting your DNS server to "" (Google's public DNS service) and see if it fixes the problem.
posted by Idle Curiosity at 7:19 PM on March 22, 2012 [1 favorite]

Or the opposite of what Idle Curiousity suggests, have you manually edited your DNS server (to OpenDNS or Google DNS)? I had trouble with a number of streaming video sites until I went back to my default ISP DNS settings. Something about the latency induced by the geographical distance between me and the alternative DNS server, if I recall.
posted by Rock Steady at 7:23 PM on March 22, 2012

As far as I can tell, Idle Curiosity has it. At least for Netflix—I suppose I may find tomorrow that I have to toggle it back and forth. Thanks, all, for the help.
posted by bricoleur at 7:31 PM on March 22, 2012

How do you manually set your DNS server to I've had this prob with Netflix before (Firefox, Comcast) and I'd like to try it.
posted by scratch at 7:43 PM on March 22, 2012

Windows 7: Control Panel > Network and Sharing Center. Click Local Area Connection under "View your Active Networks" at the right to get a dialog, click Properties, highlight Internet Protocol Version 4, click Properties. At the bottom, select "Use the following DNS server addresses" and put and for google's DNS servers. Memail me if you have some other OS and I'll try to help you.
posted by axiom at 8:21 PM on March 22, 2012 [1 favorite]

Google instructions for setting your DNS to their public server(s) (
posted by bricoleur at 8:21 PM on March 22, 2012 [3 favorites]

Also - control-shift-delete, city clearing your cache and cookies. That usually helps me when a page is acting oddly.
posted by oceanjesse at 3:18 PM on March 23, 2012

« Older Suggestions for fine art Torah, Bible, and Quran...   |   Dunnnnnnnnnnn Newer »
This thread is closed to new comments.