When I watch a movie, you don't have to worry about maintenance, computer!
April 20, 2011 4:54 PM   Subscribe

How do I keep my Windows 7 computer from deciding it's time to update when I'm watching a Netflix Watch Now movie full-screen? (It really breaks the mood.)
posted by Jonathan Harford to Computers & Internet (9 answers total)
Start > Control Panel > Windows Updates. There's a setting in here where you can be the one to choose when updates are downloaded/installed. Kinda sucks that it's so intrusive... I feel your pain.. every time I do a Windows OS installation I go through this procedure so that it doesn't dump work that's been left unattended.
posted by crapmatic at 5:04 PM on April 20, 2011

Auto updates can be set for certain times, the default is 3AM - unless it's a laptop or a system that's not on at 3AM, then it will do it whenever it can once it's on. The options are to change your auto update settings to notify you, but not actually install the updates until you do it (which means you need to actually go DO it once in a while), or disable auto updating completely (and really make sure you go do it once in a while), or leave it on...
posted by pupdog at 5:05 PM on April 20, 2011

Response by poster: UPDATE: I am posting this comment during an unexpected reboot twenty minutes into Get Shorty.
posted by Jonathan Harford at 5:26 PM on April 20, 2011

You can extend or suppress the auto-reboot period. I googled "increase time windows reboot update" which is inelegant, but worked. I've always extended the time period, as it's always inconvenient.
posted by theora55 at 5:30 PM on April 20, 2011

FWIW, I shut off my updates completely, it must be about 18 months ago now, with no ill effects.
posted by Flashman at 6:13 PM on April 20, 2011

That doesn't sound quite right to me. I've encountered something like this on my television PC. But that only happens when I only turn it after patch Tues and haven't run the updates. With it off most of the time it doesn't pick up the updates like my always-on PC. A patched box should only needs to reboot once a month at most. If this happens more frequently than that, something's screwy.
posted by BeerFilter at 6:58 PM on April 20, 2011

You can also use the Group Policy Editor to disable restart upon update.
posted by sockpup at 7:04 PM on April 20, 2011 [1 favorite]

Sorry now that I see this was already posted.
posted by sockpup at 7:06 PM on April 20, 2011

Don't turn off auto updates completely unless you plan to manually install them frequently. Malware that exploits bugs fixed by updates is real.
posted by jeffamaphone at 7:53 PM on April 20, 2011 [1 favorite]

« Older Indie Songs of Sex   |   Help me get this job! Newer »
This thread is closed to new comments.