apt-get screwed my network interface!
May 6, 2005 10:54 AM   Subscribe

Lords of Linux! Demigods of Debian! I beseech thee. I inadvertently apt-get installed etherconf, and it nuked my ethernet interface!

I was doing an "apt-get upgrade apache", to get on the latest version. It presented me with a list of packages it wanted to upgrade in conjunction, and I blithely accepted. Well, it started churning away, and then it said it was installing etherconf. At this point I lost my ssh session to the server.

I drove down to the office to log on and see what was up. Logged on locally, I can see that it's not recognizing the eth0 interface anymore. Ifconfig -a just shows lo0, 127.0.0.1.

I ran "dpkg-reconfigure etherconf" and it says that the interface detector can't detect any network interfaces. Argh! After exiting from etherconf I get a message to the console: "eth0: ERROR while getting interface flags: No such device"

This nic was easily recognized by Debian when I did the initial install. It's been a few years, so I have no idea what kind it is, or where the drivers are, but I figure if I can get Debian to do whatever detection magic it did on the initial install, it will be able to recognize this card again. It's something very generic, like a Netgear, or an IBM card.

Oh, and I checked out /etc/network..
It still has eth0 listed in the interfaces, though it decided to change the ip address from .106 to .110. I changed it back and tried rebooting. No good!

Anyone got suggestions? I suppose I can reinstall Debian on another hard drive and try copying files over, but that sounds like it will be a long, dreary process.
posted by jojopizza to Computers & Internet (7 answers total)
 
calm down, dude.... i don't fully grok what's happened but it sounds a lot like you just had a network problem. have you wiggled a few wires? unplugged and reseated the card? run ifup and ifdown a couple of times? made sure that things work with a separate machine?

i wouldn't start reinstalling stuff for a while yet!
posted by andrew cooke at 11:21 AM on May 6, 2005


Apparently the answer was: modprobe eepro100

Makes eth0 recognizable again... but it doesn't last through a reboot.
posted by jojopizza at 11:45 AM on May 6, 2005


Put "eepro100" on a line by itself in /etc/modules.conf and it will be loaded when the computer boots up.
posted by knave at 11:50 AM on May 6, 2005


actually, the file to put it in is /etc/modules.
posted by zsazsa at 12:03 PM on May 6, 2005


Thanks everyone!
posted by jojopizza at 1:36 PM on May 6, 2005


jojopizza - I know this doesn't answer your original question, but keep in mind that rebooting and reinstalling is not generally required with Linux or BSD. Unless you are working with a plain vanilla install, you shouldn't even consider these options.
posted by bh at 4:31 PM on May 6, 2005


I prefer modconf for installing kernel modules. It gives you a categorized list of all the modules on your system, and it adds/removes them from /etc/modules when you load/unload them using its interface.
posted by yarmond at 12:42 PM on May 7, 2005


« Older DNA extraction from sperm   |   Simple sound recorder Newer »
This thread is closed to new comments.