photoshop files I create often don't include previews. how do I fix that?
April 8, 2011 5:11 AM   Subscribe

photoshop files I create often don't include previews. how do I fix that?

I noticed that a lot of the psd files I create on various macs using cs3, cs4 and cs5 can't be previewed from within the finder. (see this screenshot) the error message gets displayed when you hit the spacebar to preview the image, too. this doesn't seem to happen with all my psd files but I do get it quite often. since those files cannot be previewed by other macs on my network either I presume there is some setting off in my savings dialogue.

only which one? how do I convince photoshop to create a preview image for this space, which seems to not be the thumbnail

I already have photoshop set to always save a preview image within the preferences. I also have it create a psb file but that didn't help either.
posted by krautland to Computers & Internet (6 answers total) 1 user marked this as a favorite
 
I spent a few minutes looking at my preferences panel this morning but (in CS5) didn't find the options that I remember from earlier versions.

What you need is a full size, flattened copy of the entire image to be saved along with the layers. I forget what this option was called, but unless it's now rolled into "maximize compatability" then I don't know where to find it any more.

Do you have "maximize compatability" enabled for psd/psb files? Does the problem only occur for multi-layer files?
posted by devbrain at 6:19 AM on April 8, 2011


yeah, I did enable maximize compability but it didn't do a thing. also yes on the multi-layered files. most of the psds I am currently experiencing this with are 70-300 layers. perhaps it's got something to do with them being too complex but I don't really want to accept that I can't do anything about it. it seems to happen with files created on some macs but not all. I have one coworker who doesn't have this problem at all, number of layers being totally irrelevant. sadly he isn't here right now and I can't check his preferences.
posted by krautland at 6:27 AM on April 8, 2011


that's the generic adobe "this file cannot be previewed because it's missing PDF compatiility" message. i see it all the time on .ai files, as long as they're saved earlier than CS. (i ran a test and saved an .ai file down to previous versions until i made it happen, to see how many versions it would take).

i've never seen that on a .psd before.

have you checked for differences between the OS version of the macs? it could be an issue with the quicklook plugin for either PSDs or PDFs, rather than your own PSD files.

quicklook plugins are stored in HD/Library/QuickLook/ and will be called (filename).qlgenerator.

the system level quicklook generators are in HD/System/Library/QuickLook/ and contains the default PDF viewer.

(article about what QL plugins are and do.)
posted by patricking at 8:16 AM on April 8, 2011


that sounds like a really great clue, thank you. I'm at home right now (where the issue doesn't appear but I'm running cs4 and 10.6.7 here, which is exactly the same as I am at work, so what gives?) but I'll investigate that further as soon as I am back at my office mac. which, sadly, will be sunday.
posted by krautland at 2:34 PM on April 8, 2011


Krautland, check your preferences. Under "File Handling" make sure you have "Maximize Compatibility" ticked.
posted by LuckySeven~ at 7:27 PM on April 9, 2011


I'm gonna have to stop posting in a hurry; I see from the previous suggestions you've already tried maximize compatibility. Sorry.

Here are my settings in CS5, for what it's worth:
File Handling:
File Saving Options -->Image Previews -->Always Save
Icon (Checked)
Windows Thumbnail (Checked)
Append File Extension ---> Always
Use Lower Case (Checked)
Save As To Original Folder (Checked)

File Compatibility
Prefer Adobe Camera RAW for Supported RAW Files (Checked)
Ignore EXIF profile tag (unchecked)
Ask before saving layered TIFF files (Checked)
Maximize PSD and PSB file compatibility (Always)

All of my .psd thumbnails are viewable in Finder.

Other things you might want to try:
1. Command + i on one of your .psd files to get info, on open with, change all to open with Photoshop. If that doesn't work...

2. Reset launch services.

Good luck.

posted by LuckySeven~ at 11:36 PM on April 9, 2011


« Older Career woes : digital project manager vs. software...   |   Help me replace my bedroom door with a cat... Newer »
This thread is closed to new comments.