gmail 'reply all' wierdness with mailing lists
March 10, 2011 5:40 AM   Subscribe

Google seems to have changed their 'reply to all' feature recently for lists with a 'reply-to' email address specified. Now when you click 'reply all' it sends an email to the person who sent the mail as well as to the list. I'm on a list where like 90% of the people use gmail and it's causing a problem, because some people habitually click 'reply-all' and some people usually click just 'reply'. What happens is, I'll click 'reply all' to an email, and some other person will click only 'reply' to mine and the reply will go back to me personally, instead of the list. Is there a way to revert this behavior?
posted by empath to Computers & Internet (9 answers total) 1 user marked this as a favorite
 
Are you sure this is a change to Gmail and not a change to how your mailing list specifies its Reply-To address? I have been using various YahooGroup mailing lists for ages with Gmail, and their Reply-To settings can be different for different YahooGroups:

YahooGroup 1:
Reply - goes back to sender only
Reply All - goes to sender, and CCed to mailing list.

YahooGroup 2:
Reply - goes to mailing list
Reply All - goes to mailing list, and CCed to original sender.

It depends on whether it specifies a the Reply-To address as the mailing list address (YG2 above), or if it doesn't specify a Reply-To address at all (YG1 above) which causes the original sender to be the default reply address.
posted by EndsOfInvention at 5:57 AM on March 10, 2011


Add a "reply-to" or "Mail-followup-to" header to emails you send to the list?
posted by pharm at 5:58 AM on March 10, 2011


YahooGroup 2:
Reply - goes to mailing list
Reply All - goes to mailing list, and CCed to original sender.


This is how it's working currently. But if you hit 'reply' to one which was 'reply all' to you and the list, then it does not go back to the list.

This is, btw, a new change. I've been on this email list for years, no one has changed the settings and this just started like 2 months ago.
posted by empath at 6:05 AM on March 10, 2011


Okay, more details:

emails that say sent 'to list'

have reply-to: list@example.com in the header.

emails that say sent 'to list, extra person'

also have the correct reply-to in the header.

But, emails that say sent 'to list, me'

do not have the reply-to in the header.

So I think what the problem is that when I get an email sent both to the list and to me, that gmail is displaying the email sent to me directly instead of the list email.

I don't know whether what's changed is 'reply all' sending an email to the person who wrote the original mail as well as to the reply-to address, or whether it's changed which email gets displayed when you get an email sent to the list and you personally.
posted by empath at 6:13 AM on March 10, 2011




This is happening. It happens to me. I hit reply to all and get the same characteristics. Sends mail to list and sender. I like it, but it would help if you could decide to turn it on or off.
posted by JohnnyGunn at 6:27 AM on March 10, 2011


You're not alone. My VERY VERY active mailing list for my RPG noticed this in the last week and it is driving us batty. All of our research suggests it is something internal to googlegroups, and not a setting we can change, so I think your best bet is to email google and report it as a bug, and suggest they add the option to put it back to the way that doesn't suck.
posted by FritoKAL at 6:30 AM on March 10, 2011


I noticed this too, and find it extremely annoying. Sorry, no answer, though, just commiseration.
posted by torticat at 6:55 AM on March 10, 2011


Totally not an omnibus solution, but there is a Gmail labs that makes "reply to all" the default, which might solve (or put a bandaid on) the problem. If it turns out that it works, each person on Gmail would have to enable it on their own though.
posted by urbanlenny at 10:00 AM on March 12, 2011


« Older Answering this question will make you better in...   |   What should I be wearing while kayaking this... Newer »
This thread is closed to new comments.