Adobe Photoshop Elements 8 for Macintosh Text question
September 27, 2010 11:43 AM   Subscribe

How do I get Adobe Photoshop Elements 8 for Macintosh to enter text on my pictures?

I'm trying to use Adobe Photoshop elements 8 for the Macintosh. I have combined some pictures on one page and would like to add text underneath the pictures. I click on the text tool, set up the text parameters as I want, click the check mark to accept, then click on the pictures to place the text I'm going to type, which creates a text layer. The problem is that when I type nothing shows. When I click off of it, what I typed becomes the label for the layer, but nothing shows on the picture or page. How can I get the text to show up under the pictures. I've tried inserting a solid rectangle shape to type the caption in, and the same thing happens. The users guides and tutorials are no help
posted by hdh to Computers & Internet (6 answers total) 1 user marked this as a favorite
 
I can't quite imagine the scenario, but here are some issues that might be coming up:

1) the text is the same color as the background. I believe there is a separate text color option, beyond the foreground and background color selectors

2) the font size is too large for the box, making the text wrap in a non-functional sort of way. Play with the font size until something appears.

3) if the image format is a fixed palette (as it is with GIFs), text might be working differently (but it sounds like there is a new layer being created, so I'm not sure if this is could be the case).

Alternative solution: instead of setting a text box, can you simply click with the text tool where you want the text to start? You can't format the text in terms of defining the text field, but you won't get weird wrapping issues if the font is too large or the space isn't sufficient for everything you want to type.
posted by filthy light thief at 11:49 AM on September 27, 2010


Make sure the text layer is on top. If it's buried beneath an image layer, you wouldn't see it.
posted by sageleaf at 12:02 PM on September 27, 2010


So far none of your suggestions have made a difference. Thanks for trying. Could Snow Leopard have anything to do with it?
posted by hdh at 12:25 PM on September 27, 2010


• Opacity for the text layer is 100%?
• Depending on the size of the image, it may be that your font size is actually too small. Try text at a huge number...150pt, for instance...and see what happens.
• The font layer isn't acting as a mask, is it?

Have you tried setting the text in a brand new blank document? If that works, try copy/pasting from the new doc to the old.
posted by Thorzdad at 12:43 PM on September 27, 2010


I got it to work but very strangely. I saved the file as Photoshop Raw and tried opening it up on an older version of Photoshop elements (4.0) It came up with some of the fonts weren't in that version and would replace it with a known font and sure enough some of the text showed. Some was white, so I changed the color to black and fixed it up. I had to move some of my white boxes to background to show the text. Then saved the file as a .jpg.

I went back to my newer version of Elements and reopened the original file, and the all of a sudden everything showed. Who knows why. I had to play with fonts and moving things to the foreground, but all of the fonts were black, not the white that was in the 4.0 version.

For whatever reason, it worked and I got what I needed done. Thanks for all of your help and ideas.
posted by hdh at 1:00 PM on September 27, 2010


It seems like it happens like clockwork. I'll use a paint program for around five minutes, then I'll try to do something perfectly reasonable, something that has always worked before. Only this time, it won't. Sometimes it was something I just did in the same document.

Most of the time when it happens, it's because there is a selection or mask in effect I didn't mean to apply. Most paint programs, if anything in the document is selected, will prevent any changes from happening to anything else in the document. This has tripped me up many times. Try going under the Edit menu and selecting Deselect All.

If that didn't work, try making sure the selected layer is visible, its opacity is 100%, that there isn't a visible layer between the intended layer and the active one that is hiding your changes (check if the changes are visible in the little preview image in the layer docker) that the current color isn't transparent, and that the current color's opacity isn't 0% (which might be a different thing depending on the program).
posted by JHarris at 2:35 PM on September 27, 2010


« Older Haaaaaaaaaaaaaaack   |   Should I try to learn two languages at once? Newer »
This thread is closed to new comments.