Mac OSX and Gmail Aren't Playing Nice
September 19, 2010 10:41 PM   Subscribe

Mac OSX (Safari) and Gmail: why do 'read' and 'unread' messages always look the same?

When I use Gmail on my Windows 7 machine, no matter what browser I use, all the 'unread' messages are in bold font and all the 'read' messages are in regular font.

When I use Gmail on OSX, using Safari (but I've noticed it in Chrome too), all messages appear to be in bold font.

Here's a screenshot.

I've checked Safari settings but nothing jumps out, and the fact that it happens in Chrome leads me to suspect it's not a browser problem.

Other details:

MacBook Pro 13"
OSX Snow Leopard 10.6.4
System Preferences under the 'Appearance' are set to the following:

"Turn off text smoothing for font sizes 6 and smaller."
posted by jnrussell to Computers & Internet (12 answers total) 2 users marked this as a favorite
 
It's not just the messages, EVERYTHING is bold on that page, and it shouldn't be. Perhaps your Helvetica font got overwritten by Helvetica Bold? That sounds weird though.
posted by yaemes at 11:17 PM on September 19, 2010


That's a good question, but doesn't appear to be the case. I don't think I've ever messed with Helvetica (I've added other fonts to Font Book, but never messed with Helvetica that I can recall). Here's a screenshot of Helvetica Regular in Font Book next to Gmail in Safari. Also, Helvetica is the default in Pages and I've never had issues switching between regular and bold in that program.
posted by jnrussell at 11:39 PM on September 19, 2010


I'd check userstylesheets and extensions. Does it work in Firefox?
posted by yaemes at 11:41 PM on September 19, 2010


Same issue in Firefox. And now that yaemes mentioned it, I'm realizing that pretty much everything that uses Helvetica is looking like that... for example if I go to a website that uses Verdana, it looks just fine. So maybe it IS a problem with my Helvetica fonts. But what on earth could I have done? How can I fix it?
posted by jnrussell at 11:47 PM on September 19, 2010


The MD5 of Helvetica.dfont in /System/Library/Fonts/ should be dd65abb99849448101a8eca61e9e0781


Find your Helvetica's MD5 by pasting md5 "/System/Library/Fonts/Helvetica.dfont" into Terminal.
posted by yaemes at 11:53 PM on September 19, 2010


The MD5 matches. (screenshot)
posted by jnrussell at 12:00 AM on September 20, 2010


This is madness...
posted by yaemes at 12:19 AM on September 20, 2010


The operating system caches typeface data for added performance. If the cache gets corrupt, text can be displayed incorrectly.

Try removing this font cache. Open the Terminal application and type in the following:

sudo atsutil databases -remove

Enter your password, press Return, then log out and log back in. Try viewing Gmail again with your browser of choice.
posted by Blazecock Pileon at 1:30 AM on September 20, 2010


Ok, I tried that, no dice. I also repaired disk permission and reset PRAM just for kicks, then I completely Safari, Chrome and Firefox (used AppZapper) and used Omniweb (same results) and re-downloaded a fresh copy of Safari. Still no change.
posted by jnrussell at 7:46 AM on September 20, 2010


er, I mean I completely removed those browsers using AppZapper.
posted by jnrussell at 7:47 AM on September 20, 2010


I managed to fix the problem. I had assumed that all my browsers were using Helvetica to render Gmail's fonts, but had not bothered to check. Gmail is using Arial (naturally) and for whatever reason I don't have a non-bold Arial weight. So I went in to Font Book and disabled all Arial variants, and now Gmail (and other sites) renders in Helvetica with expected weights.

It's probably not a true fix, but I never use Arial in the first place so it's a good enough workaround for me.

Thanks to everyone for all your great ideas, and even though it seemed like I sent you all on a wild goose chase just the fact that you made me think more about the font issue (rather than browser or system prefs) helped me find an answer.
posted by jnrussell at 8:45 AM on September 20, 2010


Interesting problem nonetheless.
posted by yaemes at 1:32 PM on September 20, 2010


« Older Ways to Read Books On ipod   |   Ironic Print Ads with Pop Culture Reference? Newer »
This thread is closed to new comments.