IE Hangs
February 7, 2005 6:38 AM   Subscribe

Internet Explorer hangs (locks up itself, though I can switch to and use other programs) for about 20 seconds when I type in a new url in the address bar, and then loads the site as usual. No such lag if I click on a link or a bookmark. No such problem in Mozilla. I'm running XP.
posted by Framer to Computers & Internet (9 answers total)
 
Have you run Windows Update lately? Have you checked for spyware, trojans and worms? (oh my)
posted by sic at 7:12 AM on February 7, 2005


Is the lockup when you begin typing the URL? It probably just means there are a crapload of entries in your history, and it's loading them all up for the Autocomplete. Either turn Autocomplete off or clear your history.
posted by neckro23 at 7:26 AM on February 7, 2005


Yep. All clean and current.
posted by Framer at 7:30 AM on February 7, 2005


I'm guessing you're typing the URL as "metafilter" or "metafilter.com"? I'd suggest typing the full "http://www.metafilter.com" instead. Sometimes if I just type "google," IE decides to do strange things like an MSN web search for "google."
posted by Sibrax at 9:21 AM on February 7, 2005


You can try typing "regsvr32 urlmon.dll" in the run box. This fixes some of those sorts of IE problems. I've had only mixed results. Also, are you using a proxy? One of the weirdest fixes I've come across with IE is putting a space anywhere within the proxy exception list, thus eliminating timeouts from links clicked from outlook or elsewhere (I know this isn't your problem, but IE is one flaky bird sometimes).
posted by jikel_morten at 9:23 AM on February 7, 2005


Clearing out Temporary Internet Files does untold wonders.

Also, it bears repeating that you really should stop using IE as much as possible. This is just another reason why.

You probably have a perfectly good reason to use IE though.
posted by grouse at 9:41 AM on February 7, 2005


It sounds like the explorer part of the app is looking for a network share it can't find. Do you have a network the machine is on?
posted by ontic at 10:10 AM on February 7, 2005


Actually, I bet money to donuts you have a proxy specified in IE settings, and that proxy can't be found

Go to Tools -> Internet Options -> Connections -> LAN settings. See if you have a proxy server specified in there. This can happen if you are using a work computer, or if your internet connection provider put one in at the time of setup). If you have anything in there, disable it and see what happens.
posted by blindcarboncopy at 12:55 PM on February 7, 2005


I've noticed similar behaviour in Firefox with the A9 toolbar after I've visited an https address. I therefore guess that you've got something looking up each address you type. A9 and Netcraft are benign examples. I'd suggest running Lavasoft's Adaware with the latest patterns.
posted by krisjohn at 8:45 PM on February 7, 2005


« Older Please suggest books in which a moon colony rebels...   |   Name that Kleptones vocal Newer »
This thread is closed to new comments.