Dreamweaver CS3 Not Acknowledging Code Formatting Preferences
February 7, 2010 10:41 AM   Subscribe

Dreamweaver CS3 forgets preferences and improperly formats code, it won't insert line breaks where I set it to in the tag libraries...I've tried everything. In particular, the ul/ol/li/p tags do not format correctly.

I want each ul tag to have breaks before, inside, and after, and each li tag to have breaks before and after, but DW puts everything on one line, ALWAYS!

This pattern seems to correspond exactly to the preview I see when I go to Preferences > Code Format > Tag Libraries, select the tag and customize the line breaks...however, the Code view doesn't reflect this, and when I use Design View to create the list, OR if I alter a properly formatted list in Design view, everything gets squeezed onto one line.

Here is what I have tried unsuccessfully to date:

1. Prefs > Code Formatting > Edit Tag Libraries...
2. Prefs -> line breaks (tried Unix, Windows)
3. Commands > Apply Source Formatting (messes up my entire code by putting everything in the body tag on one line - in other words, my entire page goes on one line. ARGH!!!)
5. Automatic Wrapping After Column 76 - this one is really stupid, it just
does a HARD break on each line so when you turn it back off you have to go in and manually delete all these hard breaks...

Has no one else experienced this? Can you get Design View to properly format tags? If so, then something on my computer is horked. But when I look at code generated by DW on some of my coworkers' computers, they also have the same problem - I just guess their tolerance for crappy code is higher than mine.

My preferences in DW also decide to "revert to default" about 2x a month, randomly...I have NO clue about this one...sigh. I've repaired permissions to no avail.

Please help!
posted by workinprogress to Computers & Internet (7 answers total) 1 user marked this as a favorite
 
I use Dreamweaver CS3, and I can't get it to do what you are saying yours does.

The default settings match what you say you want ( I use Windows line breaks and I do not use wrapping).

Double check the settings for the "html" tag, just to make sure that's not borking things up. (The only place I'm aware of that you can specify code all on one line is in the CSS formatting.)

It may be working in Design View that's doing it. I have never worked in Design View, so I can't say one way or the other.

I'd try a reinstall. Backup your sites, uninstall the existing copy, use a registry cleaner like CCleaner or RevoUninstaller to remove orphaned registry keys and reinstall new.
posted by Benny Andajetz at 3:24 PM on February 7, 2010


Thanks for the quick reply, Benny!

I neglected to mention that I'm on a Mac, 10.5.8, and have DW set to use Unix line breaks.

I spent a TON of time customizing my code colors and preferences, but have backups of all. I think you may be right and a complete reinstall may set me to rights again, but it seems like DW should obey me, silly app!

I'll wait a couple days to see whether anyone else has a workaround, then try removing/reinstalling.

Thanks again!
posted by workinprogress at 3:30 PM on February 7, 2010


Noted: I checked HTML tag library settings, and they are set to "before, inside, and after" and "formatted and indented."
posted by workinprogress at 3:32 PM on February 7, 2010


In my experience, the BR tag isn't going to reliably work in the places you specified, which is probably why Dreamweaver is ignoring it.

What I do instead is add the following CSS declaration:

li { padding-bottom: 10px; }

ul {padding-bottom: 10px; padding-top: 10px;}

(I do all my HTML by hand, so I don't know how you'd do it in Dreamweaver, apologies!)

That's 10 pixels of padding, which looks enough like a line break for my tastes. But obviously you can adjust it at will.
posted by ErikaB at 6:43 PM on February 7, 2010


Meh, it's not the break tags that aren't working, it's that DW ignores my preferences for how the code looks in Code view...it doesn't insert breaks after the tags when I tell it to in the tag libraries, bunching everything up on one line...even tho I have it set to insert line breaks in Code view before, inside, and after a specific tag (li, for example) it still bunches everything up...

I'll keep looking!! Thanks again!
posted by workinprogress at 4:15 AM on February 8, 2010


I MAY HAVE FOUND MY ANSWER!! I tried adding .html to the list of files NOT to rewrite in the preferences, and it to work...I'll have to test further, but this makes me SO happy!
posted by workinprogress at 4:54 AM on February 8, 2010


I've found that Dreamweaver will sometimes just randomly refuse to insert line breaks, even just using the keyboard Shift-Enter - a day later, without even a reboot it will start working again.
posted by Lanark at 4:23 AM on May 3, 2010


« Older What are the terms and lease rates for cell tower...   |   I need to find an herb shop in S. Ohio. Help me... Newer »
This thread is closed to new comments.