Slow Airport Extreme Data Transfers Using Windows 7
February 4, 2010 7:03 PM   Subscribe

Does anyone own one of the new dual band Airport Extremes, using it to access a USB Hard Drive externally, and use Windows 7? If so, how is it working for you? Because it's not working real great for me at the moment. If you're a WiFi guru or you have a perfectly functioning AE with a similar setup, please help me out!

I own one of Apple's new Airport Extreme base stations. I use it to wirelessly access my USB hard drive with my late 2009 model MacBook Pro, which runs Windows 7, from around the house.

Problem is that data transfer between my computer and the wireless hard drive is sloooooooooow. The drive works fine; if I plug it directly into my computer via USB, transferring data takes a very short amount of time. But if I access it via WiFi, even with my laptop sitting right next to the AE, well, like I said... it's very slow.

The way my network is set up is is as follows. I have a Billion Wireless Modem generating my access point. I've set it to use WPA2 TKIP and to use 802.11g. My Airport Extreme is set up to join that network wirelessly, which it does with ease. This allows both my laptop and my wife's laptop to access the drive. Albeit slowly.

Apple says that the AE should automatically work out what the best band to use is, so since its capable of a+b, g and n, it should have automatically set itself to use Wireless G, since that's what the router is set to generate. But when I try to copy data from my computer to my hard drive, what usually happens is this.

1. If I'm using Windows Explorer, the transfer will usually time out.

2. If I use Total Commander, the transfer seems to hang for a few seconds before beginning, and then I get transfer speeds of around 800kb/s. Surely I should be getting faster speeds than that if I'm using 802.11g?

I have switched off Windows Firewall and I use Comodo in its place. I suppose Comodo could be to blame but I wouldn't know how. Plus I've tried closing Comodo completely and file transfers happen just as slow as always.

Reading the Apple support forums, there seem to be similar complaints from other users with setup's similar to mine, but there also seem to be many people who've said they have no problems at all. So I'm wondering if there's some sort of setting I need to change that could fix things? Apple doesn't seem to be forthcoming with answers or a firmware update so in the meantime, I'm hoping the Hive Mind can provide some ideas.

Any help you can provide would be much appreciated.
posted by Effigy2000 to Computers & Internet (13 answers total) 1 user marked this as a favorite
 
are both laptops Windows 7? what's the speed like when you try to do the transfer from Mac OS X?
posted by mrg at 7:31 PM on February 4, 2010


802.11g isn't that fast, which might be explaining your troubles. I'm not sure if 800 kb/s is particulary low, high or to be expected from an 802.11g network, but here are a few suggestions anyway. Is there a reason you have two wireless access points? If it's because you want to provide legacy wireless compatibility, then I suggest leaving the 'Billion Wireless Modem' providing 802.11g, and the AirPort Extreme providing 802.11n. Provided that the two are connected via ethernet (which they should be), then you should have no problems and all the computers will be on the same network. Of course, only one of them can act as a DHCP server, but I'm guessing this is already setup or else your AirPort base station at the very least would be complaining a lot. ]

Connecting directly to an 802.11n-only network will provide the most decisive speed boost. Other than that, the most obvious problem I can see is that your AirPort base station may be connected to your 'Billion Wireless Modem' via wireless, which will compound the inherent slowness of 802.11g. I might just have misinterpreted your choice of words, however.
posted by jaffacakerhubarb at 7:40 PM on February 4, 2010


Oh, and one thing I forgot: give the two access points different names if you decide to follow your advice, otherwise things will rapidly get confused. :)
posted by jaffacakerhubarb at 7:42 PM on February 4, 2010


"Is there a reason you have two wireless access points?"
posted by jaffacakerhubarb at 1:40 PM on February 5

I don't. I only have one access point, the Billion wireless router which is set to use 802.11g (it's fastest setting). The Airport Extreme connects to that network. So basically if my laptop is accessing the hard drive, it does so via the router. Sorry if I wasn't clear on that.

"If it's because you want to provide legacy wireless compatibility, then I suggest leaving the 'Billion Wireless Modem' providing 802.11g, and the AirPort Extreme providing 802.11n."
posted by jaffacakerhubarb at 1:40 PM on February 5

The Airport Extreme software dosen't allow me to choose whether I use a+b, g or n. I assume this is because, as Apple says, the AE automatically choses whats best. But if someone knows a way to force the AE to use g, please do let me know!
posted by Effigy2000 at 7:47 PM on February 4, 2010


"are both laptops Windows 7? what's the speed like when you try to do the transfer from Mac OS X?"
posted by mrg at 1:31 PM on February 5

Yes, both laptops use Windows 7. I've not tried using MacOS, mainly because the external drive isn't formatted to a compatable file format (it's using FAT. I know, I know I should go to NTFS but that's a big job and it'll be one for another day).
posted by Effigy2000 at 7:49 PM on February 4, 2010


You only have on access point. OK. The bit that I'm confused about is that you say you only have one access point, but the AirPort Extreme must be doing something wirelessly. Perhaps you have an extended network? Either way, we'll try and forget the non-AirPort router for the time being.

That's right — the AirPort Extreme will usually default to a/b/g/n, or something like that, switching down to the lowest common denominator — so if you have ten 802.11n-capable devices and one 802.11b, they all have to be on 802.11b. Regardless, there is a way to force it, and thankfully it's a simple one! Hold down the alt key and click on the network type dropdown menu. I'm not currently anywhere near an AirPort base station of any kind, so I can't remember exactly what it looks like, but you want something to the effect of '802.11n only'. They're fairly sensibly labelled, so it shouldn't be too hard to find. And again, don't forget to change the name so the two don't conflict and freak each other out (you can use the same password to connect though). Then, provided it's 802.11n compatible, connect the Windows laptop to what should now be a newly visible access point, and your transfers should straight away be a lot quicker.
posted by jaffacakerhubarb at 7:54 PM on February 4, 2010


Bah, another quick edit-type post. I forgot you were on Windows! You'll have to right click, or whatever the Windows equivalent to alt-clicking is (shift? CTRL?). Apologies for the typos and assumptions, it's nearly 4am here!
posted by jaffacakerhubarb at 7:56 PM on February 4, 2010


The bit that I'm confused about is that you say you only have one access point, but the AirPort Extreme must be doing something wirelessly. Perhaps you have an extended network?
posted by jaffacakerhubarb at 1:54 PM on February 5

There were basically three available options when setting up the Airport Extreme.

1) I want to extend my wireless network wirelessly
2) I want to extend my wireless network via an ethernet cable connected to my router
3) I want my AE to join my existing network.

I chose option 3. In doing so my AE dosen't create it's own wireless network (as Option 1 did) and instead it joined my existing network. So as I said, my laptop would therefore access my hard drive as follows;

Laptop --> Router --> Airport Extreme

I will try the method you describe to force the AE to use g when I get home tonight (5 hours from now). I'll let you know how I go.

"Apologies for the typos and assumptions, it's nearly 4am here!"
posted by jaffacakerhubarb at 1:56 PM on February 5

Think nothing of it. I appreciate the assistance!
posted by Effigy2000 at 8:19 PM on February 4, 2010


You are getting exactly the speed I would expect. Currently, to get data to your Airport extreme, it's a wireless hop to your router, and another wireless hop, over the same channel, to the Airport Extreme. Congratulations, you have just cut your available bandwidth in half. On a good day I can get 2.8MB/sec over g, cut that in half, plus additional collisions etc, puts you right in the 800k - 1MB / sec range.
posted by defcom1 at 8:24 PM on February 4, 2010


Reading your latest post (missed the preview!), can you turn off the radio in your AE and hook it into your network via ethernet cable? It will significantly impact your speeds (in a positive direction)
posted by defcom1 at 8:26 PM on February 4, 2010


Personally, I'd do it the other way around - turn off WiFi in the Billion, cable it to the AE, and use the AE's faster 801.22n.

AE's from the last few years have 2 wireless modules, allowing them to operate in 2.4Ghz (b,g,n) & 5GHz (n only) bands simultaneously. I know you can't config them separately (i.e. 1 as a client, one as an AP), but it'll work nicely as an AP in both bands. This'll let you use n on 5Ghz for your laptops, plus b/g for anything else (e.g. iPhone / Touch).

Aside from that, yeah. In fact, I'm a little jealous of your throughput - I get about half that (400~500Kbps) with a couple of Expresses in WDS mode on g, though that's probably constricted by the slow NAS (WD MyBook) on the WDS client end.
posted by Pinback at 9:22 PM on February 4, 2010


Seconding Pinback's answer. For some reason I thought there was something restricting your use of the wireless on the AE.
posted by defcom1 at 10:07 PM on February 4, 2010


I did what Pinback suggested and after some major restructuring of my WiFi network, I'm now pulling down between 6 to 8MB/sec on data transfers between my computer and the external hard drive.

There's still a moment or two just before the file transfer starts where it looks like it's hanging (WTF?) but overall there's been a massive improvement in speed. Thanks pinback! Thanks everyone!
posted by Effigy2000 at 3:15 AM on February 7, 2010


« Older Identify inscriptions on wood beams in a shogun...   |   My chickens! No eggs! WTF? Newer »
This thread is closed to new comments.