Mail.app/IMAP: Prior Day's E-Mails Unfile, Dupe, and Unfilter Themselves?
January 19, 2005 7:28 PM   Subscribe

Weird Apple Mail/IMAP Problem: When I wake up in the morning, I often observe that the following has happened: all the emails that arrived in my Inbox the previous day, which I duly filed away in appropriate folders, have appeared again in my Inbox, so now I have TWO copies of each. More bizarrely, my filters have not been applied, and many emails which usually get routed right away to their own folders are still in my Inbox. What's going on?

Oh, one more note: these new messages are marked unread, as are any actual new mail I might have received, and the main reason this is a problem is that it's a pain to sort out the new from the old.
posted by rustcellar to Computers & Internet (7 answers total)
 
This is just a guess, rustcellar, but I think your client, Mail, someone corrupted one of its settings--most likely its list of already downloaded mails--and purged it, thereby "forgetting" that it had downloaded all those mails already. So it downloaded them again. This happened to me a few times in Eudora, but never yet in Mail.
posted by squirrel at 7:38 PM on January 19, 2005


It happens to me once in a while in Mail.app...

Check out Andreas Amann's Freeware Mail scripts (Remove Duplicates especially).
posted by maniactown at 7:38 PM on January 19, 2005


I think your client, Mail, somehow corrupted one of its settings
posted by squirrel at 7:39 PM on January 19, 2005


Okay, well I just found a "automatically synchronize changed mailboxes" check box under Advanced Preferences (with a warning to consult your sysadmin first, natch). We'll see if that fixes things.

That looks useful, maniactown. Probably would reduce my mailbox size by 10 MB just to run that once.
posted by rustcellar at 7:45 PM on January 19, 2005


try doing "compact folder" (pretty sure mail.app lets you do that, or am I thinking of thunderbird?) on a folder, right after you move/delete some stuff. sometimes imap servers handle these things in a 'lazy' way and you hasta force them...
posted by dorian at 8:22 PM on January 19, 2005


This sounds like synchronization failing. The messages aren't being removed from the online version of your inbox. Mail (I presume) keeps a list of items its already filtered, so that it only applies them to new mail. When it checks your mail in the morning, it notices you have a load of messages flagged as unread on the server, that it knows you've seen before. It therefore assumes you've maybe copied them after the filters were run, and it doesn't bother checking whether they exist in other mailboxes.

One thing to try is to select "Mailbox > Synchronize" before you go to bed, though this does take a while if you have a lot of mailboxes on the account. That option you've found might help too.
posted by cillit bang at 8:27 PM on January 19, 2005


This sort of thing has happened to me with IMAP before too. I haven't ever used Apple Mail, but the problem for me is caused by not expunging deleted messages. If my connection times out, then all the previously deleted/moved messages come back to life, just as you described. If there's a manual expunge command, try using it regularly or before closing the program. Also check if there's a way to automate the expunging.
posted by stopgap at 9:34 PM on January 19, 2005


« Older Dell Customer Disservice   |   My Keeper has lost its shape. Should I replace it... Newer »
This thread is closed to new comments.