Firefox opening all those startup tabs again and again
December 9, 2009 1:38 AM   Subscribe

Firefox: Multiple-tab-homepage opens a bunch of new tabs every time I click "home", even if 4 out of 5 are still open -- how do I prevent this?

On startup, I want Firefox to open my 5 default morning/all-day websites: google, calendar, newspaper, askmefi etc. That works fine. But when I navigate away from e.g. the google page, and I want it back, I hit home -- now here's my google page in the current tab, and 4 new tabs (even if those pages were already open) with my other startup pages. Result: 9 tabs, one google, and 4 doubles with calendar, newspaper etc.
I cannot find anyone complaining about this behavior, and although it looks like complete expected, I would like FF to check if one of the startup pages was loaded already, and then just reload it if it is... Any ideas/add-ons to accomplish this?
posted by gijsvs to Computers & Internet (6 answers total) 1 user marked this as a favorite
Obvious Idea Time. If you have the bookmark toolbar enabled, can you just create a shortcut for Google? New home button, right below the current one.

My brother's computer is set up with multiple home pages, and it bugs me to no end that 3 to 5 pages open up whenever I hit home. Of courses, that's what home does: it takes you to your home page(s), however many of them you have.
posted by niles at 1:49 AM on December 9, 2009

Response by poster: thanks but no thanks, no bookmark toolbar for me, my screen is small enough as it is -- more obvious ideas?
posted by gijsvs at 1:58 AM on December 9, 2009

The PermaTabs extension would probably serve you better than multiple home pages do.
posted by glibhamdreck at 2:29 AM on December 9, 2009

Here's the how-to from Firefox help.
posted by nangar at 4:58 AM on December 9, 2009

Best answer: Fair enough. After doing a lot of searching around, I ran across this old AskMe question. Looks like the best answer (all the way at the bottom) should do the trick for you.
posted by niles at 10:46 AM on December 9, 2009

Response by poster: niles, thanks for digging that up. As usual, askme has it somewhere...

I actually used SessionManager in the (single-homepage) past but did not know it could do this. Time to reinstall.
posted by gijsvs at 12:53 AM on December 10, 2009

« Older What should I do this summer?   |   Curse you, 70s stoner! Newer »
This thread is closed to new comments.