Keyboard going crazy
November 29, 2009 1:44 PM   Subscribe

Help! Keyboard going haywire – behaving as if Control key is locked ON. But it’s not the hardware (same problem occurs with 2 keyboards.) I’m on deadline and at a standstill. Anybody?

System: Lenovo 3000 V200. Windows XP Pro.

Also: Windows hangs when opening. In Configuration Mode, I can’t use the up and down arrows – meaning I can’t go to last known good config or even Safe Mode. Last change to system: Began update of Quicken, which failed due to keyboard issue.
posted by SallyHitMeOntheHead to Computers & Internet (8 answers total)
 
Have you got Sticky keys enabled?

To check press the shift key 5 times quickly. Then click cancel to turn it off on the dialog box that appears.
posted by essexjan at 1:53 PM on November 29, 2009


Thx Essexian. This is on track. Just clicking cancel didn't do it, but when I went further into the settings I saw points about pressing Ctrl twice to release a combination.

That seems to work. But then it goes back to Sticky Keys. Still under way.
posted by SallyHitMeOntheHead at 2:08 PM on November 29, 2009


Try pressing both CTRL keys at the same time.
posted by essexjan at 2:21 PM on November 29, 2009


Did that. So far so good. Got a full sentence in Word (The quick brown fox jumped over the lazy Microsoft engineer.)

Fingers crossed. Thx!
posted by SallyHitMeOntheHead at 2:34 PM on November 29, 2009


Clearly the sticky keys are the problem.

I can use Essexian's tips to turn them off temporarily, but then they come back on. I'll be typing away, and then -- chaos. In Word, for example, when I type the letter "s", a Save dialog opens -- as though I had pressed Ctrl.

How can I stick these sticky keys to an anvil and drop it in the sea?
posted by SallyHitMeOntheHead at 3:22 PM on November 29, 2009


Go to control Panel - Accessibility Options. The First screen should be on the Keyboard tab and you can untick the Sticky Keys option, or change the settings there.

Hope that helps!
posted by Admira at 4:18 PM on November 29, 2009


This is just a guess, but perhaps you've got a dodgy key somewhere (like the shift key) and when you press it, it actually fires multiple keypresses. As noted above, hitting the shift key multiple times will pull up the Sticky Keys dialog and so maybe it's just automatically activating it when you press the problem key. Try avoiding one of the shift keys for a while and see if the problem goes away. Just a guess.
posted by intermod at 5:42 PM on November 29, 2009


You could have a corrupt driver. Go into device manager, find the keyboard, right click it, go to Properties, driver tab, and you should have the option to uninstall it. Reboot and Windows will reinstall it.
posted by zinfandel at 8:05 PM on November 29, 2009


« Older Remotely buying a computer in the UK from Canada   |   Out of the Flickr group loop Newer »
This thread is closed to new comments.