Playlist on iTunes and iPhone have different songs.
November 20, 2009 9:27 PM   Subscribe

I have a smart Playlist on my iTunes which functions properly and has all the right tracks in it. I have it checked as a Playlist to export to my iPhone. The iPhone has a playlist with exactly the same name ... but completely different songs. I've double checked that I don't have two playlists with the same name in iTunes. Not just one track is different--none of the tracks overlap. Why is this happening?

So far, I've tried:

- resetting to factory settings
- rebooting the phone
- deleting the playlist, synching, recreating the playlist, and resynching

Nothing works. It's driving me nuts. WTF?!
posted by You Should See the Other Guy to Computers & Internet (9 answers total) 1 user marked this as a favorite
 
Have you tried reinstalling iTunes? Or upgrading it, it it's not current? I had the same problem for a bit, and it was solved with an update.

Curiously, I used to have a problem where my "25 most played" smart playlist actually had a selection of my 25 least played songs. To get it to work on my iPod, I actually had to create a 25 least played playlist and sync that, which, bizarrely, gave me my 25 most played on the iPod. Very frustrating.
posted by Admiral Haddock at 9:40 PM on November 20, 2009


Thanks Admiral Haddock. Yeah, it's the latest version.

And my playlist is for 250 most recently added items. I'm gonna change it to "least recently added" and see what happens.
posted by You Should See the Other Guy at 9:43 PM on November 20, 2009


Argh. Nope, didn't work. :(
posted by You Should See the Other Guy at 11:01 PM on November 20, 2009


Is it possible it's no longer syncing music at all? I.e. on the main tab when viewing your iphone there are various checkboxes for what to sync? Perhaps the sync music box got unchecked a while ago?
posted by R343L at 12:09 AM on November 21, 2009


Is the playlist set to Live Update? iTunes 9 has had all kinds of problems syncing Smart Playlists to iPhones. No guarantee that it'll work, but give it a shot. (go to Edit Smart Playlist and deselect the Live Updating checkbox)
posted by sleeping bear at 12:10 AM on November 21, 2009


Yeah, this sounds like the live update bug. You can "fix" it by disabling live updating, but that defeats the purpose of a smart playlist. After some searching I found a simple solution/hack: get info on the playlist and add a new filter condition:
• "Playlist" [is] "Music"

You need to do this to each smart playlist and then re-sync. Should now pull songs in the correct order (and therefore the correct songs, in size-limited playlists)
posted by crayz at 8:54 AM on November 21, 2009 [1 favorite]


crayz, wow, that works! Thank you, the playlists out of order has been bugging the heck out of me since I upgraded.
posted by olecranon at 10:22 AM on November 21, 2009


(But it does not work for podcasts, bummer.)
posted by olecranon at 10:28 AM on November 21, 2009


(But it does not work for podcasts, bummer.)

Did you try adding the Media Kind is Podcast to a smart playlist for Podcasts?

Or you could try a nested smart playlist (click the … button next to the media type rule)
posted by lrivers at 1:15 PM on November 21, 2009


« Older Lonliness and depression   |   Super Germs invading my mouth Newer »
This thread is closed to new comments.