How do I stop my TOC styles from reverting to their default each time I update the TOC?
October 8, 2009 10:51 AM   Subscribe

MS Word 2003 Filter: Searching google and on-line books has failed. Help me figure out why the Table of Contents in my document is misbehaving. My productivity is completely shot this morning because of this!

I'm building a document from scratch, and trying to do it the 'right' way. I am carefully creating the styles I will use in my document. Then, I will add the content.

I began by setting up all of the Heading Styles. Next, I modified the built-in TOC styles (levels 1 through 5) so that they look the way I want them to. Finally, I went to the Index and Tables dialogue box and under Options, I matched my modified TOC styles up with the custom Heading styles I had created - such that TOC 1 goes with Heading Style 1, etc.

Finally, I inserted the Table of Contents. It looked good, but I had forgotten to change the "Show Levels:" drop-down so that the Table of Contents would show 5 levels instead of the default, 3. I went back into the Index and Tables dialogue box and changed it to 5. When I went ahead and updated the Table of Contents, all my beautiful TOC styles reverted to their defaults. I changed them back. I updated the Table of Contents again. Again, the styles went back to their defaults.

I made sure to uncheck all of the "Update Automatically" boxes in my styles. So what the heck is going on?????????
posted by kitcat to Computers & Internet (25 answers total)
 
Did you have everything selected when you made the change? My version of 2003 is kaput or I'd take a look at it for you.
posted by tilde at 10:55 AM on October 8, 2009


If 'by everything selected' you mean the whole table of contents, the answer is yes.
posted by kitcat at 10:57 AM on October 8, 2009


I just noticed too - Word doesn't think the fields in my Table of Contents are in a TOC style any longer. It thinks they are all in a Hyperlink style. Which is odd, because the Hyperlink style is blue and underlined, and my TOC text is not.
posted by kitcat at 10:59 AM on October 8, 2009


Hrm. I'm wondering if it's the blank lines - Do a Ctrl+A to select everything, then set the adjustmet for the whole doc?

Another option might be to copy it into a fresh doc and try it that way.
posted by tilde at 11:01 AM on October 8, 2009


I have Word 2002, but I'd be glad to look at it and fix it for you. I write technical manuals in Word all the time, so I'm pretty good at taming the TOCs, fields and switches, and styles.
posted by Houstonian at 11:02 AM on October 8, 2009


Yeah, the renaming thing isn't fun. I've got W07 and can save it backwards and try.
posted by tilde at 11:05 AM on October 8, 2009


Hi - thanks, guys. I'll try using Ctrl+A and report back.
posted by kitcat at 11:12 AM on October 8, 2009


Nope, Ctrl+A produces the same result.

You know, the only thing that's reverting back every time is the font colour. The tabs and text sizing are all staying the same. So I'm sorry, I was wrong when I said the styles were reverting completely back to the defaults
posted by kitcat at 11:17 AM on October 8, 2009


Is your TOC still showing page numbers, or is it only hyperlinks?
posted by Houstonian at 11:21 AM on October 8, 2009


Also, if you toggle the view to show the fields and switches instead of the resulting TOC, what exactly is it? Is it this?
{ TOC \o "1-5" \h \z \u }
posted by Houstonian at 11:26 AM on October 8, 2009


The TOC was never showing hyperlinks. Sorry if that was unclear. It's when I scroll over the elements of the TOC or place my cursor there. In the Styles pane, it says they are formatted as hyperlinks rather than as TOC elements.


And I take it back about only the font colour reverting back. It's everything.

I have an idea - is it because I am using the "Distinctive" format for the TOC (this choice in made in the Index and Tables dialogue box)? It was set to "From Template" at first, but I changed it because my page numbers weren't right-aligning and my tabs weren't doing what I had specified in the TOC styles.
posted by kitcat at 11:31 AM on October 8, 2009


In the 'bad' state of things, it's TOC\o "1-4" \h\c\u
posted by kitcat at 11:33 AM on October 8, 2009


oops, that should be a 'z', not a 'c'
posted by kitcat at 11:37 AM on October 8, 2009


When you go back to the Table of Contents Options box, have those assignments changed?
posted by Houstonian at 11:45 AM on October 8, 2009


You know what? I found the exact same problem when using Word 2003. I think it's a bug.
posted by KokuRyu at 11:46 AM on October 8, 2009


Please change "distinctive" to "from template".
posted by Houstonian at 11:48 AM on October 8, 2009


You did the right thing with the styles. But for the TOC to take from your styles, you have to select "From Template" (where the styles you made are stored). If you choose "Distinctive" it goes with a built-in font, etc., from Microsoft, not your template.
posted by Houstonian at 11:53 AM on October 8, 2009


(You can think of "Distinctive" as a set of styles that overrides your template's styles. If you choose Distinctive, it will use that despite what you chose for your template. To use the template styles, you have to choose From Template.)
posted by Houstonian at 11:56 AM on October 8, 2009


Yes, ok. That's all clear now. No wonder it was overriding my own TOC styles. Thank you so much.

Now, however, I have to contend with the problem that lead me to change from "From Template" to "Distinctive" in the first place. Even though I have the leader set to a continuous line and page numbers are set to right-align in the dialogue box, the page numbers are not right-aligning and my leader is of the ...............................style. And, I can't seem to get the tabs I had set in my custom TOC styles to implement in the document so long as I'm using "From Template".
posted by kitcat at 12:07 PM on October 8, 2009


rokusan - is what I described above the bug you were talking about?
posted by kitcat at 12:27 PM on October 8, 2009


When you go into the style for one of your TOC styles, then view the tab settings for that style, is it this?
Tab stop position: 6" (or whatever your margin is)
Alignment: Right
Leader: 2.......
posted by Houstonian at 12:37 PM on October 8, 2009


I agree with Houstonian - though my inclination is to make your own template style.
posted by tilde at 12:44 PM on October 8, 2009


That must be it! I don't have the document with me now, but I did have my Alignment set to 'left' and my Leader set to 'none'. I had never paid attention to that aspect of the tab settings before.

Thank you, Houstonian and tilde. You both are super Word gurus and saved me from much grief!
posted by kitcat at 3:55 PM on October 8, 2009


Kudos to you for tackling the more-difficult things in Word, like templates and styles and fields! If you find that the tab problem isn't resolved when you change the styles, post back here if you need some help getting it right.
posted by Houstonian at 4:49 PM on October 8, 2009


I'm echoing Houston. Everything in W07 is so changed around I can't even begin to shadow what you're doing. Good luck with it and I'll dig around for my copy of 03 and install it somewhere.
posted by tilde at 5:51 PM on October 8, 2009


« Older How do you fund a startup with (virtually) no...   |   Puzzled IRL about online puzzles! Newer »
This thread is closed to new comments.