Lost folders and albums in Picasa 3
May 25, 2009 7:34 PM   Subscribe

I started Picasa 3 today and it immediately started searching my folders for pictures. After this was completed all my albums were no longer there. How can I get them recovered?

I started Picasa 3 today and it immediately started searching my folders
for pictures. After this was completed all my albums were no longer there.

I tried to restore the picasa2 and picasa2albums folders located in
C:\Documents and Settings\Username\Local Settings\Application Data
\Google. Picasa2albums has a subfolder, backup, which seems to have backups of the albums. However, copying them manually doesn't work.

Does anyone have a solution for this problem? And any suggestion for the backup plan of Picasa information? I don't want to create albums over and over again.
posted by yezimary to Computers & Internet (6 answers total)
Did you right click on one of the folders in the left-hand library and click "locate folder on disk"? They should be there in the address bar.
posted by Brian B. at 8:50 PM on May 25, 2009

I'm sorry that this is not a helpful answer, but I tried Picasa 3 with two different accounts and I'm just extremely frustrated with the workings of the UI. I think it's a lousy program because it is so nonintuitive and easy to screw up. I'm about to cut my losses and give up on it - I say this not because it's a helpful answer, it's probably not, but because I find it very easy to make this same kind of mistake repeatedly when using this program, even after you learn it, and I think that these are just fatal flaws that should result in a redesign of the program itself. Users shouldn't be having these seriously negative experiences.
posted by Miko at 9:29 PM on May 25, 2009

I had a similar problem with an earlier version of Picasa. Photos that had been organized into folders were now randomly mixed together. I simply uninstalled Picasa and all was restored.
posted by JimN2TAW at 12:10 AM on May 26, 2009

Best answer: Is this any use? Or this?

Also, here's a Picasa gotcha for Vista users: If you're using a limited account, and you use Run As Administrator to install Picasa, or if you supply administrative credentials to its inbuilt updater to let it install a newer version of itself, you might be in for a surprise.

The last thing the Picasa installer generally does is launch Picasa. If the installer is running with the credentials of your Vista admin account, then so will the instance of Picasa that it launches; which means it will scan your admin account's desktop and Pictures folder and so forth, not yours, and will show your your admin account's albums, not yours. If you've told it to scan your whole hard disk, you might not even notice that the pictures are different - just that all your album definitions have gone missing.

So if you're on Vista and you've just done a Picasa install or update, quit the resulting instance of Picasa and re-launch it without using Run As Administrator to make it work normally.
posted by flabdablet at 12:44 AM on May 26, 2009

Response by poster: Thank you @flabdablet.

The problem has not been solved because it seems a fatal bug of Picasa. But from two posts you linked I learned the folder structures and the Pal file formats. That's very helpful.

The key is to backup "C:\Documents and Settings\username\Local Settings\Application Data\Google\Picasa2Albums\b0b695bf62adae90c381c7ded23f63df", especially the random folder name. You have that one, you can restore your album info. Otherwise, no way!

I'm ready to recreate albums manually again. @Miko, I would like to give Picase another chance (but only once).
posted by yezimary at 2:32 AM on May 26, 2009 [1 favorite]

For what it's worth, I just tracked down the corresponding folders for Picasa3 as installed into Ubuntu using the packages from the Google Testing Repository, and found them at /home/stephen/.google/picasa/3.0/drive_c/Documents and Settings/stephen/Local Settings/Application Data/Google/Picasa2Albums/c7d6df57acaad0a1c89ed49e141797cf.

Nice work, Google :-)
posted by flabdablet at 6:22 AM on May 26, 2009

« Older My left foot looks inflated.   |   Swoim...swoirm...swoirmm.... Newer »
This thread is closed to new comments.