How do I disable Mail on my mac?
March 6, 2009 10:24 AM   Subscribe

Is there a way to disable on my mac (OS 10.4.11)? It pops up whenever I mistakenly click on a mailto link. I don't use it for my email, so it's really annoying.

Googling suggests that you can go to the Preferences menu in Mail, but that's greyed out for me, as I've never ever used the program before. I use my departmental webmail. I'd like to eventually figure out how to redirect the mailto links to some other email software/account, but for now, just disabling it will be fine.
posted by bluefly to Computers & Internet (11 answers total) 1 user marked this as a favorite
posted by devbrain at 10:33 AM on March 6, 2009

It may be a setting in Safari or Firefox (or whatever browser you use).
posted by eatcake at 10:33 AM on March 6, 2009

If you use Firefox, you can set this under Preferences - Applications (search for mailto). If you use Safari, you have to rely on the preferences to make this work.
posted by jessamyn at 10:35 AM on March 6, 2009

Response by poster: I forgot to mention that I'm using Safari.
posted by bluefly at 10:38 AM on March 6, 2009

If you use gmail, you can use gmail notifier to handle those things and open up gmail when you click on the links.
posted by iamabot at 10:38 AM on March 6, 2009

Are you using Firefox? Then it looks like you can definitely set mailto to work with webmail.

It's trivially easy to do with gmail and yahoo, and there are extensions that let you use other webmail services. If you aren't using Firefox, this may be a good reason to switch.
posted by oddman at 10:41 AM on March 6, 2009

You can always just delete, which will stop it from opening. Click on in the finder and press command-delete.
posted by pseudonick at 10:51 AM on March 6, 2009

Response by poster: Well, I can't really delete, since we have 2 accounts on this computer, and the other person uses it. Is the only option to switch to Firefox or install another program? Is there really no way to gain access to the Preferences menu in Why is it greyed out for me? Do I need to set up an account in Mail in order to have access to that menu? That seems really counter intuitive to me.

I'll never understand why people extol the virtues of macs.
posted by bluefly at 11:59 AM on March 6, 2009

Best answer: There is a decent chance that the reason "preferences" is greyed out is because you've never configured Mail. So, let me make sure I understand your setup.

- you and someone else use your computer with different logins?
- You both have admin logins to the machine?
- Mail pops up when you accidentally click a mailto link. Does it ask you to configure Mail? Have you ever configured Mail in your account on this machine?

If you haven't configured at all, you'll have to type in a bit of information into, just enough so the Preferences panel isn't greyed out, in order to get to preferences to set it to NOT be your default mail reader. I'm aware this sucks, but it will work.
posted by jessamyn at 12:11 PM on March 6, 2009

Response by poster: Ok. There are 3 different logins to this computer. One is an admin/root acct and the other 2 are regular user accts. Mainly we have the admin acct to install programs we need to use.

I set up an account in Mail, and then I was able to change my Preferences. I didn't realize that one had to actually configure it in order to tell it I didn't want to use it -- that does suck. This won't change anything for the other user right?

I might try switching to Firefox in the future to try out those extensions for using Gmail and webmail. Thanks so much for your help and patience.
posted by bluefly at 12:52 PM on March 6, 2009

> This won't change anything for the other user right?

Correct. It's really a holdover, in my opinion, from the early days of OSX where they sort of wanted you to do all your stuff with the simple apps that came with the machine - mail, calendar, ichat, iphoto. Some of those apps have staying power, but some of them have been pretty well superceded by web applications (or Thunderbird for a lot of people) and it's not as easy as you'd like it to be to detangle the built-in preferences that are OS+application. Glad you figured it out.
posted by jessamyn at 1:09 PM on March 6, 2009

« Older unrealistic thespianic fantasies   |   Best embedded video solution? Newer »
This thread is closed to new comments.