My Powerbook's processor is almost always at 100%. Is this normal?
November 4, 2004 7:38 PM   Subscribe

My Powerbook's processor is almost always at 100%. Is this normal? If I have just my email open and a web browser, it hovers between 80 and 95% pretty much constantly.
posted by dobbs to Computers & Internet (36 answers total)
I would think not. My ibook does about 30% with top running, which takes up about 20% itself. Using top at the command line will allow you to see what is taking up the cpu.
posted by advil at 7:54 PM on November 4, 2004

No not normal at all. What version of Mac OS X are you running?
posted by nathan_teske at 8:01 PM on November 4, 2004

launch terminal and enter "top." what process is hogging the processor?
posted by grimley at 8:04 PM on November 4, 2004

also, how old is your powerbook?

(light bulb)

How big is your HD, and how much ram do you have?

(GUI version of top is "Process Viewer")
posted by mwhybark at 8:06 PM on November 4, 2004

isn't it "Activity Monitor"? or is that 10.3 specific?
posted by grimley at 8:09 PM on November 4, 2004

Response by poster: I'm on Panther. It's a year old. I use it a lot. The little fan is going more and more often these days (I have the back end of the powerbook propped up so air can get underneath). I think it's a 867mhz. I have 640 ram. HD is 40 gig and is almost half free.

grimley... this'll sound stupid but whenever I launch Terminal I just get a tiny tiny window with a red "close" dot in the corner. and that's it.

From Activity Monitor, Camino takes up close to 30 or 40%, everything else varies between 0 and 20. I'm starting to think the little processor monitor thing is on crack.
posted by dobbs at 8:15 PM on November 4, 2004

I used to know much more about system maintenance with OS9, but since X have been a little out of it. For luck I run Cocktail every week or so, only using the system tab and only running the cron scripts - which are designed to run in the middle of the night - and the system and user caches. I use pshop, indesign and other apps which make rather large temp files, and it seems to help things. Not sure about what is causing the Terminal window to appear that way. I'd delete whatever preferences are in user>library>preferences - a quick look reveals maybe that will help - but i'm not responsible for it!
posted by grimley at 8:22 PM on November 4, 2004

What's that process monitor that reported the usage as 100%? It sounds like you're saying that was something other than Activity Monitor, so maybe it's wonky or you misinterpreted it...?

By the way, is that 640 MB?? For OS X? Feh. Only Apple believes that's sufficient to run the OS usefully. Your whole system will run a lot smoother with a memory upgrade.
posted by nakedcodemonkey at 9:09 PM on November 4, 2004

Response by poster: nakedcodemonkey, it's this program Menu Meters. And 640MB is the max this computer can take. It shipped with 256. It's a laptop, remember.

And I'm not misinterpreting the monitor. It simply sits in the menu bar and displays a percentage, which jumps around like a jumping bean: 22, 16, 36, 88, 52, 77, 79, 88, 8, 100, 85, etc. That's all just while typing the numbers into my brower.
posted by dobbs at 9:25 PM on November 4, 2004

grimley: yes. D'oh. Too much old data in noggin.

I haven't ever heard of bogus terminal behavior like that. What programs to you typically launch and keep open? Is there an Apple Store you can go visit?

Do you have a full data backup? Is it recent? Do you often download material from illicit sources? Licit ones that require odd plugins for your browser?
posted by mwhybark at 9:25 PM on November 4, 2004

Any web browser should be 0-10 at most if it's not doing anything - something may be wrong with camino? Just like top, activity monitor takes up a certain amount of cpu while running (for me it's 7-15) so don't forget to factor that out.

It's basically not normal for a user-level program to use any cpu while it's not doing something. There are a few system processes that will continuously be using CPU - WindowServer is the main one.

And I have 640MB - that is enough for almost whatever you want to do, and won't cause any constant swapping or CPU usage.
posted by advil at 9:37 PM on November 4, 2004

Response by poster: Terminal's been like that since a clean install of Panther last year. I don't even know what that program does so I don't know what I'm missing. (I switched to Mac last year.)

There is no Apple store in Toronto, unfortunately. I always feel intimidated when I go the stores that do sell Apple stuff, which is why I asked here instead of there.

Illicit sources? No, I wouldn't say I do. I don't download warez and bootleg movies and stuff like that if that's what you mean.

I don't really do much of the plugin thing. I did with Firefox but I got so sick of that browser. Actually, I think all of the browsers for Mac suck. Especially with Flash. I'd say that 80 percent of the Flash sites I visit cause my browser to freeze and maybe 10 percent cause the computer to freeze.

I don't think I have much running at startup:

Notational Velocity
MSN Messenger
Escape Pod (which I find I need because of the browser problem)
Epson Scan Monitor
System Events (I don't know what this is--I assume it's an OS X thing)

I mostly just use Word, browse the web, and Photoshop, really. And email. I'm an email junkie.

The programs that consistently make me have to wait the longest while they do shit are easily iTunes and any web browser. Admittedly, I have a LOT of MP3S. And iPhoto, which is so slow I don't even bother with it.

I am buying a second external drive this week so I can back up. I'm worried about losing stuff.

Oh! and I often have a drive plugged in and a second monitor--not sure if that would affect speed and stuff though I doubt it.
posted by dobbs at 9:43 PM on November 4, 2004

Response by poster: advil, the monitor fluctured like that with Firefox as well.

Any time I click send for email or click a link in a browser, my cpu thingy goes to 100 for about 10 seconds and then settles to 80 and slowly sinks back down again. As soon as I start typing it jacks back up. For instance, right now I have camino, system preferences, and BBEdit open. As I type this, the numbers are flying between 42 and 85. WhenI click Post it'll hit 100 for sure.
posted by dobbs at 9:45 PM on November 4, 2004

Dobbs, try changing to a different font in the Terminal Preferences. I had the same problem on one of the Macs at work, and that fixed it.
posted by jaut at 9:58 PM on November 4, 2004

"And 640MB is the max this computer can take."

Actually, you can take out the 512M SODIMM and put a 1GB module in there. They just said 640 was the max because at the time the 867 came out there was no such thing as a 1GB module, and the machine only has one memory slot.

If you're paranoid about getting any old stick of RAM, you can overpay for a meaningless "compatibility guarantee" from the reputable Other World Computing. 640MB really is enough, though: I've got that much in this machine and it's got 250MB free at the moment, with all kinds of crap running.

The weird terminal behavior should be easy to get rid of. Drag this prefs file to the Trash: /Users/dobbs/Library/Preferences/

Menu Meters can report momentary CPU usage frequently enough that you'll see the numbers jump all around. Momentary numbers are meaningless -- you want to see a moving average over a few seconds. Regardless, it sounds like Camino is broken. With two browsers, Mail, an RSS thingy, SSHKeychain, GPGMail, Terminal, and Activity Monitor all running, I'm using between 1% and 2% CPU. That number becomes 5% if I turn the processor down to 533MHz. So clearly your experience is not normal or to be expected.
posted by majick at 10:05 PM on November 4, 2004

For instance, right now I have camino, system preferences, and BBEdit open. As I type this, the numbers are flying between 42 and 85. WhenI click Post it'll hit 100 for sure.

Actually if the numbers you're worried about are when you're doing something, this may not be surprising. I can make the cpu usage spike by scrolling safari with the arrow keys. I think this is just quartz. When you're not doing anything (and have no windows open with flash/animated gifs etc), just watching the numbers, that is when you should be surprised at high cpu usage.
posted by advil at 10:34 PM on November 4, 2004

Response by poster: Jaut, the Terminal Preferences doesn't have a font option (assuming you mean open terminal and go into FILE | PREFERENCES).

The weird terminal behavior should be easy to get rid of. Drag this prefs file to the Trash: /Users/dobbs/Library/Preferences/

Majick, that didn't work. I dragged to trash (with terminal not running), ran Terminal... same thing. My "window" consists entirely of the red close window button and maybe a centimeter underneath that.

Advil, hmm. Okay. I'll keep an eye on it over the next few days when I'm not actually doing something. I swear it's never under 15 % and usually near-max.

Everyone else have the same probs with browsers and flash that I mentioned?
posted by dobbs at 11:05 PM on November 4, 2004

dobbs, I'm not sure but why don't you try pulling the second drive off and seeing if that doesn't speed things up for you. You might have to reboot to see any effect. I have a G4 powerbook with an external drive and it dogs my system when I leave it attached.

I use FireFox and prefer it to any other browser. But then, I avoid most Flash sites, they tend to annoy me.

My thing with my machine is that it will sometimes not wake up and I'll have to reboot it.
posted by fenriq at 11:20 PM on November 4, 2004

Response by poster: fenriq, I have pulled the drive off (and the extra monitor) but the processor # jumps around so much it's nigh impossible to really determine much of anything.

My computer behaves very much the way a windows machine does when it has a virus. For instance, lately, when I go to a web site I've never been to before, I get a msg from the browser saying it's an invalid url. I click okay, type in the same url, and the site shows up. This happens pretty consistently. I click a link -- no site there -- click okay -- click same link -- there's the site!

I suppose once I get the second drive I should back up and do a full reinstall as something is definitely dogged.
posted by dobbs at 11:42 PM on November 4, 2004


did you buy applecare when you purchased the computer?

if no, is it a year old, or longer? your machine will have a 1 year warranty on it.

if you're under warranty, or have applecare, i'd call apple support and explain everything to them. odds are they're going to want you to ship them your machine.

i would back up all of your data and then send it off to them.

if you aren't under warranty, the best thing you can try is to back up all your data and re-format with a fresh install of Panther.

that said, i'm not 100% sure that's going to help you. your machine is doing a lot of odd things. i'd re-install the OS first.

if you are still under warranty, and don't have applecare - buy it.

that goes for all you mac users. it's like $300 for notebooks, and it really is invaluable if something zany happens with your machine.

dobbs - if you reinstall panther and it's still broken, and you aren't under warranty and you don't have applecare, you may want to consider selling the thing on ebay and buying a new one. they're in the range of $999 these days.

hope that helps.
posted by christian at 12:14 AM on November 5, 2004

I, too, am a big fan of menu meters.

Open activity monitor. Watch to make sure all those menu widgets aren't growing out of control. In the early betas of quicksilver, I'd often find it eating 50% for no go reason. Also look at how much ram they're eating.

I love cocktail until it went shareware. The big new app for maintenance is OnyX
posted by filmgeek at 4:00 AM on November 5, 2004

dobbs that browser behaviour is the same for everyone at the moment. see here for an explanation. Have you cleaned all the caches out of the browsers? Deleted .icn files? They are notorious for draggin things down. And run Cocktail or OnyX.
posted by grimley at 5:51 AM on November 5, 2004

dobbs -- I've experienced a little of what you're going through. For me the processor would hit 100% and stay there. The processor would get hotter than the sun. For me it was friggin Norton Antivirus. There was a fix @ symantec though.

The processor utilization will zip up and down all the time. When checks mail it goes up a little, then drops down. I just want the idle to be nice and low -- <1 0% when it is just sitting there. br>
Regarding the your need to re-enter URLs on the internets... For me that was a problem with my ISP and wireless router. I added the IP addresses of the DNS servers into the network prefs for the airport card and that went away.
posted by birdherder at 6:00 AM on November 5, 2004

"Jaut, the Terminal Preferences doesn't have a font option..."

It's in Terminal / Window Settings (not Preferences) / Display. I'm using Anonymous Regular 9pt.

Trashing the pref ought to have removed the possibility of it being a setting at the root of that problem, but what the hell, play with the fonts and see what happens.

One thing that ought to be suggested before you start reinstalling things or deleting anything else is this: Create a new user (System Preferences / Accounts) and log in with that. If you have all the same problems, it points toward a system problem rather than a user configuration problem.

I've also found LaunchBar to be less resource-intensive than Quicksilver. It also suits me better in other ways, but the fact that it uses almost no CPU time and not much memory is something I like.
posted by majick at 6:03 AM on November 5, 2004

Dobbs, some ideas:

1. Change the sample rate of your CPU monitor. Make it sample at least once a second. This will stop the apparent jumping around. It will look more steady. Also, if you're using Menu Meters or Net Monitor, turn on its graphing display of the CPU, too, so you can see how it looks over time.

2. Open Terminal. Ignore the small window for the moment. Go "Preferences" in the Terminal menu. Does it have a check next to "Open a saved .term file when Terminal starts"? If so, take the check off that box. Close Preferences. Quit Terminal. Relaunch Terminal. Does the small window still appear? If so, do the next step:

Open Terminal. Ignore the small window for the moment. Go "Preferences" in the Terminal menu. Change the radio button so that "Excecute this command (specify complete path)" is selected. Make sure only "/bin/tcsh" is in that field. Close Preferences. Quit Terminal. Relaunch Terminal. Does the small window still appear? If so, do the next step:

Go to Terminal in the menu and choose Window Settings. In the drop-down menu of the window called "Terminal Inspector" which appears, choose Window. Set the dimensions to something like 100 by 50. Then click the "Use Settings as Defaults" button at the bottom. Quit Terminal. Relaunch Terminal. Your small window should now be large. If this fails, then I have no further solutions.

3. Make sure you are using the latest release of Camino. Earlier releases had a problem where it would constantly check bookmarks to make sure they were valid. If you have a lot of bookmarks, like I do, this could take forever. If you don't run Camino, what does your processor do?

4. Make sure you are using the latest Flash plugin. This is a must. If Flash makes more than one browser crash, then Flash is likely the problem.

5. Can you run Activity Monitor? If so, will you rank the processes according to percentage and take a few of screen shots? (Or, if the Terminal solutions work, you can just take screen shots of Terminal.) I'd like to see what processes are running. My iBook idles at less than 3%. Your PowerBook, which is much faster, should too.
posted by Mo Nickels at 6:23 AM on November 5, 2004

dobbs, if you launch terminal, there is an option under the "Terminal" menu. Under that there is a "Window Settings" that inexplicably brings up the "Terminal Inspector." (Why not call it that in the sub-menu?) Still further in the pull down menu there is a "Window" option where you can set the dimension of terminal. Can you reset it that way? birdherder - why do you run Norton? We don't really have viruses in OSX, and if there was one, you can bet the community would make big wind of it fairly quickly. If Norton is doing this, why not just get rid of it? this is more curiousity than anything...
posted by grimley at 6:38 AM on November 5, 2004

iTerm is, IMHO, a better version of Terminal, supporting tabbed sessions and more customization. You should be able to run "top" from that.

Some other thoughts...

- Escape Pod always caused me stability problems when I ran it (which is kind of ironic). It hasn't been updated in a year, which for a low-level-access app like that is bound to lead to problems.

- Repair Permissions. When in doubt, Repair Permissions. It's in your Disk Utility (/Applications/Utilities).

- 640MB is enough RAM for you. Unless you're a graphic artist or gamer, it's a perfectly fine amount.

- Scale back what you're doing. Run Safari, no matter how painful it is for you. Don't launch everything at once, but start with one app, and launch others as you need them. You should be able to pinpoint what's causing your spike more easily that way.
posted by mkultra at 7:15 AM on November 5, 2004

A lot of Mac users have been reporting trouble accessing sites on the first attempt since a recent software update from Apple (this has been discussed at -- an excellent resource, btw). The solution isn't clear.

I don't find Quicksilver to be a resource hog (according to Activity Monitor, it isn't). Word is at the top of the CPU charts for me, using about 20% even hidden in the background. Camino uses almost nothing when not in current use.

The advice to create a "clean" new user is good. If you've still got problems with that, it's time to consider doing a clean install of the system, painful as that is.

Also discussed at Macintouch is the emergence of malware for the Mac, called Opener. This apparently requires physical access to the machine to be installed, but once there, will hog your CPU cycles (among other things). This is probably not dobbs' problem, though, because some of the apps Opener installs would have appeared in the Activity Monitor report.
posted by adamrice at 8:10 AM on November 5, 2004

adamrice, Opener needs root access so the chances of it getting in your system are slim, but it does demonstrate some vulnerability. The link i mentioned above explains how to fix the site access issue. any luck dobbs?
posted by grimley at 8:14 AM on November 5, 2004

How many fonts do you have installed, dobbs? Also, when you "wait" and the processor is a 100%, can you tell if the HD is spinning like crazy?

if you're not sure, iPulse does some cool monitoring stuff.

dobbs, Mo's Terminal advice is worth following. One other thing, though. Did you mention whether or not you've tried to enlarge the Terminal window? Grab the lower left corner of the tiny lil thing and pull down and out. This might not work, but let us know.
posted by mwhybark at 9:22 AM on November 5, 2004

Response by poster: Wow. Lots of responses and a few emails from non-mefi members.

Mo, I tried all those terminal fixes and none of them worked. mwhybark, yes, I tried to manually enlarge the window and it did not work. All I can do is close it. It's useless.

I am going to try more of the solutions over the next half hour or so and report back.
posted by dobbs at 9:55 AM on November 5, 2004

dobbs, buddy- iTerm. Trust me- you'll never use Terminal again.

Keep us posted!
posted by mkultra at 10:55 AM on November 5, 2004

In the Activity Monitor, under the "Monitor" menu, there is an item labeled "Dock Icon". Select from it the "Show CPU history" option. As mentioned above you'll be able to constantly monitor the CPU usage as a function of time, additionally you'll see what amount is used by System Processes and what amount by User Processes.
Do yo have fast user switching enabled? If you do, do you have a second user logged in?
posted by golo at 11:59 AM on November 5, 2004

Response by poster: Ugh. Sorry, I got sidetracked.

Okay, I created another user and everything on that side is hunky-dory so that means there's a problem with my setup/software, right? I should reinstall from scratch...?

mkultra, I've never used Terminal and don't even know what it does. :)

golo, I don't know what you mean by "monitor cpu usage as a function of time". All it does is put a blue bar in my dock which rises and falls (in conjunction with the percentage on the monitor on my menu bar).

Thanks for all your help, folks!
posted by dobbs at 6:43 PM on November 5, 2004

"I should reinstall from scratch...? "

This means it's almost certainly one pref or another in your /Users/dobbs/Library/Preferences. I don't advocate nuking everything (either the system or the prefs), but clearly the problem lies somewhere in your home directory, not in the OS install.
posted by majick at 4:42 PM on November 6, 2004

Response by poster: Thanks, majick. And for the email, too.
posted by dobbs at 8:26 PM on November 6, 2004

« Older Sad Violins   |   Need suggestions for comfortable-to-write-with... Newer »
This thread is closed to new comments.