Off with his head!
February 12, 2009 12:13 PM   Subscribe

Hopefully simple Ubuntu display question.

I've got a little PC running Ubuntu 8.10. I use it mainly as a development server but I also like to use the desktop for various tasks (I'm not really a command-line person) and I do that via VNC from my main PC.

The problem is when I try to boot the Ubuntu machine without a monitor attached. It stops with a warning about running in low graphics mode. I then have to connect a monitor to fix the issue.

What I want is for Ubuntu to boot into the desktop without any warnings. I then want to be able to use VNC to view the desktop. Essentially I want it to behave as if a monitor were attached (without trying to autodetect the screen resolution and refresh rate).

I found this thread on the Ubuntu forums, but it wasn't much help.
posted by le morte de bea arthur to Computers & Internet (8 answers total)
If you haven't already, try asking your question on the Ubuntu forums.
posted by chrisamiller at 12:18 PM on February 12, 2009

Alternate method to consider.
posted by devbrain at 12:31 PM on February 12, 2009

Found a link on ubuntu forums that might help:

"I think I've got it cracked, I deleted ALL files beginning with xorg.conf* (probably including the fallback one by mistake) in /etc/X11 and did a dpkg-reconfigure -plow xserver-xorg making sure nothing was auto-configured. Then I removed all the screen resolutions except 1024x768 from the new xorg.conf and it now seems to boot into X OK when it's headless. I've no idea which one of those things did the trick."
posted by grippycat at 12:34 PM on February 12, 2009

Best answer: Does this thread (specifically towards the end) work for you? It looks like setting the xorg.conf drive to Driver "vesa" is the fix.
posted by niles at 12:36 PM on February 12, 2009

If you don't have the stomach to wade through the XORG configuration or install a VNC server with it's own virtual X server, you may be able to try a hardware 'solution' like a VGA terminator to trick things into thinking there's a monitor. Apparantly you can make your own out of a junked CRT monitor.
posted by cowbellemoo at 12:43 PM on February 12, 2009

You may also have luck fiddling with BIOS settings. I don't think there's going to be a clearcut software answer unless you get up to your elbows in X settings. :(
posted by cowbellemoo at 12:47 PM on February 12, 2009

Response by poster: Found a link on ubuntu forums that might help:

Thanks grippycat... but that didn't work for me when I tried it yesterday - I think the xorg configuration process has changed slightly since 7.10. (Hope you're feeling better soon by the way).

Does this thread (specifically towards the end) work for you?

You know what? It did! Screen resolution in VNC appears to be 800x600 now, but it's good enough.

Thanks all.
posted by le morte de bea arthur at 12:49 PM on February 12, 2009

posted by cowbellemoo at 1:02 PM on February 12, 2009

« Older Hide our private things from our precious little...   |   "I can't find Pussy anywhere." Newer »
This thread is closed to new comments.