Stay ON, will you? I want my internet.
September 2, 2008 2:52 AM   Subscribe

I have a ThinkPad. Why does my wireless radio (in the ThinkVantage Access Connections/Wireless Connection Status menu) power itself off? How can I make it stay on?

I have a Lenovo ThinkPad T61 running Vista. Occasionally, when the wireless signal is low, I'll lose internet altogether. The culprit is almost always this ThinkVantage Access Connections thing (for those of you who have the same thing, it's the thing that comes up from the signal strength icon in the taskbar). It says Wireless Connection Status, and it has a little button there with the option of powering the wireless radio on or off. For some reason, when I have a low (but not too low, and sometimes it happens even when the signal is a good strength) signal, the thing will power the wireless radio OFF, and I have to manually turn it back on again before it can connect.

Does anyone know why it does this? More importantly, is there something I can do to make it stay ON? It's really obnoxious when I have someone sitting right next to me happily using the internet while I'm clicking the power on wireless radio button and cursing at my computer.

I found this related question, but I don't have to restart (ok, maybe once or twice I did) in order for it to work. The thing just shuts itself off randomly and I have to manually turn it back on by opening the thing and clicking the button.

Thanks!
posted by phunniemee to Computers & Internet (9 answers total) 2 users marked this as a favorite
 
Check your power saving settings, on many of these there's a default setting to power off the radio when there's low signal, especially on battery. I don't have a T61 that's running Vista to look at, but on XP there's a setting to tell the machine not to turn off the wireless radio.
posted by pupdog at 3:04 AM on September 2, 2008


Any chance this is one of the Lenovos where the physical wireless switch is on the front of the laptop and you accidentally switch it off? I have a x61 and I regularly turn it off that way if I am slouching on the couch with the front of the laptop resting on my stomach - I'll shift position and that movement is enough to turn the switch off.
If not... no idea. :)
posted by 8dot3 at 4:59 AM on September 2, 2008


I just got rid of Access Connections on a coworker's ThinkPad because it was acting just like you describe. Letting Windows manage the wireless connection without Access Connections fixed things.

Worth a try, at least -- you can get rid of it in Add/Remove Programs, but make sure you uninstall "Access Connections" and not "Access IBM" which is the help documentation, and if it doesn't help you can get Access Connections from IBM's website to reinstall it later.
posted by mendel at 5:15 AM on September 2, 2008


Does anyone know why it does this?
It does this because the Thinkvantage Access Connections software is utter crap. Uninstall it and use Vista's native wireless management.
posted by Cat Pie Hurts at 5:16 AM on September 2, 2008


Yeah..what mendel said ;)
posted by Cat Pie Hurts at 5:17 AM on September 2, 2008


3rding what Mendel and Cat Pie Hurts said as the Thinkvantage Access Connections is an annoying and useless piece of software that Lenovo can stick where the sun don't shine. I've disabled it on every one of my coworkers' Think Pads that have come to me to help them with their wireless connections. Windows manages it much better, trust me.
posted by Lynsey at 9:55 AM on September 2, 2008


I will take a different perspective and argue that "Access Connections" is actually a very useful piece of software, if you need the features it offers. I use it a lot, since my internet connectivity changes drastically.

If I'm in the office, I need my office printer to be my default printer, I need to connect via an ethernet connection, have specific TCP/IP settings, turn off the firewall, and have my office intranet as the home page on my browser.

If I'm at home, I need it to connect via wireless, set my home printer as the default printer, and set my personal home page (where I have my frequently visited links all configured) as my home page.

When I'm traveling, it needs to turn on the firewall, set the PDF printer as the default, and automatically enable my VPN connection.

So, I appreciate the tool and use it almost daily. It saves me a great deal of time, since it can detect the type of connection I have and automatically do all of the above tasks for me. Therefore, I get quite annoyed when people call it "utter crap" or "useless piece of software" when they meant to say "I personally do not have the need for the software so I uninstalled it" since they inherently assume that THEIR usage of the internet is the dominant or righteous usage and that OTHER people may/should not have varying needs that this software may meet.

Now, that I have blown off steam, I'll get to the actual question: While I don't have a definite answer (since I never ran into it), there are a few relevant settings, and the action you are seeing might be a direct/indirect result of one of these settings. So I would play with these to see if anything changes. They are listed from the most likely to the least likely:

1. Go to Network Connections under Control Panel (this is in XP, I don't know if they renamed it for Vista but this is essentially where you control your network devices). Select the "Wireless Network Connection", right click and select "Properties". First see if there is a tab called "Power Management". If there is, you will see an option called "Allow the computer to turn off this device to save power". Disable (uncheck) that. If there isn't a Power Management tab, see if there is a similar option under the "Advanced" tab.

2. Under the ThinkVantage Power Manager utility, go to "Global Power Settings". Under the Power Management Options section there are two Advanced buttons (there is a third one under Events, but that's a different section so ignore that), the top one is for brightness control, the lower other one is general. Click on the lower one. There is an option in there for "PCI bus power management". Try disabling that. It is possible that when you run low on power, PCI bus power management kicks in and disables power to supported devices connected to the PCI bus, which could include the wireless card.

3. In Access Connections, select Configure and then Global Settings. There is an option there that says "Enable automatic wireless LAN radio control". This is supposed to turn off the wireless after three minutes if there are no accessible connections. But perhaps it's not operating properly and as your battery runs low it gets confused. It's a far reaching idea, but worth a shot if the above two did not solve the problem.
posted by tuxster at 12:25 PM on September 2, 2008 [2 favorites]


I get quite annoyed when people call it "utter crap" or "useless piece of software" when they meant to say "I personally do not have the need for the software so I uninstalled it" since they inherently assume that THEIR usage of the internet is the dominant or righteous usage and that OTHER people may/should not have varying needs that this software may meet.

Indeed. I've owned four Thinkpads, all running Access Connections, and I have never had the problem you cite, phunniemee. I surmise that you probably have a bad setting somewhere, and if tuxster's advice is fruitless, I'd suggest calling Lenovo Software Support.
posted by Kwantsar at 12:59 PM on September 2, 2008


Thanks, guys!

pupdog: Your suggestion, while it didn't fix the problem, reminded me that there were some settings I'd been intending to change for a while now but never did. Best answer for you!

mendel: This is what I did. It seems to have solved my problem. Best answer for you!

tuxster: If I ever need to have my connections managed in so many different ways, I'll bring it back and follow your directions. Best answer for you, too!
posted by phunniemee at 6:22 PM on September 2, 2008


« Older Hard Drive Purgatory   |   Yahoo Calendar? Newer »
This thread is closed to new comments.