Skip

How to turn off Safari's "improved" autocomplete?
November 20, 2007 7:21 AM   Subscribe

Is there any way to turn off Safari's "improvement" to URL autocompletion?

I used to be able to type a letter in the URL field and Safari would autocomplete with my most commonly accessed URL starting with that letter.

For example, typing "t" would have Safari autocomplete the specific technorati search page for my blog.

But now, new in Safari 3.0.4, is a "feature" that screws up the autocomplete: typing "t" goes to the domain homepage - not the specific page I've gone to in the past. So "t" goes to technorati.com - and then I have to arrow-key down to the page I wanted. It's an unnecessary and irritating step.

Is there any way to turn that off? (Without reverting to an older version of Safari?)

P.S. I also don't like the new search feature that animates the find-in-page function. Any way to turn that off, and go back to what the Find function has been doing fine for, oh, 14 years now?
posted by mark7570 to Computers & Internet (15 answers total)
 
Put the page you want in your bookmarks, and remove any pages in your bookmarks that are taking precedence over it. Safari will autocomplete a bookmark before it goes looking in the cache.
posted by ikkyu2 at 8:22 AM on November 20, 2007


I use m, right arrow, type the first letter of the next string, a, and i bring up the /activity links from metafilter. I find it works similarly.

Default such as this doesn't appear to be editable in the preferences, or atleast in the debug menu.

I personally like the new animated find behavior, because it was impossible to find stuff in documents before, imho.

Looking through the .plist I can't find any entry with a clear definition of either the text input field auto complete action, or the find behavior, so you may be out of luck.
posted by mrzarquon at 8:37 AM on November 20, 2007


Heh..I always thought the complete link autocomplete was an annoying bug.
posted by Cat Pie Hurts at 8:37 AM on November 20, 2007


(on preview)

Seconding ikkyu2's suggestion for the bookmarks also.
posted by mrzarquon at 8:38 AM on November 20, 2007


ikkyu2: didn't work, unfortunately. i added the bookmark, even quit & restart safari, and still it's autocompleting the domain homepage (which isn't a bookmark anywhere). oh well.

mrzarquon: thanks for checking the plist. dang
posted by mark7570 at 9:00 AM on November 20, 2007


Try clearing your cache after taking ikkyu2's suggestion.
posted by proj at 10:01 AM on November 20, 2007


BTW, this seriously is an improvement, not an "improvement". What do you think is more likely for the majority of users: wanting to go to ask.metafilter.com or wanting to go to a random, specific Ask thread from somewhere in your history, forever, every bloody time you type "ask".

However: if this is just for specific pages, put them in your bookmarks toolbar. The first nine links in there can be got to via apple+1-9, which is fastest yet.
posted by bonaldi at 10:13 AM on November 20, 2007


Yeah, empty your cache.
posted by ikkyu2 at 11:02 AM on November 20, 2007


And clear your browser history too.
posted by ikkyu2 at 11:03 AM on November 20, 2007


emptied cache, cleared history, quit safari; emptied cache again, cleared history again, quit safari again; then ran safari a 3rd time - and it still does the same thing, autocompletes to the domain's homepage.

ahh well - appreciate everyone's willingness to help, tho!
posted by mark7570 at 11:39 AM on November 20, 2007


Hunh. You know what, you're right, and this is a recent change, too. I think it may well have been in Safari 3.0.4, too. Well, when you're right you're right.

Let me look around and see if there's not some plist hack you could do to restore the wanted behavior.
posted by ikkyu2 at 12:10 PM on November 20, 2007


Here's a guy who had a similar problem to you. Turns out Safari really was looking through his bookmarks and it had found a bookmark that he never made.

Are you 100% sure none of your bookmarks have technorati.com in them? One way to find out is to do Safari -> Reset Safari, then hit option-command-B to show all Bookmarks, make sure that 'all' is selected so you're looking at all bookmarks, and then use the little magnifying glass search in the bookmark window (NOT the google search in the address bar) to see if you have a hidden technorati bookmark.
posted by ikkyu2 at 12:19 PM on November 20, 2007


confirmed that i do not have the domains' homepages bookmarked, even searching All. it's quite consistent - any letter i type autocompletes the domain's homepage, even if the page i always go to is a page within that domain.

who came up with this feature idea??
posted by mark7570 at 1:22 PM on November 20, 2007


who came up with this feature idea??
Every other browser maker ever. For the reasons in my post.
posted by bonaldi at 1:24 PM on November 20, 2007


Huh. It seems to be a little different for me. It seems to be based on how many times I've visited the site. For example, if I just started up the browser, and I type "fl", I get flickr.com. But if I go to my recent activity page a bunch of times, pretty soon Safari starts prioritizing that specific page when I type "fl", and the main flickr.com page is further down the list.

If you restart your browser often, that might be what is resetting it, perhaps.
posted by litlnemo at 7:40 AM on January 3, 2008


« Older ContactLensFilter: What to do ...   |  CanadianCivilEngineeringFilter... Newer »
This thread is closed to new comments.


Post