Skip

Help me delete America!
March 14, 2009 2:42 AM   Subscribe

No matter what I do, the US-ENGLISH setting on my spellcheck keeps returning from the dead like a bad guy in a horror movie.

Is there any way to delete American English permanently and irrevocably from Microsoft Word 2007?

Suggestions I've found via Google which haven't fixed the problem...

Change your language in Control Panel
According to my settings in Control Panel I'm in the UK and speak British English. Word doesn't seem to care.

Go to the Office 07 Language Settings application on the Start Menu and change the default to British English.
I've done this countless times. When I go back, American English has somehow become the default again.

Change your Normal Template.
This only affects docs I create myself from scratch. Most of the docs I work with are being emailed to me by other people.

Start doing a spellcheck and change it from within there. / Change it from Word Options in the ribbon. / Use the little language tab at the bottom of the screen.
This only fixes things for the document I am currently working on. Any subsequent docs I open default back to American English.

Any other ideas? This is seriously eating into my productivity.
posted by the latin mouse to Computers & Internet (8 answers total) 2 users marked this as a favorite
 
Me too, on Word 2003. It's driving me crazy. My only solution was to select all text (CTRL A) and then Tools>>Language>>Set Language. For each document. I tried the Control Panel, Deleted the Normal Template and restarted (but that was because for some reason I could no longer access the table menus), and even with the spell check open, it would change back for no real reason as I was going through. Good luck. I'm hoping someone can help us.
posted by b33j at 3:57 AM on March 14, 2009 [1 favorite]


I'm afraid I don't have Word on my computer so can't verify this, but IIRC, it has separate dictionaries in its install folder (under Program Files if you're on Windows). You could try deleting the US English one (possibly called "Default Dictionary"). That way it has no recourse.
posted by turgid dahlia at 4:29 AM on March 14, 2009


Even better, delete the US English or Default Dictionary and rename the UK English one.
posted by turgid dahlia at 5:03 AM on March 14, 2009


Your problem is indicated by your phrase "Most of the docs I work with are being emailed to me by other people." The Language setting (along with loads of other settings) is created when the document is created. If the people who send you the docs created it with US English, then that is what it will be till someone (you or they) change it manually. My suggestion would be, with any document open, to record a macro Tools>Macro>Record New Macro, name it e.g. UKEnglish (you can't have spaces in Word macro names), whereby you would select all the document (Ctrl-A), Tools>Language>English (UK)>OK. Stop recording. Then put the macro on your toolbar (View>Toolbar>Customize Toolbars & Menus>Commands). In Categories, select macros, find your macro and drag it to a toolbar. Right-click the macro (which will show its full name), Properties, in the second drop-down menu choose Text Only. Click on the down arrow at the left next to the macro icon and choose another icon et voilĂ . Next time you open a document, just click on this icon in your toolbar. It will take, oh, about 0.5 seconds of your time. I am running Word 2004 on a Mac so some of the instructions may vary for you.
posted by TheRaven at 5:26 AM on March 14, 2009 [2 favorites]


By any chance do you have two (or more) keyboard layouts installed? I have QWERTY standard (for English) and Canadian Multilingual (for French), and because of that I can never change my default language (which is also US English, instead of Canadian English, alas).
posted by flibbertigibbet at 11:49 AM on March 14, 2009


What TheRaven said.
posted by fshgrl at 2:03 PM on March 14, 2009


Just to respond to some of the points raised so far.

Flibbertigibbet, I don't have multiple keyboard layouts installed, so that's not the issue.

TurgidDahlia, I'll take a look in the install folder on Monday and see if I can manually delete the American dictionary.

TheRaven, your suggestion isn't a good solution for me. I'll try to explain why, but I'm not especially tech savvy and may not have the right terminology. Bear with me...

Basically it seems like earlier versions of Word used to decide the language based on settings stored in the local copy of Word. The 2007 release changed that and now decides the language based on information encoded into the document itself.

All well and good. It's a feature, not a bug. Yadda, yadda, yadda...

My problem comes when somebody sends me a document written in an older version of Word*. This document will be written in British English and will have been spellchecked at their end with a British English spellchecker. However, because that information isn't encoded into the document itself, Word 2007 has to decide upon opening it what language the document is written in. Currently that decision is to aggressively default to US English.

There is an option in the language settings to stop Word from defaulting to US English in this way. There is also an option to remove US English permanently. However, clicking on these buttons doesn't actually do anything.

This is the part that I have a problem with, and it's a bug not a feature.

So while your macro suggestion is okay as a stopgap measure, over the course of a year, those 0.5 second increments will add up to more than a day spent cussing out Microsoft and clicking the macro button to make Word do something it should have been doing in the first place.


* Okay, it's also a problem when receiving files written in Word 2007 from users who don't know how to or haven't gotten around to changing their Normal template. I have no idea why language isn't automatically set during installation,. (Oh hi! You appear to be in the United Kingdom. Would you like all your documents in future to be written in the language of the country you actually live in? Y/N)
posted by the latin mouse at 6:23 AM on March 15, 2009


As far as i know all the fomatting for a Word document is contained in the last return at the end of the last paragraph. cutting and pasting everything but the last line into a new document that you have set up might fix the issue?
posted by fshgrl at 4:32 PM on March 15, 2009


« Older Finding a warm place with moun...   |  I'm currently jobless and have... Newer »
This thread is closed to new comments.


Post