Skip

only connect
October 22, 2008 7:37 AM   Subscribe

Two Macbook Pros, same model, same room, one gets a lot of bars and a strong connection via airport; the other gets just a couple of bars and a low connection.

I recently acquired a slightly-used (as in used for one day) Macbook Pro (15" -- not one of the models Apple just released).

I tried it in my apartment next to my old Macbook Pro (also 15", about a year older than my new-used one).

My older one got a good wireless signal. My newer one got a crappy wireless signal. They were both equidistant from my
Linksys router.

I thought maybe the older one was somehow interfering with the newer one, but I tried the newer one by itself, in a different location. In this new location, everyone else (some on similar macs) got a good signal. I still got a crappy one.

The previous owner told me that he had the same problem with it, and he took it into the Apple Store. They ran some kind of diagnostic program on it and insisted that nothing was wrong. The previous owner concluded that the signal was just weak where he was trying to use it. But unlike me, he didn't test it next to another computer.

I can sometimes get a good signal by turning airport off and on or by going into Network Preferences and hitting Renew DHCP Lease. But the boost in connectivity only lasts a few minutes. (This also might be my imagination. The signal waxes and wanes, so maybe I'm seeing a cause/effect where there isn't one.)

I have also been able to get a strong signal by placing my Macbook right next to the router. If I move even a few feet away, the signal degrades.

Vitals:
- Mac OS X Version 10.5.4
- Processor 2.4 GHz Intel Core 2 Duo
- Memory 4GB 667 NHz DDR2 SDRAM
posted by grumblebee to Computers & Internet (9 answers total)
 
Recently, the wireless card on my macbook has been dying, with more or less the same symptoms (I have cross-checked it with my still-functioning g3 ibook). My conclusion is that this is simply a hardware problem and there's nothing much I can do about it. The wireless card going out just doesn't correlate with anything I do software-wise at all. (One thing I haven't done is opened the thing up to check the connections to the antennae and so on, though.) My strategy so far has been to switch to using a wired connection everywhere (which, luckily, is easy for me to do), though I'm interested in seeing if anyone has anything better.

As far as I can tell it isn't possible to actually buy a replacement card yourself, though if you could, there are plenty of guides on the internet for how to do the replacement on a macbook at least, and it doesn't look much harder than replacing the hard drive.
posted by advil at 7:53 AM on October 22, 2008


It's possible that the wifi antenna (located in the screen) has a loose connection to the logicboard; the improvements you see from cycling your dhcp lease might just be coincidence or, maybe, the signal strength reporting is just averaged.

You might want to try the Apple store again but on a different day. Or call and send it in and complain of drastic signal strength swings and overall poor performance.
posted by nathan_teske at 8:15 AM on October 22, 2008


Did you try turning on "interference robustness?"
posted by chococat at 8:22 AM on October 22, 2008


The fact that you said you can sometimes get a better signal by turning the airport on and off makes it sound like the problem that Apple has had for about a year with no resolution.

You'll see many people complaining on the Apple message boards about it.

We have a new Macbook (last model) with this problem. The other machines in the house work perfectly (a mixture of macs and windows machines)

What seems to help is to keep the connection open. People have found that running iStumbler in the background keeps the connection up for some reason. That's true for us as well. With iStumbler running the machine acts like a normal machine, without it, it acts you what you see.

We plan to call Apple to complain, but have heard that others with the same exact problem haven't gotten anywhere yet.

You can get iStumbler from http://www.istumbler.net/
posted by bottlebrushtree at 9:10 AM on October 22, 2008


Did you try turning on "interference robustness?"

Where is this option?
posted by grumblebee at 9:16 AM on October 22, 2008


Where is this option?

Hmm...I have it on my Powerbook, which is still Tiger but it seems they've taken it away for Leopard, or rather built it in. In any case, I just realized you're on a linksys router and according to some comments in that thread you have to be on an Airport one for it to work, although others disagree.
Sorry.
posted by chococat at 9:36 AM on October 22, 2008


Grrr - I am having this identical problem with the Mac Mini I just bought to use as a media PC connected to the TV. My other MacBook (also Leopard) and WinXP laptop both connect to Linksys router flawlessly and from same location. I was just about to post for suggestions.
posted by MaxVonCretin at 9:45 AM on October 22, 2008


If both machines are N compatible, turn off b/g support on your AP. I would also go strict WPA2/AES (no TKIP). That helped me in the past. However, it sounds like a dying card or crappy antenna. Since you have two machines, you can swap the airport cards and see if the card itself is dodgy. Note that disassembling MacBook Pros is not for the faint of heart. The best guide I've found for this is here.

You could certain go back to the store at this point though as you can demonstrate side by side that one is not working as well. You will probably have to pay for the replacement card & labor though. It might be cheaper to live with it or buy a crummy USB dongle to replace it.
posted by chairface at 9:50 AM on October 22, 2008


MaxVonCretin - try running iStumbler and see if your connection improves. It was like night and day for us.

There are also some Unix based scripts that people are running from the terminal to do similar actions, but I found running iStumbler to be easier in the short term.
posted by bottlebrushtree at 12:18 PM on October 22, 2008


« Older I'm going to see the Night Mar...   |  I make amazing first impressio... Newer »
This thread is closed to new comments.


Post