Join 3,572 readers in helping fund MetaFilter (Hide)


Twitter / phone autolinking - what the hell?
May 30, 2014 11:10 AM   Subscribe

I just texted a friend while sitting in front of my laptop with Twitter open, and the text automatically posted to Twitter. How did this happen, and how do I stop it from ever happening again?

As I pulled my friend's number from my phone's contact list, an additional number auto-populated into the list of people the SMS was being sent to. It looked like this:

404-04

I had not seen it before and ignored it, but as soon as I sent the SMS, it was also tweeted by my account.

The equipment, if it makes a difference:

Phone: Motorola WX416

Laptop: Dell Latitude / Ubuntu 12.04 / Firefox

This seriously creeped me out, because I have never configured either device to allow this, and I never want it to happen again. Advice on how to do this - and how to disable the Web functionality of the phone altogether - will be greatly appreciated.
posted by ryanshepard to Computers & Internet (9 answers total)
 
40404 is the number you text to tweet by text in the US. It is a built in feature of twitter, and in fact how twitter started (that's where the 140 character thing comes from). I don't know why it autopopulated when you texted your friend, but that is super expected behavior for texting to that number. So just don't text to that number again, and problem solved.
posted by brainmouse at 11:15 AM on May 30 [5 favorites]


brainmouse: Thanks for clarifying that, but I'd like an explanation of how the phone and Twitter were able to establish a connection passively, and how I can prevent that from happening again.

I should clarify that I use two-factor authentication, w/SMSs sent from Twitter to this phone, so this is a likely source of the problem. Looking at Twitter settings now to see if I can disable tweet-by-text.

It has only happened this one time, when I was sitting directly in front of the laptop with Twitter open, however, as far as I'm aware.
posted by ryanshepard at 11:16 AM on May 30


You somewhere put your phone number in your Twitter account. When it received the text, it matched your username based on the number you tweeted from. Check the second link brainmouse posted
posted by I am the Walrus at 11:18 AM on May 30 [1 favorite]


Here is the Twitter support page on adding your phone number, you could reverse it to remove I guess
posted by I am the Walrus at 11:20 AM on May 30


The fact that it happened when you had your laptop open to Twitter in front of you is a red herring. Nothing to do with this. You just need to make sure you aren't letting your phone auto-populate 40404 as another recipient. You probably have that number in your contacts - just delete it. I don't know of any phones that would auto-populate a number that's not in the contacts list.
posted by trivia genius at 11:33 AM on May 30 [2 favorites]


trivia genius: Just checked the contacts list and 404-04 / Twitter does not appear. Agree the location may be a red herring, however.
posted by ryanshepard at 11:36 AM on May 30


Have you sent another test txt to that or any other number under the same circumstances to see if you can replicate the problem?
posted by elizardbits at 11:54 AM on May 30


I should clarify that I use two-factor authentication, w/SMSs sent from Twitter to this phone

Your phone helpfully remembered 404-04 (the number you received SMSs sent from Twitter). You probably accidentally touched "4" after inputting your friend's number. Your phone auto-completed it to 404-04. Next time don't ignore it and it won't be sent to Twitter.
posted by mikepop at 11:57 AM on May 30 [8 favorites]


have you tried texting that friend again to see if the 40404 gets added again?

it sounds like some kind of autocomplete.

not sure if you sync with google contacts but i know that both my android and my iphone have "remembered" contacts i deleted from the phone but not actually gone into the Google and deleted, even tho i figured the sync was two way (and it is for adding, for some reason).

anyways, that's my two cents if you sync your contacts with something. (maybe you don't know you do that, which could also be the issue.)
posted by sio42 at 1:28 PM on May 30


« Older Took two days off this week of...   |  One of my good friends is bein... Newer »

You are not logged in, either login or create an account to post comments