Slow Net Acces on One Macbook in the House
August 15, 2008 12:27 PM   Subscribe

One particular Mac on my home network is experiencing really slow internet connectivity. I have tried a lot of different stuff so far...

1) Wireless network with an Apple Airport Extreme wireless router plugged into DSL. It's set up to share the connection with DHCP clients, of which we have several:
a. The Macbook in question
b. Another Macbook which seems okay
c. 2 PCs
d. a TiVo
e. A mini set up as our HTPC

2) This laptop was fine for a long time in this location. I don't think it's a physical problem with the wireless access.

One day I set up BitTorrent port forwarding for the mini and now everything is fucked.

3) I have backed out all the changes I made in port forwarding

4) I have turned off the mini - which itself seems to work great

5) There is nothing running on the other computers - no iTunes, no bittorrent, nothing.

6) I have restarted absolutely everything in the house singly and together

7) The problem is somewhat intermittent - some days it's fine, others its incredibly slow. Restarts of the Macbook in question don't help.

8) The slowness in browsing doesn't particularly seem to be isolated to the DNS lookup stage. That happens slowly, but so does everything else.

9) I have tried various TCP/IP configs on the MacBook - DHCP, DHCP with manual address, full manual setup, DNS specified, DNS set by the router... no difference whatsoever.

10) And now for the REALLY confounding part: The PCs on the network are absolutely fine. I can browse the net with them just dandy. It's Firefox on the Macbook which is painful, and that seems to be about all.

What am I missing? I would have called the ISP by now but since some computers seem okay, I have not tried that yet.
posted by scarabic to Computers & Internet (10 answers total)
I think your airport extreme might be set for Automatic channels. Manually pick a channel and see if that makes any difference.

I had a similarly weird wifi thing going on and picking the channel myself worked wonders.
posted by schwa at 12:36 PM on August 15, 2008

How is your airport reception on the offending mac? I had this problem and got in touch with my ISP, they told me it wasn't their problem, they don't support wireless, just the cable into your house.

I played about with the channel settings on the hub and that seemed to sort it out.

How is the browsing on Safari or Opera. Can you isolate it to the software?
posted by twistedonion at 12:36 PM on August 15, 2008

Response by poster: It affects all browsers. Lemme fiddle with the channels...
posted by scarabic at 1:19 PM on August 15, 2008

Have you tried creating a new user on your Macbook and seeing if you still see the problem?
posted by wongcorgi at 1:31 PM on August 15, 2008

Response by poster: Mmm. I'll try that too.
posted by scarabic at 1:38 PM on August 15, 2008

Response by poster: Hm, channel 8 seems to be helping. I'm getting higher peaks on my network activity graph (~60K/sec) and they're consistent. Was getting a lot of up and down before. I'll keep an eye on this but keep them suggestions coming! This has been an on-again/off-again problem. Thanks
posted by scarabic at 3:15 PM on August 15, 2008

I just got a new MacBook from Apple after about a month of calls to AppleCare, one repair for a broken wireless antenna that probably wasn't, and another round of support calls and escalation.

I don't know how you're graphing your network activity (Airport utility? third-party app?) and whether you're monitoring a particular data stream or what the Mac is reporting as its overall transmit rate, but the support techs had me opt-clicking the Airport icon in the Mac's task bar, which shows transmit rate. Of two MacBooks on an 802.11g network, the good one was showing a consistent tr of 54, the bad one was bouncing up and down between 1 and 54 sporadically. We tested against an 802.11n network and got 130 on the good one and all sorts of rates between 1 and 130 on the bad one. I did all the recommended channel-changing, a profile of the other WLANs in the vicinity to see if I was having problems with a noisy neighbor, unplugging cordless phones, etc. etc.

One troubleshooting step the third support tech I spoke to had me perform was booting the bad Mac using its installation disc. That eliminated the possibility that my own configuration was the problem, since the computer was connecting to the wireless network using Apple's default configuration.

You might want to do that and take notes on what sort of transmit rate you get immediately after connecting, after a few minutes of letting the machine sit, and after sleeping/waking it. If nothing else, you'll be able to tell a support tech you performed that step, since it seems to be a routine part of whatever troubleshooting flow chart they have to use.

In my case, the machine would do fine until it was put to sleep. On waking, it would manifest its problems. Looking at "All Messages" in the console app would show some module errors . Once I could reproduce the error at will by sleeping the machine then waking it on a completely clean install of Leopard, Apple conceded that a second hardware error must be involved. For whatever reason, Apple opted to replace the entire machine rather than do the next logical thing, which would have been replacing the Airport card.

Two other things gleaned while I was trying to fix the problem myself:

1. Some people have reported that turning IPv6 support completely off in the network prefs (System Preferences / Network / Advanced / TCP-IP/ Configure IPv6 : Off) cleared up problems with sporadic wireless connections.

2. Others said that using static IP addresses and configuring their DNS settings manually instead of using DHCP helped. (System Preferences / Network / Advanced / TCP-IP/ Configure IPv4) then either manually, or using DHCP with manual address.
posted by mph at 6:01 PM on August 15, 2008

Have you tried power cycling your modem? Just kidding.

I actually had the exact same problem with one of my laptops a few months ago; turning off IPv6 (as mph suggests above) fixed it completely.
posted by LuckySeven~ at 11:31 PM on August 15, 2008

Response by poster: Interesting... more to try! This whole thing continues to be a pain in the ass... My MacBook has fared a little better since setting a channel manually, but now the mini is falling off the network constantly. Since the mini was the primary competitor for bandwidth, I can't tell what the improved performance on the MacBook actually means. I don't think the hardware in the laptop is bad... unless it WENT bad recently... it's worked quite well for over a year. Then again, I DID just pass out of warranty so it's time for weird shit to start happening, right?

The transmit rate is reported as 130 right now. The connection seems to be working all right, or at least better than before. I'm actually just using Apple's "Activity Monitor" to keep an eye on network in/out - the "network" tab has some info and a handy little graph.

I will probably go back to fully manual TCP/IP setup since diddling with that did not seem to help anything. Turning off IP6 is also an interesting option - I guess that's not needed for anything?
posted by scarabic at 10:22 AM on August 17, 2008

Response by poster: This continues to be a clusterfuck.

started getting better performance out of my MacBook by selecting channel 7 and lelaving it there, but then the Mini started falling off the wireless network every time I turned around. It was easy to put it back on the network, just selected the network by name from the dropdown. But then a few hours later it would have fallen off again. Totally frustrating.

No change from disabling IPv6.

I'm not sure that "Use interference robustness" applies and I'm leery slowing the network down by using it.

Actually at this point I'm pretty sure that it's just some kind of bullshit interference / wireless reception issue and I'm going to wire as many of the clients as I can via Ethernet.

Screw Airport. I would rail against Apple for building suck rinky-dink hardware (this is supposed to be Wireless-N hardware and my entire setup spans only 3 adjacent rooms!!!) but I didn't have much better luck with LinkSys either. I guess my house is just made of lead or something.

Thanks for the help, all!
posted by scarabic at 2:53 PM on August 21, 2008

« Older Something kinda like the Peace Corps, but not?   |   current state of competitive gaming Newer »
This thread is closed to new comments.