Why are all my images coming out pink in Photoshop?
September 2, 2004 9:05 AM   Subscribe

Every image I open in Photoshop comes out in shades of pink; and in the color picker, there's only variations of that color. [more inside]

Screenshot.

It's Photoshop 5.5 for Windows. I don't remember touching any settings to create this mess, but I'm obviously(?) wrong.

I'm as clueless as one can be when it comes to Photoshop, so keep the instructions simple! Thanks in advance for your help.
posted by kchristidis to Computers & Internet (15 answers total) 1 user marked this as a favorite
 
Quick question: have you installed any third-party plugins recently?
It may have thrown your pallettes out of whack.
Try viewing the images again, using MSPaint or some other program
to see if the color/hue discrepancy is the same.
posted by Smart Dalek at 9:24 AM on September 2, 2004


Change the color depth in your Display settings. I was getting this on PS5.5 on NT4 too, till I switched down to "High Color" mode. Not sure why, since I'd imagine "True Color" should be just that. Problem disappeared a bit later when I reinstalled Windows.
posted by brownpau at 9:32 AM on September 2, 2004


Make sure you aren't in Quick Mask Mode.
posted by studentbaker at 10:28 AM on September 2, 2004


If you're opening GIFs and such, you may have to do the following:

* Select All
* Copy
* Open a new PSD file
* Paste

I've seen this a lot when trying to edit GIFs, and it's got something to do with how PS5.5 (and maybe other versions) handles the color channels in optimized GIFs. Copying and pasting into a new comp allows Photoshop to treat the image like a 'normal' Photoshop composition, complete with all the range of colors.
posted by cyrusdogstar at 10:35 AM on September 2, 2004


Every image? Or just GIFs? If it really is every single thing, you're in need of new video drivers. Especially if the system in question is getting a little old -- quite a few video chipsets had this problem a few years back. You could, conceivably, play games with "turning down" the drawing accelleration level in Windows, but the real answer is probably going to be fresh video drivers.
posted by majick at 11:44 AM on September 2, 2004


You shouldn't have to copy and paste. Just make sure to change the mode from indexed color to RGB.
posted by hyperizer at 11:58 AM on September 2, 2004


Thanks everyone for your tips so far, but unfortunately it seems that nothing has worked.

- Smart Dalek, no plugins installed. Also, the images look fine in every other application.
- studentbaker, I checked it and I'm in "Standard Mode".
- cyrusdogstar, done it, the PSD is pink too.
- majick, this doesn't happen with GIFs only; it happens with every image type I've tried (JPG, PNG, GIF). The system is getting a bit old, but I'm able to work just fine in Paintshop Pro, and other applications; why is that?
- hyperizer, the mode is already set to "RGB".

Help, folks.
posted by kchristidis at 2:09 PM on September 2, 2004


I'm not sure if this is in 5.5 as well, but check that View->Proof Colors is unchecked.
posted by Gyan at 2:50 PM on September 2, 2004


"The system is getting a bit old, but I'm able to work just fine in Paintshop Pro, and other applications; why is that?"

Chalk it up to crappy old video drivers. I've run with driver sets that made desktop icons pink, but every app worked fine. I've had situations like yours, where only Photoshop (or things that try to use hardware gamma or overlay features) show pink artifacts.

I don't guarantee that video drivers are the root of the problem, but so far your experience is actually quite consistent with the way some old drivers I've seen have failed. Updating something to try if you can come up with more recent drivers, or perhaps see if you can scrounge up a different video card to swap in.
posted by majick at 3:01 PM on September 2, 2004


Photoshop seems real confused by your monitor profile. Either create a new one, or turn off color management entirely. (Not sure exactly what steps you must take to do that in Photoshop 5.5.)
posted by kindall at 3:03 PM on September 2, 2004


Are you absolutely certain that it's not the monitor? Bad CRT monitors often go pink/red.
posted by theora55 at 3:41 PM on September 2, 2004


No, it's obviously not the monitor -- look at the screen capture.
posted by kindall at 4:02 PM on September 2, 2004


I think kindall may have the solution, it looks to me like color management may be at fault here. Try turning that off and seeing if it helps.

I have color management turned off on my home machine, nothing I do here needs to be calibrated. Look at Preferences under the Edit menu, that should be where color management options are offered.
posted by Salmonberry at 4:26 PM on September 2, 2004


You're not alone. This thread also has someone trying to figure it out, see if the fixes brought up do anything for you.
posted by Salmonberry at 4:33 PM on September 2, 2004


Fixed! Kindall and Salmonberry were right!

I had forgotten entirely there was such a thing as a monitor profile. That, combined with the fact that I'm on a new monitor, got me certain that you were 100% correct.

After a bit of messing around with the options, I disabled the "Display Using Monitor Compensation" option in the "RGB Setup" window (screenshot), and my colors were back. Not sure if this was the most elegant way to go (don't have a clue on how to create a new profile), but it works, so I guess I'm alright.

Thank you very much everyone for your tips and the time you spent trying to help me, and a special thanks to you kindall, and Salmonberry, for finally helping me fix this problem.

I appreciate it a lot, thanks again!
posted by kchristidis at 5:59 PM on September 2, 2004


« Older Looking for an Aeron-quality chair that doesn't...   |   What's the best mp3 downloader? Newer »
This thread is closed to new comments.