problem apps ignoring proxy settings
August 8, 2008 7:11 PM   Subscribe

Why are Firefox and Transmission ignoring my proxy settings? OS X 10.5.4

I'm connecting to a server through ssh with:
ssh -D -p name@server

In System Preferences > Network > Advanced > Proxies, I have a SOCKS proxy set at localhost:. This setup successfully sends most of my traffic through the remote server, but Firefox can occasionally get around it (when watching Hulu) and Transmission connects directly to other peers (connections to the tracker go through the proxy, though). \

I've tried setting the proxy options of those applications independently, but I don't see any change in their behavior. What's letting them get around the system-level configuration, and what can I do to enforce proper behavior? I'm open to other proxy setups, this was the simplest I'd found.
posted by tylermoody to Computers & Internet (5 answers total)
 
Some of my text got eaten. The ssh line should be:
ssh -D [localport] -p [remotesshport] name@server

Then, the next line should read "...SOCKS proxy set at localhost:[localport]..."

I had originally used angle braces
posted by tylermoody at 7:13 PM on August 8, 2008


Are you aware that Firefox has its own proxy settings?
posted by kindall at 7:27 PM on August 8, 2008


What's letting them get around the system-level configuration

is the fact that this configuration is more of a guideline than an enforceable rule, and that it's not a guideline all your apps will respect (especially cross-platform things like Firefox and Transmission, which tend to have their own ways of specifying what proxy to use).

If you want to prevent things connecting to other things except via your SOCKS proxy, you need to enforce that with a firewall. However, that won't, in and of itself, force your apps to do what you want; you will still need to configure their own proxy settings if they don't respect the OS X ones.

If you've set Firefox to use a SOCKS proxy, it will use it for all web traffic (it will use it for DNS lookups as well, if you set network.proxy.socks_remote_dns to True in about:config). If Hulu appears to be going around the side of that setting, that's probably a Flash plugin issue. I don't know how to tell the Flash plugin what proxy to use.

As for Transmission: perhaps a newer version might help?
posted by flabdablet at 8:18 PM on August 8, 2008


If you want more flexibility than Firefox provides, FoxyProxy is good.
posted by staggernation at 10:13 PM on August 8, 2008


(to nip the "i upgraded to transmission, now my torrents wont start" question)

Actually, don't upgrade to transmission 1.3, it is getting kicked off of trackers left and right currently. I couldn't get any of my torrents to start working on it, so I had to revert to 1.22. No other settings changed, didn't even't reload the torrents, just replaced the app, and 1.22 started downloading files from 400+ seed torrents where 1.3/1.32 were failing. Even if they fix the problem, it will be a while for the trackers to repeal their ban on apps reporting themselves as 1.3X.

(also, the ban got started because 1.3 started acting like the <1.0 version that was not acting very traffic friendly)
posted by mrzarquon at 8:52 PM on August 10, 2008


« Older projectmyworld!?   |   fricking fantastical frozen yogurt Newer »
This thread is closed to new comments.